sssd 1.8.4-1ubuntu1 source package in Ubuntu

Changelog

sssd (1.8.4-1ubuntu1) quantal; urgency=low

  * Merge from Debian unstable, remaining changes:
    - control, rules: Drop libsemanage-dev from build-depends, it's not
      in main. Configure --with-semanage=no.

sssd (1.8.4-1) unstable; urgency=low

  * New upstream bugfix release 1.8.2.
    - Several fixes to case-insensitive domain functions
    - Fix for GSSAPI binds when the keytab contains unrelated
      principals
    - Fixed several segfaults
    - Workarounds added for LDAP servers with unreadable RootDSE
    - SSH knownhostproxy will no longer enter an infinite loop
      preventing login
    - The provided SYSV init script now starts SSSD earlier at startup
      and stops it later during shutdown
    - Assorted minor fixes for issues discovered by static analysis
      tools
  * New upstream bugfix release 1.8.3.
    - Numerous manpage and translation updates
    - LDAP: Handle situations where the RootDSE isn't available anonymously
    - LDAP: Fix regression for users using non-standard LDAP attributes for
      user information
  * New upstream bugfix release 1.8.4. (LP: #981125, #985031)
    - Fix a bug causing AD servers not to fail over properly when the KDC
      on the primary server is down
    - Fix an endianness bug on big-endian systems when looking up services
    - Fix a segfault dealing with nested groups (LP: #981125)
    - Make the nowait cache updates work for netgroups
    - Fix a regression that broke domains with use_fully_qualified_names = True
      (LP: #985031)
  * control: Move the dependency of libsasl2-modules-gssapi-mit to
    Recommends.
  * control: sssd works with Heimdal gssapi modules too, add
    libsasl2-modules-gssapi-mit as an option for the Recommends.
    (LP: #966146)
  * libpam-sss.pam-auth-update:
    - Drop the dependency to 128, since pam_sss should always be below
      pam_unix. (LP: #957486)
    - Drop 'use_authtok' from the password stack, since it only works when
      pam_cracklib is installed. This will allow password changes on the
      default install.
  * sssd.postrm: Try to remove /etc/sssd only if it exists.
    (Closes: #666226)
  * Add disabled by default Apparmor profile (LP: #933342)
    - debian/sssd.upstart.in: load the profile during pre-start
    - add debian/apparmor-profile, install to /etc/apparmor.d
    - debian/rules: use dh_apparmor to install profile before sssd is
      restarted
    - debian/control: sssd Suggests apparmor (>= 2.3)
    - debian/control: Add dh-apparmor to build-depends
    - debian/sssd.preinst: disable profile on clean install or upgrades
      from earlier than when we shipped the profile
  * rules: Mangle the date stamp on pam_sss.8 so that the compressed file is
    identical across all archs. (Closes: #670019)
  * control: Add build-depends on libnl-dev to enable Netlink support.
  * control: Add build-depends on libkeyutil-dev to enable support for
    kernel keyring manipulation.
  * sssd.logrotate: Rotate logs weekly, keep four previous rotations.
    (Closes: #672984)
  * sssd.upstart.in: Delete an invisible control character from the pre-start
    script. (LP: #1003845)
 -- Timo Aaltonen <email address hidden>   Mon, 04 Jun 2012 09:51:20 +0300

Upload details

Uploaded by:
Timo Aaltonen on 2012-06-04
Uploaded to:
Quantal
Original maintainer:
Ubuntu Core Developers
Architectures:
any
Section:
utils
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
sssd_1.8.4.orig.tar.gz 2.1 MiB d20845928c91fd66fadc404967089b21b6b64801b1288c789812be51521476a2
sssd_1.8.4-1ubuntu1.diff.gz 25.7 KiB 3ce2cb5939745668ba7d62c300f2869dcefafb0fe5bd78dee762c735464d0da4
sssd_1.8.4-1ubuntu1.dsc 2.7 KiB 7305c57610178e7cd20d3445dc466313ddd6d130513b35427eaf0fd0a89bc3b8

Available diffs

View changes file

Binary packages built by this source

libipa-hbac-dev: No summary available for libipa-hbac-dev in ubuntu quantal.

No description available for libipa-hbac-dev in ubuntu quantal.

libipa-hbac0: No summary available for libipa-hbac0 in ubuntu quantal.

No description available for libipa-hbac0 in ubuntu quantal.

libnss-sss: No summary available for libnss-sss in ubuntu quantal.

No description available for libnss-sss in ubuntu quantal.

libpam-sss: No summary available for libpam-sss in ubuntu quantal.

No description available for libpam-sss in ubuntu quantal.

libsss-sudo-dev: No summary available for libsss-sudo-dev in ubuntu quantal.

No description available for libsss-sudo-dev in ubuntu quantal.

libsss-sudo0: No summary available for libsss-sudo0 in ubuntu quantal.

No description available for libsss-sudo0 in ubuntu quantal.

python-libipa-hbac: No summary available for python-libipa-hbac in ubuntu quantal.

No description available for python-libipa-hbac in ubuntu quantal.

python-sss: No summary available for python-sss in ubuntu quantal.

No description available for python-sss in ubuntu quantal.

sssd: No summary available for sssd in ubuntu quantal.

No description available for sssd in ubuntu quantal.

sssd-tools: No summary available for sssd-tools in ubuntu quantal.

No description available for sssd-tools in ubuntu quantal.