Change log for unalz package in Ubuntu

117 of 17 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-05-13
Deleted in groovy-proposed (Reason: moved to Release)
unalz (0.65-8) unstable; urgency=medium

  * debian/control: Use debhelper compat level 13
  * debian/control: Add Rules-Requires-Root: no
  * debian/{rules,unalz.manpages}: Stop overriding dh_installman and use
    debian/unalz.manpages
  * debian/control: Bump Standards-Version to 4.5.0
  * debian/salsa-ci.yml: Add Salsa CI config
  * debian/rules: Pass the hardning CPPFLAGS properly; the upstream
    makefile only uses CFLAGS so we use CPPFLAGS in CFLAGS.

 -- Changwoo Ryu <email address hidden>  Wed, 13 May 2020 01:24:05 +0900
Superseded in groovy-release on 2020-05-13
Published in focal-release on 2020-03-23
Deleted in focal-proposed (Reason: moved to Release)
unalz (0.65-7build1) focal; urgency=medium

  * No-change rebuild for libgcc-s1 package name change.

 -- Matthias Klose <email address hidden>  Sun, 22 Mar 2020 17:01:36 +0100

Available diffs

Superseded in focal-release on 2020-03-23
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-12-29 (Reason: moved to release)
unalz (0.65-7) unstable; urgency=medium

  [ Helmut Grohne ]
  * Fix FTCBFS: Provide a c++ compiler in $(CPP). (Closes: #901348)

  [ Changwoo Ryu ]
  * Use debhelper 11
  * Use HTTPS for the copyright format URI
  * Standards-Version: 4.1.4

 -- Changwoo Ryu <email address hidden>  Sat, 16 Jun 2018 13:17:28 +0900

Available diffs

Superseded in cosmic-release on 2018-06-16
Published in bionic-release on 2017-12-27
Deleted in bionic-proposed (Reason: moved to release)
unalz (0.65-6) unstable; urgency=medium

  * debian/{control,copyright,watch}: Correct the upstream URL
  * debian/control:
    - l10n-korean team is set as the Maintainer
    - Update Vcs-* to the salsa.debian.org repository
    - Standards-Version: 4.1.2
  * debian/{compat,control}: Use debhelper 10
  * patch: Fix file offset overflow on incomplete files (Closes: #871722)

 -- Changwoo Ryu <email address hidden>  Wed, 27 Dec 2017 17:38:44 +0900

Available diffs

Superseded in bionic-release on 2017-12-27
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2020-07-10 (Reason: moved to release)
unalz (0.65-5) unstable; urgency=medium

  * Correct pipe mode (Closes: #775233)
  * Correct crash; check filename length record (Closes: #775237)
  * Standards-Version: 3.9.8
  * debian/control: Use secure URLs for Vcs-*
  * debian/copyright: Correct DEP-5 format
  * debian/rules: Enable hardening=+all

 -- Changwoo Ryu <email address hidden>  Sun, 22 Jan 2017 19:49:15 +0900

Available diffs

Superseded in zesty-release on 2017-01-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-01-27
Deleted in trusty-proposed (Reason: moved to release)
unalz (0.65-4) unstable; urgency=low


  * Standards-Version: 3.9.5
  * Remove unneeded quilt build dependency
  * Correct debian/copyright format
  * Add tags on patches
  * Clean up build rule (Closes: #736460)
  * Improve package description and update note on supported formats.
  * debian/control: Correct Vcs-* fields
  * Add git-buildpackage config

 -- Changwoo Ryu <email address hidden>  Mon, 27 Jan 2014 03:16:36 +0900

Available diffs

Superseded in trusty-release on 2014-01-27
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
unalz (0.65-3) unstable; urgency=low


  * Build-Depends on zlib1g-dev version >= 1.2.7 (Closes: #672400)
  * debian/copyright: rewrite using the copyright format 1.0
  * Use debhelper 9.

 -- Changwoo Ryu <email address hidden>  Sat, 12 May 2012 20:41:32 +0900

Available diffs

Superseded in quantal-release on 2012-05-23
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
unalz (0.65-1) unstable; urgency=low

  * New Upstream Version
  * Document about zlib and libbz2 link in copyright and in README.Debian.
  * Document the details of the supported ALZ formats in README.Debian.
  * Standards-Version: 3.8.2
  * Do not overwrite CDBS supplied build flags.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  06 Nov 2009 10:39:04 +0000

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
unalz (0.64-1) unstable; urgency=low

  * New Upstream Version
  * Standards-Version: 3.8.0.
  * Switch to CDBS.
  * Use system installed libbz2 instead of the embedded one.
  * Depends on ${misc:Depends} for debhelper.
  * Updated the copyright year and the download URL in the copyright file.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 12:15:05 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
unalz (0.62-1) unstable; urgency=low

  * New upstream release.
  * Switched to docbook XML for the man page. Corrected the command
    synopsis.
  * Updated the upstream mail address.

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
unalz (0.55-4) unstable; urgency=low

  * QA upload.
  * UnAlz.h: Add missing includes.  Thanks to Martin Michlmayr for the
    patch.  Closes: #417746.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 Apr 2007 13:26:57 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
unalz (0.55-3) unstable; urgency=low

  * QA upload.
  * Fix build failure on GNU/kFreeBSD and Hurd.  Thanks to Petr Salinger
    for the patch.  Closes: #401514.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  20 Dec 2006 13:08:12 +0000
Superseded in feisty-release on 2006-12-20
unalz (0.55-2) unstable; urgency=low

  * QA upload.
  * Enable iconv support.  Closes: #378833.
  * Conforms to Standards version 3.7.2.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  08 Nov 2006 19:59:25 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
unalz (0.55-1) unstable; urgency=low

  * QA upload.
  * New upstream release.
    - Fixes directory traversal vulnerability [CVE-2006-0950].
      Closes: #356832. 
  * Package is orphaned (#362995); set maintainer to Debian QA Group.
  * Acknowledge NMU.  Closes: #283049.
  * Link against zlib1g instead of a private copy.  (The same is not
    possible for libbz2, parts of which were modified.)
  * Switch to debhelper 5.
  * debian/README.Debian: Redundant; remove.
  * debian/unalz.xml: debian/unalz.sgml is more recent; remove.
  * debian/copyright: Add license for bzip2 and zlib sources.
  * debian/rules: Remove generated man page on clean.
  * debian/watch: Add.
  * Conforms to Standards version 3.7.0.

 -- Martin Pitt <email address hidden>   Mon,  08 May 2006 11:40:57 +0100
Superseded in dapper-release on 2006-05-08
Superseded in dapper-release on 2006-02-03
unalz (0.52-1) unstable; urgency=low


  * New Upstream Update. 
  * Corrected encryption part.
  * Corrected make file for linux system.
  * Added pipe mode
  * Added setlocale function to main function.

 -- Yooseong Yang <email address hidden>  Wed, 28 Sep 2005 09:27:48 +0900
Obsolete in breezy-release on 2008-03-25
unalz (0.30build1) breezy; urgency=low


  * Rebuild for new C++ ABI

 -- Matthias Klose <email address hidden>  Tue, 28 Jun 2005 09:09:22 +0000
Obsolete in hoary-release on 2008-03-19
unalz (0.30) unstable; urgency=low


  * New Upstream Update. 

 -- Yooseong Yang <email address hidden>  Wed, 29 Dec 2004 15:13:48 +0900
117 of 17 results