virt-manager 1:1.0.1-4ubuntu1 source package in Ubuntu

Changelog

virt-manager (1:1.0.1-4ubuntu1) vivid; urgency=low

  [ Chris J Arges ]
  * Merge from Debian unstable.  Remaining changes:
    - debian/control: Depend on gir1.2-appindicator3-0.1 for appindicator
      support.
    - debian/control: Switch gir1.2-vte-2.90 to 2.91.
    - debian/control: Add lsb-release to BuildDepends so we can detect
      whether we're running on Ubuntu or Debian.
    - debian/rules: Set qemu user to libvirt-qemu so appropriate
      permissions get set.
    - debian/rules: Set the preferred distro so we appear first in the
      list.
    - d/p/0001-serialcon-Drop-use-of-yet-more-removed-API.patch,
    - d/p/0001-serialcon-Remove-some-redundant-VTE-API-calls.patch: Cherry-pick
      two patches from upstream to stop using API removed in VTE 2.91.
    - d/p/dont-force-keyboard-grabs.patch: don't force keyboarb grab before
      widget is realized
    - d/p/prevent-access-to-deleted-objects.patch: prevent access to deleted
      objects
    - d/p/more_helpful_error_message.patch: explain to the user why connecting
      to qemu:///system failed and how to fix it.
    - d/p/use_ubuntu_package_names.patch: Suggest installing the packages that
      are actually available in Ubuntu.
    - d/p/uefi_support.patch: ugly hack to add a UEFI firmware option.
    - d/p/virtinst/9004_ubuntu_fix_tree_support.patch: Fix tree detection for
      all ISO/HTTP source, to not longer fail with cobbler/koan.
    - d/p/virtinst/9005_ubuntu_releases.patch: add Trusty, updated support
      status, and switch back to cirrus by default to get a reasonable screen
      size during installation.
    - d/p/virtinst/9006_fix_path_to_qemu-dm.patch: drop the full path from
      qemu-dm as already done for hvmloader and pygrub. The Xen tools will
      handle this and add the missing path.
    - d/p/add_qemu_binaries.patch: add the actual binary name from the qemu
      packages so default hypervisor detection works properly on first run.
    - d/p/fix_changing_graphics_type.patch: fix changing the graphics type in
      the details dialog.
    - d/p/hook_into_domain_balloon_event.patch: properly hook into hotplug
      events so memory size gets updated.
    - d/p/fix_showing_vcpus.patch: display the right number of vcpus in the
      customize dialog.
    - d/p/fix_whitespace_in_storage_name.patch: Fix using storage when the
      directory name contains whitespace
    - d/p/mark-libvirt-lxc: Clearly mark the LXC connections as being
      libvirt-lxc, to avoid confusion due to differing features and
      configurations.
    - d/p/leave-mnemonics-alone-on-focus-change.patch: Leave
      gtk-enable-mnemonics setting alone under Unity when windows change focus.
    - Refreshed:
      - d/p/details-Fix-changing-graphics-type-bz-1083903.patch
      - d/p/fix-removable-drive-support.patch
      - d/p/Make-SpiceClientGtk-optional.patch
  * Bump standards version to 3.9.6.
  * add data/icons/32x32/actions/vm_clone_wizard.png to match rest of UI. This
    was adapted from Debian bug (Closes: #763698)

virt-manager (1:1.0.1-4) unstable; urgency=medium

  * [8b6f491] Drop Gtk2 only python-spice-client-gtk
  * [1006788] Make SpiceClientGtk optional (Closes: #763623)
  * [7da9c44] Recommend livbirt-daemon-system (Closes: #768000)

virt-manager (1:1.0.1-3) unstable; urgency=medium

  * [da12f60] details: Fix changing graphics type (bz 1083903)
    (Closes: #764880)
  * [d81fd3c] Don't enable usb redirection into the guest by default
    (Closes: #764894)

virt-manager (1:1.0.1-2.1) unstable; urgency=medium

  * Non-maintainer upload, with permission from maintainer.
  * fix-removable-drive-support.patch: new patch, cherry-picked from upstream
    (Closes: #764508).

virt-manager (1:1.0.1-2) unstable; urgency=medium

  * Upload to unstable
  * [3fb8054] Drop long unused quilt from build-deps
  * [27878eb] Move GConf values to GSettings (Closes: #740047)

virt-manager (1:1.0.1-1) experimental; urgency=medium

  * [f36ee97] Version gtk-3.0 build-dep.
    Thanks to Paul Wise (Closes: #740048)
  * [b82bf86] New upstream version 1.0.1
    Closes: #758470
  * [52b2fdd] Recommend libvirt-daemon instead of libvirt-bin. This pulls in
    fewer dependencies and is sufficient to run qemu/kvm instances as
    non-root.
 -- Chris J Arges <email address hidden>   Wed, 21 Jan 2015 14:23:49 -0600

Upload details

Uploaded by:
Chris J Arges on 2015-01-21
Uploaded to:
Vivid
Original maintainer:
Ubuntu Developers
Architectures:
all
Section:
admin
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Vivid: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
virt-manager_1.0.1.orig.tar.gz 2.4 MiB 08e3740ae07292bc3f68160a43897fccb90d7bc14ffb133c8ad685c9d44444d8
virt-manager_1.0.1-4ubuntu1.debian.tar.gz 36.8 KiB 4b949499bf212af3c4ed0c7e7727f869be7eb60e19cbde3bc3be85a860600132
virt-manager_1.0.1-4ubuntu1.dsc 1.8 KiB 4ceb139f7bb4aa1cdba0693e19eb425a1f16ffd6d49c5d15bd2b498ba0cb624b

View changes file

Binary packages built by this source

virt-manager: No summary available for virt-manager in ubuntu vivid.

No description available for virt-manager in ubuntu vivid.

virtinst: No summary available for virtinst in ubuntu vivid.

No description available for virtinst in ubuntu vivid.