vmware-package 0.22 source package in Ubuntu

Changelog

vmware-package (0.22) unstable; urgency=low

  * Convert most of vmware-package's Recommends to Depends in light of
    stricter checking by dpkg-shlibdeps(1).
  * Add Depends: libstdc++5 [i386]; closes: #462784.
  * Fully qualify path to execstack; closes: #471544.
  * Add Conflicts: vmware-bin to vmware-server.
  * Add Conflicts: vmware-server to vmware-bin.
  * Invoke m-a with 'build' instead of 'auto-build'.
  * Update to VMware Workstation 6.0.3-80004.
  * Update to VMware Player 2.0.3-80004.
  * Update to VMware Server 1.0.5-80187.
  * These updates include an updated private copy of openssl0.9.7, which
    resolves the following vulnerabilities: CVE-2006-2940, CVE-2006-2937,
    CVE-2006-4343.
  * VMware kernel modules are now buildable unpatched on Linux 2.6.24.

vmware-package (0.21) unstable; urgency=low

  * Update to any-any 115.
  * Loosen regex for vmware-any-any.
  * Fix conditional for invoking multi_file_err(); closes: #462620.

vmware-package (0.20) unstable; urgency=low

  * Support building debs from multiple tarballs.
  * Ship a changelog and copyright file in each generated package.
  * Depends: prelink and disable executable stacks in VMware's shipped
    libraries.
  * Relax inetd requirements for vmware-server to openbsd-inetd |
    inet-superserver; closes: #448691.
  * Remove init.d links on uninstallation of vmware-server and
    vmware-server-mui; closes: #448163.
  * Install vmware-server-console icon to the correct location and update
    .desktop file; closes: #448004.
  * Remove Recommends: libssl0.9.7, since this package is no longer available
    in sid; closes: #447815.

vmware-package (0.19) unstable; urgency=low

  * Update to VMware Workstation 6.0.2-59824.
  * Update to VMware Player 2.0.2-59824.
  * Correct unknown version error message; closes: #447777.

vmware-package (0.18) unstable; urgency=low

  * Fix broken -K option.

vmware-package (0.17) unstable; urgency=low

  * Update to any-any 114.
  * Add vmnet1.hostonly* values to /etc/vmware/config in vmware-server;
    closes: #446116.
  * Add a -K / --kvers-list command line option which is passed to
    module-assistant when building modules; closes: #447134.
  * Add example usage to README.Debian; closes: #444400.
  * Fall back on $EMAIL if $DEBEMAIL is not set.

vmware-package (0.16) unstable; urgency=low

  * Put the vmware-package Debian version number in the generated packages'
    changelogs.
  * Embed the vmware-package version number in the version number of the
    generated packages.  This may break automatic upgrades depending on the
    localver component of previously installed packages.
  * Update to VMware Workstation 6.0.1-55017.
  * Update to VMware Player 2.0.1-55017.
  * Update to VMware Server 1.0.4-56528.
  * These updates resolve the following vulnerabilities: CVE-2007-0061,
    CVE-2007-0062, CVE-2007-0063, CVE-2007-4059, CVE-2007-4155, CVE-2007-4496,
    CVE-2007-4497.
  * VMware kernel modules are now buildable on Linux 2.6.22.

vmware-package (0.15) unstable; urgency=low

  * Install fixed i386/amd64 specific vmware-authd pam.d configs;
    closes: #440871.
  * Convert to an Arch: i386 amd64 package since these are the only
    architectures supported by VMware, and cross-building will likely never be
    feasible.
  * Recommend a significant number of run-time dependencies in generated
    VMware packages in vmware-package's control file.
  * Introduce a vmware-modules-_KVERS_ virtual package in the various modules
    packages to ensure mutual conflicts.

vmware-package (0.14) unstable; urgency=low

  * Only recommend ia32-libs; add build-deps on ia32-libs [amd64] in the
    generated package control files; closes: #440882.

vmware-package (0.13) unstable; urgency=low

  * Depend on ia32-libs on amd64 so that generated packages will pick up the
    shlibdeps; closes: #440863.
  * Use shipped rather than Debian PAM libraries on amd64; closes: #440871.
  * Prevent shlibs files from entering generated packages.

vmware-package (0.12) unstable; urgency=low

  * Unconditionally force the "2.6.x build system" by passing VM_KBUILD=26 to
    the VMware kernel module Makefiles; closes: #437401.

vmware-package (0.11) unstable; urgency=low

  * Explicitly depend on vmware-lib in the generated workstation and player
    packages; closes: #435756.
  * Update to any-any 113.

vmware-package (0.10) unstable; urgency=low

  * Inspect all ELF executables shipped in the generated packages for shared
    library dependencies; closes: #433882.
  * Validate the Maintainer field; closes: #433879.
  * Document "not_configured" behavior in README.Debian.
  * Attempt to break idiotic behavior in the shipped VMware init script:
    - failing to run if a "not_configured" file is present
    - invoking insmod .../$module.o instead of modprobe $module
  * Update to any-any 112.

vmware-package (0.9) unstable; urgency=low

  * Depend on bzip2.
  * Make vmware-package depend on libx11-6, libxext6, libxi6, libxinerama1,
    and make these build-dependencies of vmware-player, vmware-server-console,
    and vmware-workstation.
  * Recommend ia32-libs | libc6-i686 in vmware-bin and vmware-server.
  * Add a --distribution option to set the distribution in the .changes file
    of generated packages; closes: #433020.
  * Quiet the gnome_icon.sh script during the make-vmpkg build process.

vmware-package (0.8) unstable; urgency=low

  * Add a dry run feature to make-vmpkg.
  * Perform version detection even when -p is specified; closes: #431733.
  * Copy application icons to the appropriate locations in generated
    vmware-common packages; closes: #431932.

vmware-package (0.7) unstable; urgency=low

  * Attempt to use DEBFULLNAME and DEBEMAIL for the Maintainer field of
    generated packages; closes: #431733.

vmware-package (0.6) unstable; urgency=low

  * Update to any-any 110 kernel modules.
  * Generated kernel modules are now placed in Section: non-free/misc.
  * Build kernel modules when invoked as root and rootcmd is fakeroot.

vmware-package (0.5) unstable; urgency=low

  * Add myself to Uploaders and change the Maintainer field to the alioth
    vmware-package mailing list.
  * Nearly everything has been rewritten.
  * Support VMware Workstation 6.0.0-45731.
  * Support VMware Player 2.0.0-45731.
  * Support VMware Server 1.0.3-44356.
  * Support VMware Server Console 1.0.3-44356.
  * Support VMware Server MUI 1.0.3-44356.
  * Support any-any 109 kernel modules.

vmware-package (0.4) experimental; urgency=low

  * adapt to vmware-player-1.0.3

vmware-package (0.3) experimental; urgency=low

  * adapt to vmware-any-any-108.
  * fix man page file name for make-kpkg
  * add man page for vmware-package.conf
  * Allow vmware-any-any package version to be overridden from
    environment

vmware-package (0.2) experimental; urgency=low

  * adapt to vmware-any-any 105. Closes: #401072

vmware-package (0.1) experimental; urgency=low

  * call debuild with -uc -us
  * Fix typo and wording issues in docs. Thanks to Mika Prokop.
  * use dpkg-buildpackage instead of debuild. Fix Dependencies. Again,
    thanks to Mika Prokop.
  * make-vmpkg patch: Help, more tests. Again, thanks to Mika.
  * add vmware-package.conf for md5sums and more. Thanks, Mika.
  * fix minor number in device creation code. duh.
  * Add some helping echos to make-vmpkg. Thanks to Christoph Biedl.

vmware-package (0.0) experimental; urgency=low

  * Initial packaging (Closes: #394138)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  26 Jun 2008 09:53:37 +0100

Upload details

Uploaded by:
Ubuntu Archive Auto-Sync on 2008-06-26
Uploaded to:
Intrepid
Original maintainer:
Debian vmware-package team
Architectures:
i386 amd64
Section:
misc
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Intrepid: [FULLYBUILT] amd64 [FULLYBUILT] i386

Downloads

File Size SHA-256 Checksum
vmware-package_0.22.tar.gz 23.5 KiB 67429eac64a1d4f170235b167f490cc34f0428ec81b6c1982ab5d38c9c80a3b9
vmware-package_0.22.dsc 654 bytes f363ba3c14ae8e6ad176e9fdcaff814f52c5d8ac3133985fb7d670317bcfd753

View changes file

Binary packages built by this source

vmware-package: No summary available for vmware-package in ubuntu karmic.

No description available for vmware-package in ubuntu karmic.