Ubuntu

“rails” 2.0.2-1ubuntu1 source package in The Hardy Heron

Publishing history

2.0.2-1ubuntu1
PUBLISHED: Hardy pocket Release in component universe and section web
  • Published on 2008-03-06

Builds

Changelog

rails (2.0.2-1ubuntu1) hardy; urgency=low

  * Post Feature Freeze upload (LP: #198160)
  * Change maintainer to MOTU
  * Add 20_fix_cp.dpatch to fix copy in doc package build and avoid FTBFS
    - Patch thanks to Michael Milligan

rails (2.0.2-1) unstable; urgency=low

  * New upstream release
    + SQLite3 is now the default database, instead of MySQL
    + [config/environments/production.rb] production mode will now
    longer cache templates meaning they will load A LOT faster but for
    any changes to appear, one will have to reload the entire
    application.

rails (2.0.1-2) unstable; urgency=low

  * Added Pre-Depends on dpkg (>= 1.10.24) as a workaround to Debian
    install scripts do not seem to be updated since beginning
    of century. Can't upload bzip2 deb compressed deb without adding
    this superfluous depend.
  * Move libmocha-ruby1.8 from Depends to Recommends as it is only
    needed for unit testing.
  * Give in and depend on libruby1.8-extras. We need this to satisfy
    dependencies on OpenSSL and the ever so popular rubygems, though
    rails will continue to work if rubygems 'gem' fails.

rails (2.0.1-1) unstable; urgency=low

  * New upstream release (closes: #454909)
     + ActionWebservice is no more - rolled into ActionResource
     + SOAP support removed
  * Use bzip2 to compress the deb, instead of the default (gzip)
  * Update Standards version to 3.7.3 - no changes needed
  * Added a lot more exceptions to lintian checks - rails does not
    need all script executable.

 -- Scott Kitterman <email address hidden>   Wed, 05 Mar 2008 21:05:42 -0500