libselinux1 binary package in Ubuntu Xenial armhf

 This package provides the shared libraries for Security-enhanced
 Linux that provides interfaces (e.g. library functions for the
 SELinux kernel APIs like getcon(), other support functions like
 getseuserbyname()) to SELinux-aware applications. Security-enhanced
 Linux is a patch of the Linux kernel and a number of utilities with
 enhanced security functionality designed to add mandatory access
 controls to Linux. The Security-enhanced Linux kernel contains new
 architectural components originally developed to improve the security
 of the Flask operating system. These architectural components provide
 general support for the enforcement of many kinds of mandatory access
 control policies, including those based on the concepts of Type
 Enforcement, Role-based Access Control, and Multi-level Security.
 .
 libselinux1 provides an API for SELinux applications to get and set
 process and file security contexts and to obtain security policy
 decisions. Required for any applications that use the SELinux
 API. libselinux may use the shared libsepol to manipulate the binary
 policy if necessary (e.g. to downgrade the policy format to an older
 version supported by the kernel) when loading policy.

Publishing history

Date Status Target Pocket Component Section Priority Phased updates Version
  2016-03-17 12:38:52 UTC Published Ubuntu Xenial armhf release main libs Required 2.4-3build2
  • Published on 2016-03-17
  • Copied from ubuntu xenial-proposed armhf in Primary Archive for Ubuntu
  Deleted Ubuntu Xenial armhf proposed main libs Required 2.4-3build2
  • Removal requested on 2016-03-17.
  • Deleted on 2016-03-17 by Ubuntu Archive Robot

    moved to release

  • Published on 2016-03-16
  2016-03-17 12:44:52 UTC Superseded Ubuntu Xenial armhf release main libs Required 2.4-3build1
  • Removed from disk on 2016-03-18.
  • Removal requested on 2016-03-18.
  • Superseded on 2016-03-17 by armhf build of libselinux 2.4-3build2 in ubuntu xenial PROPOSED
  • Published on 2016-01-20
  • Copied from ubuntu xenial-proposed armhf in Primary Archive for Ubuntu
  2016-03-18 18:10:10 UTC Deleted Ubuntu Xenial armhf proposed main libs Required 2.4-3build1
  • Removed from disk on 2016-03-18.
  • Removal requested on 2016-01-20.
  • Deleted on 2016-01-20 by Ubuntu Archive Robot

    moved to release

  • Published on 2016-01-19
  2016-01-20 10:29:22 UTC Superseded Ubuntu Xenial armhf release main libs Required 2.4-3
  • Removed from disk on 2016-01-21.
  • Removal requested on 2016-01-21.
  • Superseded on 2016-01-20 by armhf build of libselinux 2.4-3build1 in ubuntu xenial PROPOSED
  • Published on 2015-12-08
  • Copied from ubuntu xenial-proposed armhf in Primary Archive for Ubuntu
  2016-01-21 12:10:10 UTC Deleted Ubuntu Xenial armhf proposed main libs Required 2.4-3
  • Removed from disk on 2016-01-21.
  • Removal requested on 2015-12-08.
  • Deleted on 2015-12-08 by Ubuntu Archive Robot

    moved to release

  • Published on 2015-11-19
  2015-12-08 08:36:27 UTC Superseded Ubuntu Xenial armhf release main libs Required 2.3-2build1
  • Removed from disk on 2018-01-22.
  • Removal requested on 2015-12-09.
  • Superseded on 2015-12-08 by armhf build of libselinux 2.4-3 in ubuntu xenial PROPOSED
  • Published on 2015-10-22
  • Copied from ubuntu wily-proposed armhf in Primary Archive for Ubuntu