Impossible to do pairing in Kubuntu

Bug #56651 reported by David Leadbeater on 2006-08-17
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
Daniel Holbach

Bug Description

Kubuntu can not use bluez-passkey-gnome and using /usr/lib/kdebluetooth/kbluepin does not work.

Adam Israel (aisrael) wrote :

Confirmed on edgy. I had to grab the source package and make to get hcid/passkey-agent. This was required to get the passkey from the bluetooth device (Apple Mighty Mouse) via the new d-bus interface.

Changed in bluez-utils:
status: Unconfirmed → Confirmed
Jorge Castro (jorge) wrote :

Also confirming, got my new apple bluetooth mighty mouse working by building passkey-agent.

Changed in bluez-utils:
status: Confirmed → Unconfirmed
status: Unconfirmed → Confirmed
Matti Lindell (mlind) wrote :

I stumbled on this as well.. Hopefully this gets some attention soon.

Changed in bluez-utils:
status: Unknown → Fix Released
Michał Sawicz (saviq) wrote :

Same here.

Johan Christiansen (johandc) wrote :

Could anyone write a small hint/guide on how i get passkey-agent installed? And why isn't this thing fixed yet when there are a fix in Debian?

Matti Lindell (mlind) wrote :

This bug seems to be the reason why I can't pair my mobile. Could someone raise importance of this bug a bit?

Lubos Kolouch (lubos-kolouch) wrote :

I have same problem - cannot pair my MDA Vario...
hope my little post helps to raise the importance a bit :)

Arthur Peters (amp) wrote :

I have the same problem.

I ran:

passkey-agent 0000 [ID of device]

and pair with PIN 0000 worked.

Lubos Kolouch (lubos-kolouch) wrote :

How can you run this if the passkey-agent binary is missing?

E-B (ebelt9hf) wrote :

Is it a solution to take the old passkey binary (from the dapper Package?)

Matti Lindell (mlind) wrote :

Solution should be to sync this packge or at least the missing passkey-agent.

fimbulvetr (fimbulvetr) wrote :

I too am experiencing this problem. I think the priority should be raised so it can be fixed for edgy. Bluetooth is a very common technology and it's adoption rate is accelerating. To have support missing from edgy is a big problem.

fimbulvetr (fimbulvetr) wrote :

Compile passkey-agent like this:

sudo apt-get install build-essential cdbs libdbus-glib-1-dev debhelper

sudo apt-get source bluez-utils

cd bluez-utils-3.1/

sudo ./debian/rules binary

(This builds a deb in ../)

Install that, or cp ./hcid/passkey-agent /usr/bin/ or run ./hcid/passkey-agent

Matti Lindell (mlind) wrote :

Dan V, you'll loose Ubuntu changes which are not in Debian that way.

I think we need a UVF exception for this now. I'm not sure who should be subscribed here, but since bluez-utils source is in main I'll ping Release Team.

monsieurgonzalez (luisghm) wrote :

I can confirm the same problem here (fresh Edgy Beta Kubuntu install). All attempts to pair my Headset result in "pairing denied" messages.

Artem Abramyan (cvacubo) wrote :

I can confirm too.

In Kubuntu Edgy (KDE 3.5.4) my Nokia 6681 (and much more other devices) doesnt detect bluetooth on my Dell D410 anymore. KDE not find bluetooth devices.

If I use hcitool scan then devices are then in KDE they too appear, but authorization does not work.

On phone it is asked PIN, but in KDE is not present (does not appear kbluepin).

I can't paired bluetooth device.

Matt Zimmerman (mdz) wrote :

As with bug 62255, this issue isn't ready for the release team yet

Changed in bluez-utils:
assignee: nobody → bluetooth
Pulp (pulp-oxlx) wrote :

Problem is solved by installing the bluez-utils from debian, this file :

as you can notice, it's the new version, it solved agent registration and phone access worked fine.
Default password is 12345 and is stored in /etc/bluetooth/passkeys/default

Good luck.

Il giorno ven, 06/10/2006 alle 04.58 +0000, Pulp ha scritto:
> Problem is solved by installing the bluez-utils from debian, this file :
> as you can notice, it's the new version, it solved agent registration and phone access worked fine.
> Default password is 12345 and is stored in /etc/bluetooth/passkeys/default
> Good luck.


debian doesn't ship the passkey-agent binary, we should really update
our version of the bluez-suite

have you got the kdebluetooth gui tools working after installing this package?

Andreas Daab (andreas-daab) wrote :

After running passkey-agent, e.g. with

passkey-agent --default 1234

kdebluetooth file transfer works without any problem.

Changed in bluez-utils:
importance: Undecided → High
Étienne BERSAC (bersace) wrote :

I confirm this bug on edgy on macbook with a wireless mighty mouse.

Daniel Holbach (dholbach) wrote :

I consider the bug fixed with syncing bluez-gnome from Debian, bug 65253. It will be seeded to supported soon too.

Changed in bluez-utils:
status: Confirmed → Fix Released
PetyrRahl (petyr) wrote :

Just updated and got the updates for the bluez-gnome package. This does not fix the problem for KDE however as the passkey-agent binary is still not included. I'm not sure how to go about re-opening this bug or if I should just file a new request.

lor (astarventure) wrote :

i also have this bug. i cannot pair my bluetooth mobile phone. ubuntu is userfriendly distro and this bug should be fixed before release

lor (astarventure) wrote :

also why /usr/lib/kdebluetooth/kbluepin does not work as pin helper in kubuntu?

Daniel Holbach (dholbach) wrote :

I subscribe the Kubuntu team to the bug.

Daniel Holbach (dholbach) wrote :

Reopening the bug. Kubuntu has problems with the passkey-agent. Jonathan Riddell proposed to use the patch of - which makes it possible to exec passkey agents 'the old way'. However using the patch and running passkey-agent --default /usr/lib/kdebluetooth/kbluepin seems not enough.

Changed in bluez-utils:
status: Fix Released → Confirmed
description: updated
Marcel Holtmann (holtmann) wrote :

The passkey-agent.c example source code is now installed under /usr/share/doc/bluez-utils/examples/ together with a simple Makefile to compile it if needed. Remember that this is an example code on how to write a passkey agent. Every desktop environment should provide its own default passkey agent. For GNOME it is provided by the bluez-passkey-gnome package. The KDE people need to step up and write a clean passkey agent for their desktop. Everything else is an ugly hack.

Daniel Holbach (dholbach) wrote :

 bluez-utils (3.7-1ubuntu3) edgy; urgency=low
   * debian/rules:
     - install usr/bin/passkey-agent.
   * debian/patches/010-kubuntu-pin-helper.patch:
     - applied modified version of

 kdebluetooth (0.99+1.0beta1-12ubuntu8) edgy; urgency=low
   * debian/kbluepin.autostart.desktop:
     - add autostart file, which starts
       /usr/bin/passkey-agent --default /usr/lib/kdebluetooth/kbluepin
   * debian/kdebluetooth.install:
     - install it to /usr/share/autostart.

Changed in bluez-utils:
assignee: bluetooth → dholbach
status: Confirmed → Fix Released
Alberto Milone (albertomilone) wrote :

I still have this problem.

I have:
bluez-utils 3.7-1ubuntu3

kdebluetooth 0.99+1.0beta1-12ubuntu8

Alberto Milone (albertomilone) wrote :

The problem persists with:
kdebluetooth 0.99+1.0beta1-12ubuntu9

gpothier (gpothier) wrote :

I experienced the problem before, but with latest updates I successfully paired with my phone.
I rebooted the machine after the updates.

Alberto Milone (albertomilone) wrote :

I can only send files from my computer to my mobile phone.

If I try to send a file from my mobile phone to my computer, the phone says it can't find any bluetooth device.

This doesn't happen in Dapper.

Daniel Holbach (dholbach) wrote :

Alberto: can you please open a new bug report for that and do a quick run through ?

sk0rp10 (matteo-andreozzi) wrote :

confirmed on feisty

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.