Change log for bobcat package in Ubuntu

160 of 60 results
Published in disco-release on 2019-01-27
Deleted in disco-proposed (Reason: moved to release)
bobcat (4.08.06-1build1) disco; urgency=medium

  * No-change rebuild for readline soname change.

 -- Matthias Klose <email address hidden>  Mon, 14 Jan 2019 19:58:17 +0000
Superseded in disco-release on 2019-01-27
Deleted in disco-proposed on 2019-01-29 (Reason: moved to release)
bobcat (4.08.06-1) unstable; urgency=low

  [ Frank B. Brokken ]
  * New upstream release adds factory-members to the Exception class, fixes
    flaws in man-pages.

  [ Ondřej Nový ]
  * d/copyright: Change Format URL to correct one

  [ tony mancill ]
  * Update pattern in debian/watch

 -- Frank B. Brokken <email address hidden>  Mon, 17 Dec 2018 09:47:49 +0100

Available diffs

Superseded in disco-release on 2018-12-18
Deleted in disco-proposed on 2018-12-19 (Reason: moved to release)
bobcat (4.08.05-1) unstable; urgency=low

  * New upstream release
    - turns BigInt::diophantus into a static member
    - contains several cosmetic changes to source files and man-pages (see the
      upstream changelog for details)

 -- Frank B. Brokken <email address hidden>  Wed, 26 Sep 2018 13:34:25 +0200

Available diffs

Superseded in disco-release on 2018-11-10
Published in cosmic-release on 2018-06-23
Deleted in cosmic-proposed (Reason: moved to release)
bobcat (4.08.04-1) unstable; urgency=low

  [ Frank B. Brokken ]
  * New upstream release
    - Upstream migrated from Github to Gitlab
    - Updated debian/watch

  [ tony mancill ]
  * Remove -arch and -indep targets in debian/rules

 -- Frank B. Brokken <email address hidden>  Sun, 17 Jun 2018 19:09:37 +0530

Available diffs

Superseded in cosmic-release on 2018-06-23
Deleted in cosmic-proposed on 2018-06-25 (Reason: moved to release)
bobcat (4.08.03-1) unstable; urgency=low

  [ Frank B. Brokken ]
  * New upstream release fixes prepares bobcat for g++-8
    (Closes: #897997)
  * Updated Standards-Version to 4.1.4 in debian/control.

  [ tony mancill ]
  * Update Vcs fields for migration from Alioth -> Salsa

 -- tony mancill <email address hidden>  Mon, 07 May 2018 08:15:49 -0700
Superseded in cosmic-release on 2018-05-08
Published in bionic-release on 2018-02-08
Deleted in bionic-proposed (Reason: moved to release)
bobcat (4.08.02-2build1) bionic; urgency=high

  * No change rebuild against openssl1.1.

 -- Dimitri John Ledkov <email address hidden>  Mon, 05 Feb 2018 23:20:58 +0000
Superseded in bionic-release on 2018-02-08
Deleted in bionic-proposed on 2018-02-10 (Reason: moved to release)
bobcat (4.08.02-2) unstable; urgency=low

  * Rebuilt the Debian package to fix some issues with the pristine-tar and 
    upstream branches (not showing the 4.08.02 version).

 -- Frank B. Brokken <email address hidden>  Mon, 18 Sep 2017 09:35:43 +0200

Available diffs

Superseded in bionic-release on 2017-11-03
Published in artful-release on 2017-06-22
Deleted in artful-proposed (Reason: moved to release)
bobcat (4.07.00-2) unstable; urgency=medium

  * Upload to unstable for buster release cycle.

 -- tony mancill <email address hidden>  Tue, 20 Jun 2017 15:58:04 -0700

Available diffs

Superseded in artful-release on 2017-06-22
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
bobcat (4.04.00-1) unstable; urgency=low

  [ Frank Brokken ]
  * New upstream release adds new class BinopsBase, adding (selections of)
    binary operators to classes derived from it, added members to several
    existing classes, modernized GetHostent, and repaired several bugs. See
    the upstream's changelog.

  [ tony mancill ]
  * Add debian/watch file.
  * Update Vcs URLs in debian/control to use HTTPS.

 -- Frank B. Brokken <email address hidden>  Thu, 24 Nov 2016 13:17:44 +0100
Superseded in zesty-release on 2016-12-23
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
bobcat (4.02.00-1ubuntu2) yakkety; urgency=medium

  * No-change rebuild for readline soname change.

 -- Matthias Klose <email address hidden>  Sat, 17 Sep 2016 11:58:59 +0000
Superseded in yakkety-release on 2016-09-18
Deleted in yakkety-proposed on 2016-09-20 (Reason: moved to release)
bobcat (4.02.00-1ubuntu1) yakkety; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - d/p/0001-libadd-pthread-ftbfs.patch: Adjusted library order to
      link, resolving FTBFS

Superseded in yakkety-release on 2016-06-15
Published in xenial-release on 2015-11-30
Deleted in xenial-proposed (Reason: moved to release)
bobcat (4.01.03-2ubuntu1) xenial; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - d/p/0001-libadd-pthread-ftbfs.patch: Adjusted library order to
      link, resolving FTBFS (a leftover symptom of BTS#608145).

 -- Sebastien Bacher <email address hidden>  Mon, 23 Nov 2015 15:56:33 +0100
Superseded in xenial-proposed on 2015-11-23
bobcat (4.01.03-2) unstable; urgency=medium

  * Upload to unstable after receiving ACK of transition from the 
    Release Team.  See Debian BTS #805523.
  * Add patch for manpage typos.

 -- tony mancill <email address hidden>  Thu, 19 Nov 2015 20:50:56 -0800
Superseded in xenial-release on 2015-11-30
Deleted in xenial-proposed on 2015-12-03 (Reason: moved to release)
bobcat (3.25.02-3ubuntu1) xenial; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - d/p/0001-libadd-pthread-ftbfs.patch: Adjusted library order to
      link, resolving FTBFS (a leftover symptom of BTS#608145).

Superseded in xenial-release on 2015-11-05
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
bobcat (3.25.01-2ubuntu3) wily; urgency=medium

  * debian/rules:
    - Fix empty package libbobcat3v5 by installing files in right spot

 -- Michael Terry <email address hidden>  Thu, 13 Aug 2015 14:58:19 -0400
Superseded in wily-proposed on 2015-08-13
bobcat (3.25.01-2ubuntu2) wily; urgency=medium

  * Rename library packages for g++5 ABI transition.

 -- Steve Langasek <email address hidden>  Mon, 03 Aug 2015 07:49:42 +0000
Superseded in wily-release on 2015-08-13
Deleted in wily-proposed on 2015-08-15 (Reason: moved to release)
bobcat (3.25.01-2ubuntu1) wily; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - Carry forward the linking order as it still FTBFS in ubuntu.

Superseded in wily-release on 2015-06-06
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
bobcat (3.23.01-1ubuntu1) vivid; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - Adjusted library order to link, resolving FTBFS

Superseded in vivid-release on 2014-10-26
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
bobcat (3.22.00-1ubuntu1) utopic; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Adjusted library order to link, resolving FTBFS

Superseded in utopic-release on 2014-04-27
Published in trusty-release on 2014-01-01
Deleted in trusty-proposed (Reason: moved to release)
bobcat (3.19.01-1ubuntu1) trusty; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Adjusted library order to link, resolving FTBFS

Superseded in trusty-release on 2014-01-01
Deleted in trusty-proposed on 2014-01-02 (Reason: moved to release)
bobcat (3.18.01-1ubuntu1) trusty; urgency=low

  * Adjusted library order to link, resolving FTBFS (a leftover symptom
    of BTS#608145).
 -- Daniel T Chen <email address hidden>   Tue, 26 Nov 2013 08:46:11 -0500
Superseded in trusty-proposed on 2013-11-26
bobcat (3.18.01-1) unstable; urgency=low


  [ Frank B. Brokken ]
  * New upstream release fixes a previously undetected compilation error

  [ tony mancill ]
  * Bump Standards-Version to 3.9.5.

 -- tony mancill <email address hidden>  Fri, 22 Nov 2013 23:51:44 -0800

Available diffs

Superseded in trusty-release on 2013-11-26
Deleted in trusty-proposed on 2013-11-27 (Reason: moved to release)
bobcat (3.17.00-1) unstable; urgency=low


  * New upstream release mainly removes inline functions from maintenance
    header files. For several other issues: see the upstream changelog

 -- Frank B. Brokken <email address hidden>  Wed, 09 Oct 2013 17:52:15 +0200

Available diffs

Superseded in trusty-release on 2013-10-22
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
bobcat (3.14.00-1) unstable; urgency=low


  [ Frank B. Brokken ]
  * New upstream release overhauls SyslogStream and Syslogbuf
  * Update debian/rules to export CXX = g++ instead of g++-4.7.

  [ tony mancill ]
  * Update debian/control with versioned dependency on g++ >= 4:4.7.1
  * Update Format URL in debian/copyright.

 -- tony mancill <email address hidden>  Fri, 10 May 2013 22:07:11 -0700

Available diffs

Superseded in saucy-release on 2013-05-12
Deleted in saucy-proposed on 2013-05-13 (Reason: moved to release)
bobcat (3.13.00-1) unstable; urgency=low


  * New upstream release adds CGI::param1 to CGI 

 -- Frank B. Brokken <email address hidden>  Tue, 30 Apr 2013 21:13:41 +0200

Available diffs

Superseded in saucy-release on 2013-05-09
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
bobcat (3.01.00-1) unstable; urgency=low


  * New upstream release (bumps the soname version).
    + Arg, ArgConfig and ConfigFile use the bridge design pattern.
    + Programs depending on the Bobcat library must be recompiled.
    + DateTime bugfix.
  * Rename the library package libbobcat2 to libbobcat3 to reflect
    the soname bump (no further relationships are needed, since
    libbobcat2 and libbobcat3 do not ship common files).
  * Drop unneeded and errant relationships of Provides|Conflicts|Replaces:
    libbobcat1 previosly added to the library package section (post lenny).
  * Likewise, drop Provides|Conflicts|Replaces: libbobcat1-dev
    relationships from the -dev package section (libbobcat1-dev is
    a non-virtual package in lenny, which has been subsequently renamed
    to libbobcat-dev in squeeze).

 -- George Danchev <email address hidden>  Wed, 16 May 2012 16:58:39 +0200

Available diffs

Superseded in quantal-release on 2012-05-24
bobcat (2.22.00-1) unstable; urgency=low


  * New upstream release (bug fix, manual cosmetics, code cleanup)

 -- Frank B. Brokken <email address hidden>  Mon, 16 Apr 2012 09:26:51 +0200
Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-12-16
bobcat (2.20.01-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  16 Dec 2011 16:25:46 +0000

Available diffs

Superseded in precise-release on 2011-12-16
bobcat (2.20.00-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  14 Nov 2011 10:35:24 +0000

Available diffs

Superseded in precise-release on 2011-11-14
bobcat (2.19.01-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  21 Oct 2011 09:25:33 +0000

Available diffs

Superseded in precise-release on 2011-10-21
bobcat (2.19.00-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 09:10:55 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
bobcat (2.18.00-2) unstable; urgency=low

  * Build depend on 4:4.6.0, better support for c++0x.
    (fixes ftbfs with older compilers on some architectures)

Available diffs

Superseded in oneiric-release on 2011-06-18
bobcat (2.17.00-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  07 Jun 2011 11:25:19 +0000

Available diffs

Superseded in oneiric-release on 2011-06-07
bobcat (2.16.00-1) unstable; urgency=low

  * New upstream release (changes inline implementations of 
    virtual members to non-inline).          Closes: #602817
  * Added Vcs-* fields.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  27 May 2011 07:44:03 +0000

Available diffs

Superseded in oneiric-release on 2011-05-27
bobcat (2.15.02-1) unstable; urgency=low

  * New upstream release. Closes: #626889
    (repairs segfaults observed with g++ 4.6 
    for static data members in the Cidr class.)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  17 May 2011 09:12:47 +0000

Available diffs

Superseded in oneiric-release on 2011-05-17
bobcat (2.15.01-1) unstable; urgency=low

  * New upstream release repairs flaws appearing with g++ 4.6.
    (includes bobcat changes resulting in bobcat 2.15.00).
    Closes: #625076
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  06 May 2011 09:23:39 +0000

Available diffs

Superseded in oneiric-release on 2011-05-06
bobcat (2.15.00-1) unstable; urgency=low

  * New upstream release repairs flaws appearing with g++ 4.6 
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  04 May 2011 13:35:30 +0000

Available diffs

Superseded in oneiric-release on 2011-05-04
bobcat (2.14.00-1) unstable; urgency=low

  * New upstream release: new classes StringLine and Cidr, and bugfix

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
bobcat (2.10.03-1) unstable; urgency=low

  * New upstream release (Closes: #608183)
 -- Bhavani Shankar <email address hidden>   Wed, 29 Dec 2010 17:19:36 +0100

Available diffs

Superseded in natty-release on 2010-12-31
bobcat (2.10.02-1ubuntu1) natty; urgency=low

  * Resolve unresolved symbols in shared library.
  * Link with g++, use correct -z defs option.
 -- Matthias Klose <email address hidden>   Wed, 29 Dec 2010 15:21:27 +0020

Available diffs

Superseded in natty-release on 2010-12-29
bobcat (2.10.02-1) unstable; urgency=low

  * New upstream release fixes missing ConfigFile::size() member
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  27 Dec 2010 10:59:12 +0000

Available diffs

Superseded in natty-release on 2010-12-27
bobcat (2.10.01-2) unstable; urgency=low

  * Set distribution to unstable.

Available diffs

Superseded in natty-release on 2010-12-25
Obsolete in maverick-release on 2013-03-05
bobcat (2.08.01-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
bobcat (2.06.00-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  08 Dec 2009 08:14:56 +0000

Available diffs

Superseded in lucid-release on 2009-12-08
bobcat (2.05.00-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in lucid-release on 2009-11-24
Obsolete in karmic-release on 2013-03-04
bobcat (2.02.03-1ubuntu1) karmic; urgency=low

  * Inline patch: string/unescape1.cc
    Fix FTBFS caused by "error: invalid conversion from 'const char*' to
    'char*'".

 -- Stefan Ebner <email address hidden>   Sat, 12 Sep 2009 16:57:28 +0200

Available diffs

Superseded in karmic-release on 2009-09-12
bobcat (2.02.03-1) unstable; urgency=low

  * New upstream release. (Closes: #525746)
  * disable symbols check (-c0): Rf.
    http://lists.debian.org/debian-devel/2009/04/msg00298.html

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  09 May 2009 22:58:37 +0100

Available diffs

Superseded in karmic-release on 2009-05-09
bobcat (2.02.02-1) unstable; urgency=low

  * New upstream release.  (Closes: #525746)

Available diffs

Superseded in karmic-release on 2009-05-05
bobcat (2.01.1-1) unstable; urgency=low

  * New upstream release.

Available diffs

Superseded in karmic-release on 2009-04-28
Obsolete in jaunty-release on 2013-02-28
bobcat (2.00.1-2) unstable; urgency=low

  *  added missing libbobcat2 (= ${binary:Version}) to depends of libbobcat-dev

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  06 Dec 2008 22:02:17 +0000

Available diffs

Superseded in jaunty-release on 2008-12-06
bobcat (2.00.1-1) unstable; urgency=low

  * New upstream release. Fixes an FTBFS on architectures where 
    size_t is not unsigned int.

Available diffs

Superseded in jaunty-release on 2008-12-05
bobcat (1.21.1-2) unstable; urgency=low

  *  Enforce versioned dependencies on the library 
     via dh_makeshlibs -V (Closes: #504603)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 Nov 2008 16:57:54 +0000

Available diffs

Superseded in jaunty-release on 2008-11-09
bobcat (1.21.1-1) unstable; urgency=low

  * New upstream release.

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
bobcat (1.18.1-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  26 May 2008 12:51:56 +0100
Superseded in intrepid-release on 2008-05-26
bobcat (1.17.2-1) unstable; urgency=low

  * New upstream release. (Closes: #464684)

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
bobcat (1.17.0-1) unstable; urgency=low

  * New upstream release.

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
bobcat (1.15.0-1) unstable; urgency=low

  * New upstream release (Closes: #423744)
  * Build-Depends: yodl >= 2.04a
  * Transition build-deps from tetex to texlive packages

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  30 May 2007 07:27:28 +0100
Superseded in gutsy-release on 2007-05-30
bobcat (1.14.2-1) unstable; urgency=low

  * New upstream release  (Closes: #417127)
    Added (still) missing header files. Also see the upstream changelog 

Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
bobcat (1.12.1-1) unstable; urgency=low

  * New upstream release: 
        See the upstream changelog, for both 1.12.0 and 1.12.1.
        Due to a presumed g++ compiler bug release 1.12.0 was not added
        to the Debian archive. Instead 1.11.0 is immediately followed by
        1.12.1. 

Superseded in feisty-release on 2006-12-12
bobcat (1.11.0-1) unstable; urgency=low

  [ Frank Brokken ]
  * New upstream release expands and generalizes the Wrap* classes
    see the upstream changelog for details

  [ George Danchev ]
  * rules:get-orig-source - use sed instead original-awk
  * fix a textual typo in package description
  * build-depend on icmake >= 6.30-1 

160 of 60 results