Wrong configuration for Brazilian keyboard

Bug #66774 reported by Evandro Fernandes Giovanini on 2006-10-18
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
console-setup (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

When the "Brazil" keymap is selected in the installer, the XKBMODEL setting in /etc/default/console-setup and XkbModel in /etc/X11/xorg.conf is set to "pc105". For Brazilian keyboards it should be "abnt2" instead, as that is the standard model used in Brazil.

With this bug Brazilian users will have to manually edit these configuration files to set the correct keyboard layout, which is a regression from Dapper. Hopefully it can be fixed before the 6.10 final release.

Jonh Wendell (wendell) wrote :

Hi.

As brazilian user, i can confirm this bug.
But i guess it's not related to ubiquity, once i installed my edgy from alternate cd.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) on 2006-10-18
Changed in ubiquity:
assignee: nobody → kamion
importance: Undecided → Medium
Colin Watson (cjwatson) wrote :

First step:

casper (1.77) edgy; urgency=low

  * Honour console-setup/modelcode preseeding. Needed for Malone #66719,
    #66774.

 -- Colin Watson <email address hidden> Fri, 20 Oct 2006 19:59:39 +0100

Colin Watson (cjwatson) wrote :

Second step:

gfxboot-theme-ubuntu (0.2.9) edgy; urgency=low

  * Preseed console-setup/modelcode to abnt2 for Brazilian (Malone #66774)
    and to jp106 for Japanese (Malone #66719). Adjust our own keymaps in
    line with this.

 -- Colin Watson <email address hidden> Fri, 20 Oct 2006 20:12:40 +0100

Colin Watson (cjwatson) wrote :

And this should complete the fix:

console-setup (1.7ubuntu19) edgy; urgency=low

  * If upgrading from an older version than this one, check for the Terminus
    font face and change it to VGA (if you do like it, you can change it
    back and it won't be touched again). If Terminus was in use, also check
    for the 12x6 font size and change it to 16, since that was apparently
    selected due to a strange use-of-debconf bug.
  * Run kbd_mode on each tty in ACTIVE_CONSOLES rather than on the current
    tty, since the current tty might belong to X and changing X's tty out of
    raw mode is a very bad idea (closes: Malone #66929; requires kbd 1.12-15
    or console-tools 1:0.2.3dbs-62ubuntu10).
  * Adjust the default keyboard model for Brazilian (closes: Malone #66774)
    and Japanese (closes: Malone #66719) layouts.

 -- Colin Watson <email address hidden> Fri, 20 Oct 2006 20:16:09 +0100

Changed in console-setup:
status: Confirmed → Fix Released
João Bordignon (joaoeb) wrote :

Regression in Feisty. The keyboard works in the terminal, don't work in X. XkbModel is set as 105 instead of abnt2. Don't tested in Gutsy.

Grazieno Pellegrino (grazieno) wrote :

In gutsy, the problem continues.

I seem to be experiencing this on Natty. I installed a pt-br keyboard on an Asus EeePC 1002HA for my parents in law to use, however I cannot make the question mark \ backslash button work with any of the Brazilian layouts in the keyboard selector. It defaults to 105 keys intl.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers