cupsys 1.3.5-1ubuntu1 source package in Ubuntu

Changelog

cupsys (1.3.5-1ubuntu1) hardy; urgency=low

  * Merge with Debian unstable; remaining Ubuntu changes:
    - TearDown (fast shutdown):
      + debian/control: Add sysv-rc (>= 2.86.ds1-14.1ubuntu2) dependency.
      + debian/rules: Use 'multiuser' update-rc.d mode.
    - debian/control, debian/rules: Drop cupsys-dbg package.
    - debian/cupsys.{pre,post}inst, debian/cupsys.preinst: Various upgrade
      fixes that need to be kept until after the next LTS:
      + Revert to single cupsd.conf file.
      + Remove obsolete rc.d links.
      + Revert usr/share/doc symlink/directory breakage.
    - debian/patches/ubuntu-default-error-policy-retry-job.dpatch: Retry a
      failed job instead of stopping the print queue.
    - debian/patches/ubuntu-disable-browsing.dpatch: Disable browsing by
      default.
    - Add AppArmor profile:
      + debian/local/apparmor-profile
      + debian/cupsys.postinst: Reload AA profile on configuration.

cupsys (1.3.5-1) unstable; urgency=high

  [ Kenshi Muto]
  * New upstream release
    - cups-stops-broadcasting-on-HUP-with-explicit-BrowseAddress patch is
      merged.
    - Fix that SNMP backend did not check for negative string lengths.
      (CVE-2007-5849, closes: #457453).
  * Update pdftops.pl to 1.20. It fixes overwriting arbitary files
    via symlink attack. (CVE-2007-6358, closes: #456960)

  [ Till Kamppeter ]
  * debian/patches/fix_regression_reactivate_net_ifaces_changes_detection.dpatch :
    Fix a regression in upstream code that has removed the network interface
    update poll (CUPS STR #2631, LP: #177075). Thanks to Hugues Fournier
    (hugues dot fournier at gmail dot com) for the patch.

cupsys (1.3.4-4) unstable; urgency=high

  [ Kenshi Muto]
  * cupsys depends on "ghostscript | gs-esp", not "ghostscript | gsp-esp"!
    I should punish myself.
    (closes: #456455)

cupsys (1.3.4-3) unstable; urgency=high

  [ Martin Pitt ]
  * debian/control: Bump Standards-Version to 3.7.3 (no changes necessary).

  [ Till Kamppeter ]
  * debian/patches/cups-stops-broadcasting-on-hup-with-explicit-browseaddress.dpatch:
    cups stopped broadcasting on a hup signal when using a fixed
    browseaddress (cups str #2618, lp: #173470).

  [ Kenshi Muto]
  * Debconf translation
    - French (closes: #456272)
    - do update-debconfpo. Update all translations to use the msgstr 'dnssd'
      for msgid 'dnssd'.
  * cupsys depends on "ghostscript | gs-esp", to ease testing transition and
    upgrades from etch (closes: #456455).

 -- Martin Pitt <email address hidden>   Wed, 02 Jan 2008 13:29:53 +0100

Upload details

Uploaded by:
Martin Pitt on 2008-01-02
Uploaded to:
Hardy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
net
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
cupsys_1.3.5.orig.tar.gz 4.6 MiB 0e20787103f92df6d772c167248df6f110e40a83c41ba0d435b422fb03ba3416
cupsys_1.3.5-1ubuntu1.diff.gz 126.1 KiB 36d3123720abc7ae873a137c4599e463341be862b4951d98f70b1cc7f91cb256
cupsys_1.3.5-1ubuntu1.dsc 1.2 KiB d10d4d3be23a8b7353272e53a90ac00c57d2bc2202752fe41009ee0cded4c4ea

View changes file

Binary packages built by this source

cupsys: No summary available for cupsys in ubuntu hardy.

No description available for cupsys in ubuntu hardy.

cupsys-bsd: No summary available for cupsys-bsd in ubuntu hardy.

No description available for cupsys-bsd in ubuntu hardy.

cupsys-client: No summary available for cupsys-client in ubuntu hardy.

No description available for cupsys-client in ubuntu hardy.

cupsys-common: No summary available for cupsys-common in ubuntu hardy.

No description available for cupsys-common in ubuntu hardy.

libcupsimage2: No summary available for libcupsimage2 in ubuntu hardy.

No description available for libcupsimage2 in ubuntu hardy.

libcupsimage2-dev: No summary available for libcupsimage2-dev in ubuntu hardy.

No description available for libcupsimage2-dev in ubuntu hardy.

libcupsys2: No summary available for libcupsys2 in ubuntu hardy.

No description available for libcupsys2 in ubuntu hardy.

libcupsys2-dev: No summary available for libcupsys2-dev in ubuntu hardy.

No description available for libcupsys2-dev in ubuntu hardy.