[SRU] dosemu (dapper)

Bug #72951 reported by StefanPotyra
8
Affects Status Importance Assigned to Milestone
dosemu (Ubuntu)
Fix Released
Undecided
StefanPotyra

Bug Description

Hi,

affected:
bug #58618, bug#54431, bug #58611, bug #53996. (some duplicates).

In short:
* dosemu compiled w.o. X-support (regression from breezy)
* fonts not working (regression as well)

What I did to fix it:
* add xfonts-utils and on libxt-dev to build-depends (fixes the no X-support thingy): Thus configure once again finds the right headers for X and get's it right.
* add bdftopcf to build-depends (otherwise the fonts cannot be compiled, dapper diverged from debian there in respect to what package supplies the bdftopcf binary)
* update the target directory of the fonts.

But hey, freedos segfaults? Yep, this will get it's own SRU, as it's not a bug in dosemu FWIW.

What's a little bit weird, is that I needed to restart X so that the fonts of xfonts-dosemu get registered. The postinst/postrm are created by dh_installxfonts though, so imo it should be fine. If anyone has a clue, spit it out please ;)

Cheers,
    Stefan.

Revision history for this message
StefanPotyra (sistpoty) wrote :
Changed in dosemu:
assignee: nobody → motu-sru
Revision history for this message
StefanPotyra (sistpoty) wrote :
Revision history for this message
Daniel T Chen (crimsun) wrote :

Looks good, +1.

Revision history for this message
StefanPotyra (sistpoty) wrote :

As discussed yesterday: assignee -> me, subscribe motu-sru instead.

Changed in dosemu:
assignee: motu-sru → sistpoty
Revision history for this message
Reinhard Tartler (siretart) wrote :

+1

Revision history for this message
Steve Kowalik (stevenk) wrote :

A few issues.

Isn't the version number supposed to be 1.2.2-3ubuntu0.1~proposed1 ?
And the patch looks a little strange, with the postrm getting cleared out, and then the exact same lines being put back again.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Version: will be updated shortly (it's sitting here since before we had the new version scheme *g*)

The postrm is not changed, just renamed:
debian/postrm: renamed to dosemu.postrm, otherwise dh_installxfonts
    won't create the necessary maintainer scripts for xfonts-dosemu.

Seems like debhelper sees otherwise only a file named postrm and won't react on the package xfonts-dosemu any longer.

Revision history for this message
StefanPotyra (sistpoty) wrote :
Revision history for this message
Steve Kowalik (stevenk) wrote :

Ah ha. That doesn't require that you rename the postrm, it requires that you understand what the -a option does for debhelper scripts. :-)

-a acts all on architecture-dependant packages, of which xfonts-dosemu isn't. :-)

Add -i to the dh_installxfonts call, and it should be good, sans the postrm change for a much smaller debdiff.

Revision history for this message
StefanPotyra (sistpoty) wrote :
Revision history for this message
StefanPotyra (sistpoty) wrote :

Hm... the -i was there in the first place. I could swear however that during previous builds, a postinst/postrm was never created for xfonts-dosemu. Now (and on a real clean dapper) it does get created. Maybe I was just doing some silly things ;)

Revision history for this message
Reinhard Tartler (siretart) wrote :

+1 anyway :)

Revision history for this message
Steve Kowalik (stevenk) wrote :

I don't see the point of increasing the version of the debhelper build dependancy, but that's very minor. Other than that, +1

Revision history for this message
Reinhard Tartler (siretart) wrote :

whats the status of this SRU?

Revision history for this message
StefanPotyra (sistpoty) wrote :

@Reinhard: sorry for my lack of comments: After Daniel said he's fine with it on irc, I've uploaded it to dapper-proposed. FWIW it's still in the queue.

Format: 1.7
Date: Tue, 19 Dec 2006 00:19:41 +0100
Source: dosemu
Binary: dosemu xfonts-dosemu
Architecture: source
Version: 1.2.2-3ubuntu0.1~proposed1
Distribution: dapper-proposed
Urgency: low
Maintainer: Bart Martens <email address hidden>
Changed-By: Stefan Potyra <email address hidden>
Description:
 dosemu - The Linux DOS Emulator
 xfonts-dosemu - VGA font for the DOS Emulator
Changes:
 dosemu (1.2.2-3ubuntu0.1~proposed1) dapper-proposed; urgency=low
 .
   * debian/rules, debian/xfonts-dosemu.dirs: Moving the fonts to
     /usr/share/X11/fonts/misc.
     Closes: ubuntu #58618, 54431.
   * debian/control: Build-depend on newer debhelper version and on
     xfonts-utils and on libxt-dev.
     Thanks Bart Martens for the fix. Closes: ubuntu #58611, #53996.
   * debian/rules: Use autoconf. Thanks Bart Martens.
   * debian/control: Build-depend on bdftopc for fonts.
     Closes: ubuntu #58618.
   * SRU-Report: LP#72951.
Files:
 19580caa012dd034543914442bd2623e 781 contrib/otherosfs optional dosemu_1.2.2-3ubuntu0.1~proposed1.dsc
 8d53609ac944ee8c0ff6aa3755a68a44 25077 contrib/otherosfs optional dosemu_1.2.2-3ubuntu0.1~proposed1.diff.gz

Revision history for this message
Tollef Fog Heen (tfheen) wrote :

Accepted into dapper-proposed, please solicit testing as per https://wiki.ubuntu.com/MOTU/SRU

Changed in dosemu:
status: Unconfirmed → Fix Committed
Revision history for this message
Peter Cherriman (pjcherriman) wrote :

I've been running the breezy version of dosemu on my dapper system due to the lack of X support.

I've just upgraded to the dapper proposed package and it works for me.

Revision history for this message
StefanPotyra (sistpoty) wrote :

For the record: EarlRodd also reported success with testing, see bug #58611.

Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

Dosemu 1.2.2-3ubuntu0.1~proposed1 works without any problem - I've tested on several workstations, where DOS-based accounting software is used everyday.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Propagating to dapper-updates, due to brand new SRU policy.

Format: 1.7
Date: Wed, 7 Mar 2007 00:21:46 +0100
Source: dosemu
Binary: dosemu xfonts-dosemu
Architecture: source
Version: 1.2.2-3ubuntu0.1
Distribution: dapper-updates
Urgency: low
Maintainer: Ubuntu MOTU Developers <email address hidden>
Changed-By: Stefan Potyra <email address hidden>
Description:
 dosemu - The Linux DOS Emulator
 xfonts-dosemu - VGA font for the DOS Emulator
Changes:
 dosemu (1.2.2-3ubuntu0.1) dapper-updates; urgency=low
 .
   * Propagating to dapper-updates.
   * Update maintainer field.
   * Tested by: Peter Cherriman, EarlRodd and Mantas Kriauciunas.
Files:
 d6a2e69d10dd3e1d5307125f8e8761be 836 contrib/otherosfs optional dosemu_1.2.2-3ubuntu0.1.dsc
 27c9e83d2dca82b0530dec7b235b0e1f 25202 contrib/otherosfs optional dosemu_1.2.2-3ubuntu0.1.diff.gz
Original-Maintainer: Bart Martens <email address hidden>

Revision history for this message
Martin Pitt (pitti) wrote :

Stefan, I had to reject your upload:

- It contained changes relative to the -proposed upload: Please do not change Maintainer fields in stable releases, we do not know whether all the tools in dapper/edgy get along with the new field.
- Please build the .changes file with all the changes since the last dapper/dapper-updates version (use the -v switch of debuild/dpkg-buildpackage).

Please fix this and reupload. Thank you!

Revision history for this message
StefanPotyra (sistpoty) wrote :

Martin, thanks for the info. Seems like I got misinformed about the maintainer-field when I asked around ;).

Next try:

Format: 1.7
Date: Fri, 9 Mar 2007 16:28:04 +0100
Source: dosemu
Binary: dosemu xfonts-dosemu
Architecture: source
Version: 1.2.2-3ubuntu0.1
Distribution: dapper-updates
Urgency: low
Maintainer: Bart Martens <email address hidden>
Changed-By: Stefan Potyra <email address hidden>
Description:
 dosemu - The Linux DOS Emulator
 xfonts-dosemu - VGA font for the DOS Emulator
Changes:
 dosemu (1.2.2-3ubuntu0.1) dapper-updates; urgency=low
 .
   * No change upload, propagating to dapper-updates.
   * Tested by: Peter Cherriman, EarlRodd and Mantas Kriauciunas.
 .
 dosemu (1.2.2-3ubuntu0.1~proposed1) dapper-proposed; urgency=low
 .
   * debian/rules, debian/xfonts-dosemu.dirs: Moving the fonts to
     /usr/share/X11/fonts/misc.
     Closes: ubuntu #58618, 54431.
   * debian/control: Build-depend on newer debhelper version and on
     xfonts-utils and on libxt-dev.
     Thanks Bart Martens for the fix. Closes: ubuntu #58611, #53996.
   * debian/rules: Use autoconf. Thanks Bart Martens.
   * debian/control: Build-depend on bdftopc for fonts.
     Closes: ubuntu #58618.
   * SRU-Report: LP#72951.
Files:
 3621c82339764a991f3c45bf6f39c99b 761 contrib/otherosfs optional dosemu_1.2.2-3ubuntu0.1.dsc
 6ce1f6da6e93b1aab3d1b93803ef5a53 25254 contrib/otherosfs optional dosemu_1.2.2-3ubuntu0.1.diff.gz

Revision history for this message
Martin Pitt (pitti) wrote :

Thank you! Accepted into dapper-updates.

Changed in dosemu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers