Change log for emacs22 package in Ubuntu

129 of 29 results
Deleted in natty-release on 2016-11-01 (Reason: LP: #671673)
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
emacs22 (22.2-0ubuntu9) lucid; urgency=low

  * SECURITY UPDATE: arbitrary mailbox read/write via race condition.
    - Add debian/patches/fix-movemail-race.diff: thanks to Dan Rosenberg.
    - CVE-2010-0825
 -- Kees Cook <email address hidden>   Tue, 23 Mar 2010 16:03:59 -0700

Available diffs

Obsolete in karmic-updates on 2013-03-04
Obsolete in karmic-security on 2013-03-04
emacs22 (22.2-0ubuntu6.2) karmic-security; urgency=low

  * SECURITY UPDATE: arbitrary mailbox read/write via race condition.
    - Add debian/patches/fix-movemail-race.diff: thanks to Dan Rosenberg.
    - CVE-2010-0825
 -- Kees Cook <email address hidden>   Tue, 23 Mar 2010 16:06:34 -0700
Obsolete in jaunty-updates on 2013-02-28
Obsolete in jaunty-security on 2013-02-28
emacs22 (22.2-0ubuntu2.9.04.1) jaunty-security; urgency=low

  * SECURITY UPDATE: arbitrary mailbox read/write via race condition.
    - Add debian/patches/fix-movemail-race.diff: thanks to Dan Rosenberg.
    - CVE-2010-0825
 -- Kees Cook <email address hidden>   Tue, 23 Mar 2010 16:07:52 -0700
Obsolete in intrepid-updates on 2013-02-20
Obsolete in intrepid-security on 2013-02-20
emacs22 (22.2-0ubuntu2.8.10.1) intrepid-security; urgency=low

  * SECURITY UPDATE: arbitrary mailbox read/write via race condition.
    - Add debian/patches/fix-movemail-race.diff: thanks to Dan Rosenberg.
    - CVE-2010-0825
 -- Kees Cook <email address hidden>   Tue, 23 Mar 2010 16:09:09 -0700
Obsolete in hardy-updates on 2015-04-24
Obsolete in hardy-security on 2015-04-24
emacs22 (22.1-0ubuntu10.2) hardy-security; urgency=low

  * SECURITY UPDATE: arbitrary mailbox read/write via race condition.
    - Add debian/patches/fix-movemail-race.diff: thanks to Dan Rosenberg.
    - CVE-2010-0825
 -- Kees Cook <email address hidden>   Tue, 23 Mar 2010 16:10:09 -0700
Superseded in karmic-updates on 2010-03-29
Deleted in karmic-proposed on 2010-03-30 (Reason: moved to -updates)
emacs22 (22.2-0ubuntu6.1) karmic-proposed; urgency=low

  * backport patch from emacs23 to ensure that dynamic menus get updated properly
    Closes: #550541,  LP: #415101
 -- Reinhard Tartler <email address hidden>   Mon, 09 Nov 2009 12:03:17 +0100

Available diffs

Superseded in lucid-release on 2010-03-29
Superseded in lucid-release on 2009-11-27
emacs22 (22.2-0ubuntu8) lucid; urgency=low

  * backport patch from emacs23 to ensure that dynamic menus get updated properly
    Closes: #550541,  LP: #415101
 -- Reinhard Tartler <email address hidden>   Fri, 06 Nov 2009 11:14:23 +0100

Available diffs

Superseded in lucid-release on 2009-11-09
emacs22 (22.2-0ubuntu7) lucid; urgency=low

  * revert debian/rules back to 22.2-0ubuntu4.
  * drop the 'emacs' metapackage, it is now provided via emacs23.

 -- Reinhard Tartler <email address hidden>   Wed, 04 Nov 2009 15:34:36 +0100

Available diffs

Superseded in lucid-release on 2009-11-04
Obsolete in karmic-release on 2013-03-04
emacs22 (22.2-0ubuntu6) karmic; urgency=low

  * Bump the version number of the 'emacs' package, since the first attempt
    to drop this binary from emacs23 didn't take.

 -- Steve Langasek <email address hidden>   Wed, 14 Oct 2009 17:40:19 +0000

Available diffs

Superseded in karmic-release on 2009-10-14
emacs22 (22.2-0ubuntu5) karmic; urgency=low

  * Claim back the 'emacs' binary package, which was incorrectly moved to
    emacs23 in a post-beta merge.  LP: #433397.

 -- Steve Langasek <email address hidden>   Sun, 11 Oct 2009 19:40:32 +0000

Available diffs

Superseded in karmic-release on 2009-10-12
emacs22 (22.2-0ubuntu4) karmic; urgency=low

  * Don't fail the build if dir or dir.old* don't exist (LP: #445666).

 -- Colin Watson <email address hidden>   Fri, 09 Oct 2009 22:08:07 +0100

Available diffs

Superseded in karmic-release on 2009-10-09
emacs22 (22.2-0ubuntu3) karmic; urgency=low

  * Backport from Debian (Raphael Hertzog):
    - Update packages to depend on install-info as emacs can be used as
      info-browser. Closes: #532600, #532599, #532597, #532602
      Drop Provides: info-browser from the emacs meta-package, each real
      package provides it already.

 -- Colin Watson <email address hidden>   Fri, 11 Sep 2009 15:56:14 +0100

Available diffs

Superseded in karmic-release on 2009-09-11
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
emacs22 (22.2-0ubuntu2) intrepid; urgency=low

  * SECURITY UPDATE: temporary file race condition in vcdiff (LP: #174177)
  * debian/patches/fix-vcdiff-tmp-race.diff: update lib-src/vcdiff to use
    mktemp
  * References
    CVE-2008-1694

 -- Jamie Strandboge <email address hidden>   Thu, 04 Sep 2008 09:27:58 -0500

Available diffs

Superseded in intrepid-release on 2008-09-05
emacs22 (22.2-0ubuntu1) intrepid; urgency=low

  * new upstream release

 -- Reinhard Tartler <email address hidden>   Sun, 29 Jun 2008 17:02:53 +0200

Available diffs

Obsolete in gutsy-updates on 2011-09-16
Obsolete in gutsy-security on 2011-09-16
emacs22 (22.1-0ubuntu5.2) gutsy-security; urgency=low

  * SECURITY UPDATE: buffer overflow in format function
  * debian/patches/fix-format-overflow.diff: fix src/editfns.c to account
    for precision in integer formatting (LP: #174177)
  * SECURITY UPDATE: temporary file race condition in vcdiff
  * debian/patches/vcdiff-tmp-race.diff: update lib-src/vcdiff to use
    mktemp
  * References
    CVE-2007-6109
    CVE-2008-1694

 -- Jamie Strandboge <email address hidden>   Thu, 01 May 2008 10:58:07 -0400
Superseded in hardy-updates on 2010-03-29
Superseded in hardy-security on 2010-03-29
emacs22 (22.1-0ubuntu10.1) hardy-security; urgency=low

  * SECURITY UPDATE: temporary file race condition in vcdiff
  * debian/patches/vcdiff-tmp-race.diff: update lib-src/vcdiff to use
    mktemp
  * References
    CVE-2008-1694

 -- Jamie Strandboge <email address hidden>   Thu, 01 May 2008 14:27:46 -0400
Superseded in intrepid-release on 2008-06-29
Obsolete in hardy-release on 2015-04-24
emacs22 (22.1-0ubuntu10) hardy; urgency=low

  * debian/control: Conflict and Replace emacs22-common-non-dfsg
    (LP: #172389).  Thanks to Jamie Raymond for the report.
  * debian/emacs.prerm: Remove alternatives in reverse creation order
    (LP: #162932).  Thanks to James Troup for the report.
  * debian/emacs.menu.in:
    - Use Applications/Editors instead of Apps/Editors as per menu policy.
    - Move menu definition for "emacs -nw" here, and delete
      emacs-common.menu.in.  This way, if the user installs emacs22-nox,
      they will not have an unwanted menu item added (LP: #157984).
      Thanks to Ryan for the report.
  * debian/patches:
    - feature-spell-warning.diff: New patch that displays a warning when
      spell is used and the spell binary is not installed (LP: #154989).
    - fix-comint-sudo.diff: New patch that causes comint to recognize the
      sudo prompt used by Ubuntu (LP: #162890).
    - Rename CVE-2007-6109.diff to fix-format-overflow.diff so that it
      shows up in README.Debian.  Add patch header as well.
    - fix-local-vars-security.diff: Add CVE ID.
  * debian/README.in:
    - Place Ubuntu rather than Debian in the header line.
    - Add link to further explanation for why we use a separate package.
    - Clarify what "this package" means.
    - Together this fixes LP: #180164.  Thanks to era for the report and
      patch.
  * debian/rules: Don't build debian/emacs-common.menu and don't call
    dh_installmenu -i.

 -- <email address hidden> (Michael W. Olson (GNU address))   Tue, 08 Jan 2008 18:00:57 -0500
Superseded in hardy-release on 2008-02-08
emacs22 (22.1-0ubuntu9) hardy; urgency=low

  * Rebuild against libgif-dev instead of libungif4-dev (LP: #174252)

 -- Ilya Eremin <email address hidden>   Fri, 21 Dec 2007 00:35:33 +0000
Superseded in hardy-release on 2008-01-01
emacs22 (22.1-0ubuntu8) hardy; urgency=low

  * Security fix: patches/CVE-2007-6109.diff. Patch from upstream Romain
    Francoise! (LP: #174177)

 -- Reinhard Tartler <email address hidden>   Fri, 14 Dec 2007 15:47:26 +0100
Superseded in gutsy-updates on 2008-05-06
Superseded in gutsy-security on 2008-05-05
emacs22 (22.1-0ubuntu5.1) gutsy-security; urgency=low

  * SECURITY UPDATE: unsafe variables loadable from opened files.
  * Add debian/patches/fix-local-vars-security.diff: fix behavior, thanks
    to Michael Olson.
  * References
    CVE-2007-5795

 -- Kees Cook <email address hidden>   Sat, 03 Nov 2007 18:14:10 -0700
Superseded in hardy-release on 2007-12-14
emacs22 (22.1-0ubuntu7) hardy; urgency=low

  * Brown paper bag release.
  * debian/rules (build, clean): Call patch and unpatch, respectively, so
    that our patches actually get applied.

 -- <email address hidden> (Michael W. Olson (GNU address))   Sat, 03 Nov 2007 22:45:01 -0400
Obsolete in feisty-backports on 2009-08-20
emacs22 (22.1-0ubuntu4~feisty2) feisty-backports; urgency=low

  [ Michael Olson: Fix security issue. ]
  * debian/patches/fix-local-vars-security.diff: New patch that fixes a
    bug in local variables handling.  This bug permitted very risky, close
    to arbitrary modification of the behavior of Emacs by potentially
    untrusted visited files.  Namely, highly unsafe variables like
    `load-path' could be changed without authorization.  Fixes Launchpad
    #159525 and Debian #449008.
  * Reference:
    CVE-2007-5795

  [ Michael Olson: Bring this closer to Debian's packaging. ]
  * debian/control: Remove Build-Depends for cdbs, since we really don't
    need it after all.
  * debian/patches: Remove executable bits for all patches.
  * debian/rules:
    - Include /usr/share/quilt/quilt.make instead of cdbs.  Thanks to
      Romain Francoise for discovering this Makefile.
    - Trivial changes that minimize the differences between our package
      and Debian's:
      + Use $(...) rather than ${...}, since the former seems to be
        preferred by debian.
      + Add "set -o pipefail" before several commands involving pipes, so
        that the error code returned is the one for the first command with
        an error in the pipe.  Since the version of bash in Debian sarge
        does not support this option, and we want to be able to share
        changes with Romain's emacs-snapshot backport for sarge, send the
        output of set to /dev/null and force the exit status to be 0.
      + (nominal_ver): Split command into multiple lines.
      + Reorganize some sections to make it easier to compare changes.
      + Export DEB_HOST_GNU_TYPE and DEB_BUILD_GNU_TYPE.
      + Rename DEB_TRASH to deb_trash.
      + Rename bin_name to flavor.
      + Update comments.
      + (confflags): Use "--build=" instead of "--build " and "--host="
        instead of "--host ".
      + (deb_orig_tgz): Introduce.
      + (persistent_autogen_build_files)
        (nonpersistent_autogen_build_files)
        (persistent_autogen_install_files)
        (nonpersistent_autogen_install_files, autogen_build_files)
        (autogen_install_files, persistent_autogen_files)
        (nonpersistent_autogen_files): New variables that replace
        PERSISTENT_AUTOGEN_FILES, NONPERSISTENT_AUTOGEN_FILES, and
        DEBPKGFILES.
    - (quilt): New variable that specifies how to call quilt.  This
      particular name was chosen because Debian uses it in their emacs22
      packaging.
    - (patch_info): Use $(quilt) rather than $(DEB_QUILT_CMD).

 -- <email address hidden> (Michael W. Olson (GNU address))   Fri, 02 Nov 2007 11:00:58 -0400
Superseded in hardy-release on 2007-11-13
emacs22 (22.1-0ubuntu6) hardy; urgency=low

  [ Michael Olson: Fix security issue. ]
  * debian/patches/fix-local-vars-security.diff: New patch that fixes a
    bug in local variables handling.  This bug permitted very risky, close
    to arbitrary modification of the behavior of Emacs by potentially
    untrusted visited files.  Namely, highly unsafe variables like
    `load-path' could be changed without authorization.  Fixes Launchpad
    #159525 and Debian #449008.

  [ Michael Olson: Bring this closer to Debian's packaging. ]
  * debian/control: Remove Build-Depends for cdbs, since we really don't
    need it after all.
  * debian/patches: Remove executable bits for all patches.
  * debian/rules:
    - Include /usr/share/quilt/quilt.make instead of cdbs.  Thanks to
      Romain Francoise for discovering this Makefile.
    - Trivial changes that minimize the differences between our package
      and Debian's:
      + Use $(...) rather than ${...}, since the former seems to be
        preferred by debian.
      + Add "set -o pipefail" before several commands involving pipes, so
        that the error code returned is the one for the first command with
        an error in the pipe.  Since the version of bash in Debian sarge
        does not support this option, and we want to be able to share
        changes with Romain's emacs-snapshot backport for sarge, send the
        output of set to /dev/null and force the exit status to be 0.
      + (nominal_ver): Split command into multiple lines.
      + Reorganize some sections to make it easier to compare changes.
      + Export DEB_HOST_GNU_TYPE and DEB_BUILD_GNU_TYPE.
      + Rename DEB_TRASH to deb_trash.
      + Rename bin_name to flavor.
      + Update comments.
      + (confflags): Use "--build=" instead of "--build " and "--host="
        instead of "--host ".
      + (deb_orig_tgz): Introduce.
      + (persistent_autogen_build_files)
        (nonpersistent_autogen_build_files)
        (persistent_autogen_install_files)
        (nonpersistent_autogen_install_files, autogen_build_files)
        (autogen_install_files, persistent_autogen_files)
        (nonpersistent_autogen_files): New variables that replace
        PERSISTENT_AUTOGEN_FILES, NONPERSISTENT_AUTOGEN_FILES, and
        DEBPKGFILES.
    - (quilt): New variable that specifies how to call quilt.  This
      particular name was chosen because Debian uses it in their emacs22
      packaging.
    - (patch_info): Use $(quilt) rather than $(DEB_QUILT_CMD).

 -- <email address hidden> (Michael W. Olson (GNU address))   Fri, 02 Nov 2007 11:00:58 -0400
Superseded in hardy-release on 2007-11-03
Obsolete in gutsy-release on 2011-09-16
emacs22 (22.1-0ubuntu5) gutsy; urgency=low

  * Trigger rebuild for hppa

 -- LaMont Jones <email address hidden>   Thu, 04 Oct 2007 19:36:25 +0000
Superseded in feisty-backports on 2007-11-20
emacs22 (22.1-0ubuntu4~feisty1) feisty-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in gutsy-release on 2007-10-04
emacs22 (22.1-0ubuntu4) gutsy; urgency=low

  [ Michael Olson ]
  * debian/control(.in): Add emacs22 as a Depends option for the emacs
    metapackage

  [ Reinhard Tartler ]
  * Don't install postinst in emacs metapackage, Fixes LP: #128978

 -- Reinhard Tartler <email address hidden>   Sun, 29 Jul 2007 10:40:00 +0200
Superseded in gutsy-release on 2007-07-29
emacs22 (22.1-0ubuntu3) gutsy; urgency=low

  [ Michael Olson ]
  * debian/control(.in): Build-Depend on quilt >= 0.42, because earlier
    versions do not have the "header" command.
  * debian/patches:
    - fix-emacs-manpage.diff: New patch that includes the current version
      of etc/emacs.1 from upstream.  This fixes several typographical
      errors, and documents the -Q option.
    - debian-emacs-manpage.diff: Rebase against fix-emacs-manpage.diff.

  [ Reinhard Tartler ]
  * debian/control(.in): add "emacs" metapackage, prefer emacs-gtk over
    emacs-nox

 -- Reinhard Tartler <email address hidden>   Sat, 28 Jul 2007 11:29:55 +0200
Superseded in gutsy-release on 2007-07-28
Superseded in gutsy-release on 2007-07-27
emacs22 (22.1-0ubuntu2) gutsy; urgency=low

  [ Michael Olson ]
  * Review patches from Debian's emacs22 package.
    - patches/debian-fakemail-program-name.diff: New patch for
      lib-src/fakemail.c that changes a mention of /bin/mail to
      /usr/bin/mail.  We don't go as far as Debian in throwing errors,
      because that seems like overkill.
    - patches/fix-cc-mode-local-vars.diff: New patch for
      lisp/progmodes/cc-mode.el that fixes a buggy interaction with
      file local variables.  Include ChangeLog entry as well.
    - patches/debian-require-liblockfile.diff: New patch for
      lib-src/movemail.c that causes the build to fail if liblockfile is
      not being used.
    - patches/debian-mail-from-style.diff: Modify to also set
      `message-sendmail-f-is-evil' to t by default.
    - patches/debian-site-init.diff: Place the emacs22-specific Info
      directory before the site-wide Info directory, rather than after it.
    - patches/debian-version-mention.diff: Set to my name rather than
      Rob's, and change description to mention Ubuntu.
    - patches/debian-startup.diff: Remove commented-out code and provide
      a more detailed explanation of what's going on.
  * Rename some patches:
    - patches/feature-dbp-horizontal-split.diff: Rename from
      debian-dp-split.dpatch to indicate that this is a feature-adding
      patch.
    - patches/debian-site-init.diff: Rename from
      debian-default-info-directory.dpatch.
    - patches/debian-startup.diff: Rename from debian-emacs-flavor.dpatch.
    - patches/fix-vc-bfn.diff: Rename from patches/debian-vc-bfn.dpatch
      to indicate that this a bugfix patch.
    - patches/fix-font-lock-tty.diff: Rename from
      debian-font-lock-tty.dpatch to indicate that this is a bugfix patch.
  * Migrate debian/patches from dpatch to quilt.
    - debian/control(.in): Remove dpatch from Build-Depends and add quilt.
      Add cdbs to Build-Depends to silence lintian.
    - debian/rules:
      - Migrate to quilt.
      - New function patch_info to extract information from the headers
        of patches that begin with a certain prefix.
      - Split patch output in README.Debian into several sections, in
        order make it easier to categorize by the type of patch.  We use
        the name of the patch to determine what kind it is.
      - Lines with '#' in the headers of patches are stripped out.
      - Multiple consecutive blank lines are trimmed to only one.
    - debian/patches: Rename *.dpatch to *.diff and prettify headers.
      Also, refresh patches that applied with offsets.
    - debian/README.in: Remove lines at the end.

  [ Reinhard Tartler ]
  * Add X-Vcs-Bzr headers to debian/control.

 -- <email address hidden> (Michael W. Olson (GNU address))   Fri, 20 Jul 2007 00:13:36 CEST
Superseded in gutsy-release on 2007-07-19
emacs22 (22.1-0ubuntu1) gutsy; urgency=low

  * New upstream release.
  * This package borrows much from the work on emacs-snapshot by Romain
    Francoise.

 -- <email address hidden> (Michael W. Olson (GNU address))   Fri, 06 Jul 2007 18:41:48 -0400
129 of 29 results