Change log for espeakup package in Ubuntu

144 of 44 results
Published in disco-release on 2018-11-11
Deleted in disco-proposed (Reason: moved to release)
espeakup (1:0.80-12) unstable; urgency=medium

  * debian/espeakup.service: Fix compatibility with older versions of systemd
    (see Bug#913453). Also fix starting with empty voice language.

 -- Samuel Thibault <email address hidden>  Sun, 11 Nov 2018 17:45:44 +0100

Available diffs

Superseded in disco-release on 2018-11-11
Deleted in disco-proposed on 2018-11-13 (Reason: moved to release)
espeakup (1:0.80-11) unstable; urgency=medium

  * control: Bump Standards-Version to 4.2.0 (no changes).
  * debian/espeakup.service: Automatically load speakup_soft on daemon
    startup.

 -- Samuel Thibault <email address hidden>  Mon, 15 Oct 2018 23:17:16 +0200

Available diffs

Superseded in disco-release on 2018-11-09
Published in cosmic-release on 2018-05-05
Deleted in cosmic-proposed (Reason: moved to release)
espeakup (1:0.80-10) unstable; urgency=medium

  * Bump Standards-Version to 4.1.4 (no changes).
  * patches/mutex: Add missing mutex_lock/unlock calls.
  * patches/audio-pause: Pause espeak when the console is switched to a
    graphical VT.
  * espeakup-udeb.finish-install: Do not remove pulseaudio, now that espeakup
    releases the audio card automatically.

 -- Samuel Thibault <email address hidden>  Thu, 03 May 2018 21:48:36 +0200

Available diffs

Superseded in cosmic-release on 2018-05-05
Published in bionic-release on 2018-03-12
Deleted in bionic-proposed (Reason: moved to release)
espeakup (1:0.80-9) unstable; urgency=medium

  [ Victor Ibragimov ]
  * Add Tajik translation (closes: Bug#890081).

  [ Samuel Thibault ]
  * Fix path to voice definitions.  Fixes language auto-switch in d-i.

 -- Samuel Thibault <email address hidden>  Thu, 08 Mar 2018 00:40:12 +0100
Superseded in bionic-release on 2018-03-12
Deleted in bionic-proposed on 2018-03-13 (Reason: moved to release)
espeakup (1:0.80-8build1) bionic; urgency=medium

  * No-change rebuild against latest espeak-ng

 -- Jeremy Bicha <email address hidden>  Tue, 23 Jan 2018 20:34:56 -0500
Superseded in bionic-release on 2018-01-24
Deleted in bionic-proposed on 2018-01-25 (Reason: moved to release)
espeakup (1:0.80-8) unstable; urgency=medium

  * Configure debconf frontend to readline on the installed system for better
    accessibility.
  * When installing with espeakup, remove pulseaudio and set speech dispatcher
    to libao.

 -- Samuel Thibault <email address hidden>  Thu, 21 Dec 2017 22:51:34 +0100

Available diffs

Superseded in bionic-release on 2017-12-22
Deleted in bionic-proposed on 2017-12-23 (Reason: moved to release)
espeakup (1:0.80-7) unstable; urgency=medium

  * control: Bump Standards-Version to 4.1.1 (no changes).
  * po/sq.po: Add Albanian debconf translation.
  * debian/espeakup-udeb.start: Fix case where card 0 does not have an id or
    where cards have non-contiguous indexes.
  * debian/control: Build-dep on debhelper (>= 9.20160709) instead of
    dh-systemd.

 -- Samuel Thibault <email address hidden>  Mon, 20 Nov 2017 00:20:02 +0100

Available diffs

Superseded in bionic-release on 2017-11-23
Published in artful-release on 2017-08-19
Deleted in artful-proposed (Reason: moved to release)
espeakup (1:0.80-6) unstable; urgency=medium

  [ Samuel Thibaul ]
  * patches/space: Fix spelling space character.
  * patches/unicode: Enable unicode support.
  * control: Update maintainer mailing list.
  * control: Migrate priority to optional.
  * control: Bump Standards-Version to 4.0.1.
  * patches/empty-default: Make empty voice name select the default voice
    (Closes: Bug#872194).

  [ Valentin Vidic ]
  * Croatian translation of debconf message (Closes: Bug#859323).

 -- Samuel Thibault <email address hidden>  Sat, 19 Aug 2017 00:53:51 +0200
Superseded in artful-release on 2017-08-19
Deleted in artful-proposed on 2017-08-20 (Reason: moved to release)
espeakup (1:0.80-5build1) artful; urgency=medium

  * No-change rebuild against latest espeak-ng

 -- Jeremy Bicha <email address hidden>  Fri, 14 Jul 2017 12:19:45 -0400
Superseded in artful-release on 2017-07-14
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
espeakup (1:0.80-5) unstable; urgency=medium

  * Use canonical anonscm vcs URL.

 -- Samuel Thibault <email address hidden>  Tue, 24 Jan 2017 03:25:54 +0100

Available diffs

Superseded in zesty-release on 2017-01-24
Deleted in zesty-proposed on 2017-01-25 (Reason: moved to release)
espeakup (1:0.80-3) unstable; urgency=medium

  * espeakup-udeb:
    - Avoid issues with sound board names containing spaces.
    - Fix races with starting espeakup.

 -- Samuel Thibault <email address hidden>  Mon, 28 Nov 2016 00:30:23 +0100

Available diffs

Superseded in zesty-release on 2016-11-28
Deleted in zesty-proposed on 2016-11-29 (Reason: moved to release)
espeakup (1:0.80-2) unstable; urgency=medium

  Switch to espeak-ng (Closes: #833658)
  * control: Replace libespeak-dev, libportaudio19-dev, libjack-dev with
    libespeak-ng-libespeak-dev and libpcaudio-dev.
  * rules: Define symbol create_pulseaudio_object to create_alsa_object so that
    we don't need to link espeakup-udeb with pulseaudio.
  * control: Make espeakup depend on lsb-base (>= 3.0-6) for
    /lib/lsb/init-functions.

 -- Samuel Thibault <email address hidden>  Thu, 10 Nov 2016 00:42:41 +0100

Available diffs

Superseded in zesty-release on 2016-11-10
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
espeakup (1:0.80-1) unstable; urgency=medium

  * New upstream release.
    - docs: Remove ToDo.
    - patches/{keystrokes,pidfile,voice,daemon}: Remove, merged upstream.
    - rules: Set PREFIX to /usr.

 -- Samuel Thibault <email address hidden>  Thu, 11 Aug 2016 23:28:43 +0200

Available diffs

Superseded in yakkety-release on 2016-08-19
Deleted in yakkety-proposed on 2016-08-20 (Reason: moved to release)
espeakup (1:0.71-28) unstable; urgency=medium

  * control: Bump Standards-Version to 3.9.8 (no change)
  * patches/daemon: Replace daemon() call with proper daemonizing code
    (Closes: #775131)
  * espeakup.defaults: Do not export ALSA_CARD variable, this is not accepted by
    systemd (and it exports it already anyway).
  * espeakup.postinst: Drop "export" from defaults file on upgrade accordingly.
  * espeakup.init: Export ALSA_CARD variable. Drop STARTTIME.

 -- Samuel Thibault <email address hidden>  Thu, 21 Jul 2016 01:21:49 +0200

Available diffs

Superseded in yakkety-release on 2016-07-21
Deleted in yakkety-proposed on 2016-07-22 (Reason: moved to release)
espeakup (1:0.71-27.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Install espeakup.service. (Closes: #796608)

 -- Christian Hofstaedtler <email address hidden>  Sun, 03 Jul 2016 20:52:49 +0200

Available diffs

Superseded in yakkety-release on 2016-07-09
Deleted in yakkety-proposed on 2016-07-10 (Reason: moved to release)
espeakup (1:0.71-27) unstable; urgency=high

  [ Samuel Thibault ]
  * Drop libnss-files-udeb dependency (Closes: #819684)
  * espeakup-udeb.postinst: Only preseed installing MATE desktop by default when
    espeakup is really running.

  [ Cyril Brulebois ]
  * Bump urgency to high for the upcoming D-I Stretch Alpha 6 release.

 -- Cyril Brulebois <email address hidden>  Thu, 19 May 2016 21:07:39 +0200
Superseded in yakkety-release on 2016-05-21
Published in xenial-release on 2016-04-15
Deleted in xenial-proposed (Reason: moved to release)
espeakup (1:0.71-26ubuntu1) xenial; urgency=medium

  * Cherry-pick from Debian git repository (Samuel Thibault):
    - Drop libnss-files-udeb dependency (Closes: #819684)

 -- Colin Watson <email address hidden>  Fri, 15 Apr 2016 16:51:26 +0100
Superseded in xenial-release on 2016-04-15
Deleted in xenial-proposed on 2016-04-16 (Reason: moved to release)
espeakup (1:0.71-26) unstable; urgency=medium

  * espeakup-udeb.start: On multiboard systems, request the user to press
    enter at the right time only, not a number.

 -- Samuel Thibault <email address hidden>  Tue, 09 Feb 2016 01:34:44 +0100

Available diffs

Superseded in xenial-release on 2016-02-09
Deleted in xenial-proposed on 2016-02-10 (Reason: moved to release)
espeakup (1:0.71-25) unstable; urgency=high

  * control: Bump Standards-Version to 3.9.7 (no change).
  * espeakup.init: Fix detection when the number of the card is given instead of
    the id.

 -- Samuel Thibault <email address hidden>  Tue, 02 Feb 2016 10:44:50 +0100

Available diffs

Superseded in xenial-release on 2016-02-02
Deleted in xenial-proposed on 2016-02-04 (Reason: moved to release)
espeakup (1:0.71-24) unstable; urgency=medium

  * speakup-udeb: Use a dumb menu to deal with multiple sound cards, and make
    sure the installed system uses it.
  * speakup.init: When the card is specified, wait for it to become available
    before starting the daemon.

 -- Samuel Thibault <email address hidden>  Mon, 18 Jan 2016 00:29:22 +0100

Available diffs

Superseded in xenial-release on 2016-01-18
Deleted in xenial-proposed on 2016-01-19 (Reason: moved to release)
espeakup (1:0.71-23) unstable; urgency=medium

  * patches/voice: Fix looking up voices by language name.

 -- Samuel Thibault <email address hidden>  Wed, 06 Jan 2016 01:13:40 +0100

Available diffs

Superseded in xenial-release on 2016-01-06
Deleted in xenial-proposed on 2016-01-07 (Reason: moved to release)
espeakup (1:0.71-22) unstable; urgency=medium

  * Re-upload with 1:0.71-19 changes from Jessie included.

 -- Samuel Thibault <email address hidden>  Fri, 01 Jan 2016 17:55:08 +0100

Available diffs

Superseded in xenial-release on 2016-01-02
Deleted in xenial-proposed on 2016-01-03 (Reason: moved to release)
espeakup (1:0.71-21) unstable; urgency=medium

  * espeakup-udeb.restart:
    - Make looking up available languages independent from file hierarchy, thus
    fixing all language (but de, en, fr, pt which were still working)...  This
    also allows dropping special-casing nb into no.
    - Use portuguese for galician, since they are so close, and portuguese
    will always be better than english anyway.

 -- Samuel Thibault <email address hidden>  Thu, 31 Dec 2015 15:22:01 +0100

Available diffs

Superseded in xenial-release on 2015-12-31
Deleted in xenial-proposed on 2016-01-02 (Reason: moved to release)
espeakup (1:0.71-20) unstable; urgency=medium

  * espeakup-udeb.sh: Preseed installing MATE desktop by default when espeakup
    is used in d-i.
  * compat: Bump to 9.
  * rules: Clear.
  * patches: Switch to 3.0 patch system.

 -- Samuel Thibault <email address hidden>  Sat, 26 Dec 2015 14:20:21 +0100

Available diffs

Superseded in xenial-release on 2015-12-27
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
espeakup (1:0.71-19) unstable; urgency=medium


  * Enable STARTTIME to work around racy daemon start test.

 -- Samuel Thibault <email address hidden>  Sun, 11 Jan 2015 21:14:54 +0100

Available diffs

Superseded in vivid-release on 2015-01-12
Deleted in vivid-proposed on 2015-01-13 (Reason: moved to release)
espeakup (1:0.71-18) unstable; urgency=medium


  * synth.c: Fix spelling capital keystrokes (Closes: #770753)

 -- Samuel Thibault <email address hidden>  Sun, 23 Nov 2014 21:07:37 +0100

Available diffs

Superseded in vivid-release on 2014-11-24
Deleted in vivid-proposed on 2014-11-25 (Reason: moved to release)
espeakup (1:0.71-17) unstable; urgency=medium


  * synth.c: Fix spelling keystrokes and char-by-char echo
    (Closes: #767595)

 -- Samuel Thibault <email address hidden>  Sat, 08 Nov 2014 16:45:00 +0100

Available diffs

Superseded in vivid-release on 2014-11-08
Deleted in vivid-proposed on 2014-11-10 (Reason: moved to release)
espeakup (1:0.71-16) unstable; urgency=medium


  * po/el.po: Greek translation (Closes: #685552)
  * Bump Standards-Version to 3.9.6 (no changes).

 -- Samuel Thibault <email address hidden>  Sun, 19 Oct 2014 16:59:03 +0200
Superseded in vivid-proposed on 2014-10-24
Deleted in utopic-proposed on 2014-10-26 (Reason: moved to vivid-proposed)
espeakup (1:0.71-15) unstable; urgency=medium


  [ Samuel Thibault ]
  * espeakup.default: Fix documented path to voices.
  * rules: Set the espeak:Version subst variable.
  * control: Add a version to the espeakup-udeb dependency on espeak-data-udeb.

  [ Paul Gevers ]
  * Add d/watch file to track upstream
  * Korean translation by Changwoo Ryu (Closes: #745549)
  * Acknowledge NMU (Closes: #753109)

 -- Samuel Thibault <email address hidden>  Fri, 11 Jul 2014 11:53:11 +0200

Available diffs

Superseded in vivid-release on 2014-10-24
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
espeakup (1:0.71-14.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Replace alsa-base-udeb dependency with libkmod2-udeb (>= 17-1~).

 -- Jordi Mallach <email address hidden>  Fri, 27 Jun 2014 08:38:32 +0200

Available diffs

Superseded in utopic-release on 2014-07-05
Published in trusty-release on 2014-03-04
Deleted in trusty-proposed (Reason: moved to release)
espeakup (1:0.71-14) unstable; urgency=medium


  * Rebuild against latest espeak.  Closes: #740021.
  * control: Use Package-Type instead of XC-Package-Type.
  * Bump Standards-Version to 3.9.5.
  * Redirect espeakup-udeb's stdout to log file too.

 -- Samuel Thibault <email address hidden>  Mon, 24 Feb 2014 22:10:23 -0500

Available diffs

Superseded in trusty-release on 2014-03-04
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
espeakup (1:0.71-13) unstable; urgency=low


  [ Christian Perrier ]
  * Fix Thai and Latvian translations encoding (reported by Jakub Wilk in
    debian-i18n)

 -- Samuel Thibault <email address hidden>  Mon, 24 Dec 2012 01:05:30 +0100

Available diffs

Superseded in raring-release on 2012-12-24
Deleted in raring-proposed on 2012-12-25 (Reason: moved to release)
espeakup (1:0.71-12) unstable; urgency=low


  [ Debconf translations ]
  * Kannada (Mallikarjuna).  Closes: #694410

 -- Samuel Thibault <email address hidden>  Thu, 20 Dec 2012 22:59:15 +0100

Available diffs

Superseded in raring-release on 2012-12-21
Obsolete in quantal-release on 2015-04-24
espeakup (1:0.71-11) unstable; urgency=low


  * softsynth.c: Cherry-pick fix from upstream: pass '\n' to espeak too for e.g.
  proper pause.

 -- Samuel Thibault <email address hidden>  Sat, 15 Sep 2012 22:19:04 +0200

Available diffs

Superseded in quantal-release on 2012-09-19
espeakup (1:0.71-10) unstable; urgency=low


  * espeakup-udeb.restart: Fix voice path according to multiarch switch.
    Closes: #682313

 -- Samuel Thibault <email address hidden>  Sat, 21 Jul 2012 21:44:51 +0900

Available diffs

Superseded in quantal-release on 2012-07-22
espeakup (1:0.71-9) unstable; urgency=low


  [ Debconf translations ]
  * Welsh (Daffyd Tomos)
  * Basque (Piarres Beobide).  Closes: #671885
  * Thai (Theppitak Karoonboonyanan).  Closes: #672216
  * Traditional Chinese (Vincent Chen).  Closes: #672322
  * Galician (Jorge Barreiro).  Closes: #676993
  * Norwegian Bokmål (Hans Fredrik Nordhaug).  Closes: #678344

 -- Samuel Thibault <email address hidden>  Wed, 27 Jun 2012 14:21:27 -0300

Available diffs

Superseded in quantal-release on 2012-06-29
espeakup (1:0.71-8) unstable; urgency=low


  [ Debconf translations ]
  * Latvian (Rūdolfs Mazurs).  Closes: #674696
  * Lithuanian (Rimas Kudelis).  Closes: #675627

 -- Samuel Thibault <email address hidden>  Sat, 16 Jun 2012 12:27:38 +0200

Available diffs

Superseded in quantal-release on 2012-06-18
espeakup (1:0.71-7) unstable; urgency=low


  [ Samuel Thibault ]
  * control: Bump Standards-Version to 3.9.3 (no changes).

  [ Debconf translations ]
  * Gujarati (Kartik Mistry).  Closes: #662102
  * Brazilian Portuguese (Adriano Rafael Gomes).  Closes: #662177
  * Belarusian (Viktar Siarheichyk).  Closes: #662609
  * Telugu (Arjuna Rao Chavala).  Closes: #663208
  * Khmer (Khoem Sokhem).
  * Asturian (Mikel González).
  * Marathi (Sampada Nakhare)
  * Slovenian (Vanja Cvelbar).  Closes: #670617

  [ Christian Perrier ]
  * Rename debconf template to "debian-installer/espeakup-udeb/title"
    for localization to really work.

 -- Samuel Thibault <email address hidden>  Thu, 17 May 2012 13:37:47 +0200

Available diffs

Superseded in quantal-release on 2012-05-24
espeakup (1:0.71-6.1) unstable; urgency=low


  * Non-maintainer upload, approved by Samuel.

  [ Debconf translations ]
  * Catalan (Jordi Mallach). Closes: #661414 

 -- Jordi Mallach <email address hidden>  Sat, 03 Mar 2012 14:13:38 +0100

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2012-02-27
espeakup (1:0.71-6) unstable; urgency=low


  [ Debconf translations ]
  * Ukrainian (Anton Gladky).  Closes: #654299
  * Esperanto (David Paleino).  Closes: #656533
  * Indonesian (Mahyuddin Susanto).  Closes: #656555
  * Japanese (Kenshi Muto).  Closes: #656558
  * Hebrew (Lior Kaplan). 
  * Danish (Joe Hansen).  Closes: #656639
  * Turkish (Atila KOÇ).  Closes: #656901

  [ Christian Perrier ]
  * Polish (Michał Kułach).  Closes: #657185

  [ Samuel Thibault ]
  * Use multiarch path for espeak, depend on the multiarched espeak.
  * Drop -1 in libportaudio dependency.

 -- Samuel Thibault <email address hidden>  Sat, 28 Jan 2012 19:47:44 +0100
Superseded in precise-release on 2012-02-27
espeakup (1:0.71-5ubuntu1) precise; urgency=low

  * Sync from debian unstable. New changes:
  * debian/rules:
    - adapt paths for multiarched libespeak.a

Superseded in precise-release on 2012-01-14
Obsolete in oneiric-release on 2015-04-24
espeakup (1:0.71-2ubuntu1) oneiric; urgency=low

  * debian/rules: adapt paths for multiarched libjack.a  (LP: #831131)
 -- Julian Taylor <email address hidden>   Thu, 25 Aug 2011 14:17:33 +0200

Available diffs

Superseded in oneiric-release on 2011-08-25
espeakup (1:0.71-2) unstable; urgency=low

  * debian/control:
    - New binary package espeakup-udeb for speech synthesis in the debian
    installer.
    - Build-Depend on the portaudio version which provides static library.
    - set Maintainer to the Debian Accessibility team.
    - Bump Standards-Version to 3.9.2 (no change needed).
    - Bump debhelper dependency.
    - Build-Depend on po-debconf
  * debian/espeakup.default: Document the ALSA_CARD variable.
  * debian/po: Add templates translation.
  * debian/rules:
    - Install init script in S (closes: Bug#606953).
    - Rework to build udeb.
    - Call debconf-updatepo.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  13 Jun 2011 09:07:26 +0000

Available diffs

Superseded in oneiric-release on 2011-06-13
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
espeakup (1:0.71-1) unstable; urgency=low

  * Initial release as package separate from speakup, as upstream is actually
    separate.
    Bump the epoch to 1 to get 1:0.71 greater than speakup's 3.1.3.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  19 Nov 2009 20:58:42 +0000
144 of 44 results