network-admin doesn't scan for networks [regression]

Bug #59159 reported by Gustaf on 2006-09-06
82
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GST
Fix Released
Medium
gnome-system-tools (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Since a few weeks back, network-admin doesn't list any ESSID's for my wireless device. But they sure can be scanned. "iwlist scanning" shows access points near by.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. It looks like the feature has not been ported to the new upstream architecture yet. I've forwarded the issue: http://bugzilla.gnome.org/show_bug.cgi?id=355098

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Changed in gst:
status: Unknown → Unconfirmed
Vassilis Pandis (pandisv) wrote :

This is still an issue for on current Edgy.

Changed in gnome-system-tools:
importance: Medium → High
manuel (manuel-soto) wrote :

I've the same problem but I know that this happened after a connection was established. Netapplet let me set up the key and save it. It request a password for the "ring" which I don't know what is do with it.

After that a have in /etc/network/interfaces

iface eth1 inet dhcp
wireless-essid paco
wireless-key ???????????

I'm able to scan manually using wpa_supplicant, I don't know if network-manager use it

Does exist a method to remove all wireless configuration and start again? This is the 2nd time I get this error, the first one it was solved removing all userś configuration files but it does not work again :(

manuel (manuel-soto) wrote :

netapplet reports that there is no network devices

$ sudo wpa_supplicant -Bdd -ieth1 -c /etc/wpa_supplicant.conf
....
Setting scan request: 0 sec 100000 usec
Added interface eth1
Daemonize..

$sudo wpa_cli -ieth1
>list_networks
network id / ssid / bssid / flags
0 paco any [CURRENT]

>scan
OK

>scan_results
bssid / frequency / signal level / flags / ssid
00:17:9a:58:01:49 0 201 [WEP] paco
00:0f:b5:df:2c:45 0 178 [WEP] 492F48F

Sebastien Bacher (seb128) wrote :

will not be fixed for edgy

I also don't see the list of available wireless networks.
If this won't be fixed I think I will downgrade my laptop to dapper,
because the functionality is very nice. So will there
be no fix for this issue in edgy?

regards

Le samedi 14 octobre 2006 à 08:19 +0000, Sven Sternberger a écrit :
> I also don't see the list of available wireless networks.
> If this won't be fixed I think I will downgrade my laptop to dapper,
> because the functionality is very nice. So will there
> be no fix for this issue in edgy?

feel free to downgrade if you think that tiny detail justify it, note
that if you switch between wireless networks you might want to install
network-manager

Ryan Zeigler (rzeigler) wrote :

<rant>
network-manager is fine and dandy, but what about those of us for whom it just doesn't seem to work, and don't feel like typing sudo iwlist wlan0 scanning at the terminal.
</rant>

On the more constructive side of things, I got the source code for the gnome-system-tools, and was trying to acertain why massive chunks of src/network/connection.c ar commented out with a FIXME affixed prominently for no apparent reason, but was unable to. If someone can tell me what exactly needs to be fixed I would be willing to attempt and do it myself.

Sebastien Bacher (seb128) wrote :

Le samedi 14 octobre 2006 à 14:11 +0000, Ryan Zeigler a écrit :

> On the more constructive side of things, I got the source code for the
> gnome-system-tools, and was trying to acertain why massive chunks of
> src/network/connection.c ar commented out with a FIXME affixed
> prominently for no apparent reason, but was unable to. If someone can
> tell me what exactly needs to be fixed I would be willing to attempt and
> do it myself.

the backend and the frontend communicate over dbus now instead of using
an xml protocol, the library used for that is liboobs, what is required
is somebody to implement the liboobs methods to do the job and make
gnome-system-tools to use them

Why won't this be fixed for edgy? It's a serious regression.

Sebastien Bacher (seb128) wrote :

because nobody did the work and the desktop team is too busy with other priority to work on that before edgy

manuel (manuel-soto) wrote :

Problem solved after removing all references to the wireless interface in /etc/network/interface. eth1 in my case

John Simpkins (onerobot) wrote :

To work around this and allow your card to autoscan, remove the line

wireless-key ???????????

from /etc/network/interfaces.

Until it's fixed, netapplet makes a good replacement as it has functionality similar to NetworkManager minus the serious brokeness on many chipsets.

Matt Zimmerman (mdz) wrote :

Setting ubuntu-6.10 milestone. This is unlikely to make the final release, but I consider it serious and it will be a candidate for a post-release update if necessary.

Colin Watson (cjwatson) wrote :

Too late for Edgy, but a candidate for edgy-updates.

Peter Tocci (pjtocci) wrote :

Since "upgrading" to edgy, I have to manually type in the name of the network I want to connect to. Im just happy I remember the SSIDs of networks I use.

Changed in gst:
status: Unconfirmed → Fix Released
Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in gnome-system-tools:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

Fixed with that upload:

 gnome-system-tools (2.17.3-0ubuntu1) feisty; urgency=low
 .
   * New upstream version:
     Common:
     - Fix a bunch of compiler warnings everywhere
     - build with latest gnome-doc-utils
     - UI improvements to the "unsupported distribution" dialog
     - install icons in hicolor
     Network:
     - add back wireless detection (included signal strength),
       use libiw for this (Ubuntu: #59159)
     - use theme icons where available
     - fix bug when closing the interfaces configuration dialog
     Services:
     - recognize properly apache2/ssh/sshd/ntpd (Ubuntu: #63596, #69424)
     Time:
     - apply configuration before closing the tool if there are changes pending
     Users:
     - do not fail setting a random password (Ubuntu: #59486)
     - show help and do not close the groups dialog when clicking on 'Help'
       (Ubuntu: #71551)
   * debian/control.in:
     - Build-Depends on libiw-dev
   * debian/patches/04_activate_avahi_option.dpatch:
     - updated
   * debian/patches/19_drop_extra_g_print.dpatch:
     - cleanup extra g_print, it's not useful
   * debian/patches/90_from_cvs_fix_incorrect_loop.dpatch:
     - fixed with the new version
   * debian/patches/98_automake.dpatch:
     - updated
   * debian/rules:
     - the boot tool has been dropped, don't generate a documentation template
       for it
   * debian/watch:
     - updated

Changed in gnome-system-tools:
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

Is this still targetted for backporting to edgy-updates?

Sebastien Bacher (seb128) wrote :

might be, depending on how good the new version work on feisty and if a new requirement on iwlib would be fine for a stable update

Changed in gst:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.