Change log for libdkim package in Ubuntu

115 of 15 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-02-08
Deleted in bionic-proposed (Reason: moved to release)
libdkim (1:1.0.21-4build1) bionic; urgency=high

  * No change rebuild against openssl1.1.

 -- Dimitri John Ledkov <email address hidden>  Mon, 05 Feb 2018 16:50:26 +0000
Superseded in bionic-release on 2018-02-08
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
libdkim (1:1.0.21-4) unstable; urgency=medium

  * fix_warnings.patch: fix narrowing conversion in DecodeBase64()
    (Closes: #811734).
  * openssl1.1.patch (new): Support OpenSSL 1.1 API changes (Closes:
    #828392).
  * Add build-arch and build-indep targets.
  * Use dpkg-buildflags (and use CXXFLAGS when building libdkimtest).
  * Add Svn-* fields.
  * Raise Standards-Version to 3.9.8.

 -- Magnus Holmgren <email address hidden>  Sat, 02 Jul 2016 20:02:15 +0200
Superseded in yakkety-release on 2016-07-03
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2012-02-29
libdkim (1:1.0.21-3build1) precise; urgency=low

  * No-change rebuild against current pkgbinarymangler to fix broken
    md5sums. (see LP #875466)
 -- Martin Pitt <email address hidden>   Wed, 29 Feb 2012 08:40:27 +0100

Available diffs

Superseded in precise-release on 2012-02-29
Obsolete in oneiric-release on 2015-04-24
libdkim (1:1.0.21-3) unstable; urgency=low

  * Completely correct order of object files and libraries (Closes:
    #627387 again).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  15 Jun 2011 09:41:06 +0000

Available diffs

Superseded in oneiric-release on 2011-06-15
libdkim (1:1.0.21-2) unstable; urgency=low

  * debian/Makefile.in: Correct order of object files and libraries when
    linking so that --as-needed will work (Closes: #627387).
  * Convert to source package version 3.0 (quilt).
  * Upgrade to Debhelper compat level 7.
  * Bump Standards-Version to 3.9.2.
 -- Colin Watson <email address hidden>   Tue,  14 Jun 2011 15:33:16 +0000

Available diffs

Superseded in oneiric-release on 2011-06-14
libdkim (1:1.0.21-1ubuntu1) oneiric; urgency=low

  * Fix link ordering for 'ld --as-needed' (LP: #770761).
 -- Colin Watson <email address hidden>   Fri, 20 May 2011 10:25:00 +0100
Superseded in oneiric-release on 2011-05-20
libdkim (1:1.0.21-1build1) oneiric; urgency=low

  * Rebuild for OpenSSL 1.0.0.
 -- Colin Watson <email address hidden>   Tue, 17 May 2011 10:25:29 +0100

Available diffs

Superseded in oneiric-release on 2011-05-17
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
libdkim (1:1.0.21-1) unstable; urgency=low

  * New upstream version.
    * SSP (Sender Signing Practices) replaced by ADSP (Author Domain
      Signing Practices).
  * 30_extra_fields.dpatch: Dropped. The DKIMVerifyDetails structure now
    provides the formerly missing information in the szSignatureDomain and
    szIdentityDomain fields.
  * SONAME changed to libdkim.so.1d because of the above change.
  * Correct bug number (#524133) in the previous changelog entry.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:54:10 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
libdkim (1:1.0.19-4) unstable; urgency=low

  * Add debug package (Closes: #532058).
  * Use strtok_r() instead of strtok() for thread safety (Closes:
    #532740). Patch by Russel Coker.
  * Include built libdkimtest (Closes: #524147).
  * Move examples from library to dev package.
  * Get rid of warnings through the use of const and more correct types
    (Closes: #524147). Patch by Russel Coker.
  * Upgrade package to Standards-Version 3.8.3:
    + Add README.source.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  05 Nov 2009 06:05:05 +0000

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
libdkim (1:1.0.19-3) unstable; urgency=low

  * Don't symlink libdkim-dev's doc directory to that of libdkim*,
    it only adds another place to update when the soname changes.
  * Update debian/copyright; mention the patent license and refer to
    common-licenses for the Apache 2.0 license.
  * Remove Debian revision from symbols file.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  02 Jul 2008 12:18:15 +0100

Available diffs

Superseded in intrepid-release on 2008-07-02
libdkim (1:1.0.19-2) unstable; urgency=low

  * Change the SOVERSION to 0d (d for Debian) to avoid potential future
    clashes.
  * Bring back the version script, but only to hide internal symbols.
  * Add initial symbols file.

Available diffs

Superseded in intrepid-release on 2008-06-23
libdkim (1:1.0.19-1) unstable; urgency=low

  * New upstream release.
    - Drop remaining patches; issues fixed upstream.
  * New maintainer email address.
  * Include Yahoo! patent license as plain text.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  19 May 2008 07:40:46 +0100
Superseded in intrepid-release on 2008-05-19
libdkim (1:1.0.17-1) unstable; urgency=low

  * New upstream release.
  * Drop 20_winmacros.dpatch; fixed upstream.
  * Bump soname to libdkim1 because of incompatible struct changes.
  * 20_strict_includes.dpatch (new): Add "#include <string.h>" as necessary
    to fix FTBFS with GCC 4.3 (Closes: #455145).
  * Add an epoch to reclaim binary packages "stolen" by dkim-milter.
  * Dump the linker version script - changing the soname when necessary is
    going to be hard enough.
  * Move homepage URL from description to control field.
  * Increase Standards-Version to 3.7.3 without changes.
  * Don't ignore distclean errors.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  02 May 2008 02:13:32 +0100
Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
libdkim (1.0.14-1) unstable; urgency=low

  * New upstream release.
  * Build-depend on pkg-config.
  * Use dpatch to apply changes to upstream.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  06 May 2007 08:08:29 +0100
Superseded in gutsy-release on 2007-05-06
libdkim (1.0.13-1) unstable; urgency=low

  * Initial release (Closes: #410829).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  02 May 2007 14:05:30 +0100
115 of 15 results