Change log for libxrandr package in Ubuntu

140 of 40 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-24
Published in focal-release on 2019-10-18
Obsolete in eoan-release on 2020-12-29
Deleted in eoan-proposed (Reason: moved to release)
libxrandr (2:1.5.2-0ubuntu1) eoan; urgency=medium

  * New upstream version

 -- Sebastien Bacher <email address hidden>  Sat, 24 Aug 2019 18:11:31 +0300
Superseded in eoan-release on 2019-08-24
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
libxrandr (2:1.5.1-1) unstable; urgency=medium

  [ Andreas Boll ]
  * New upstream release.
    - Fixes CVE-2016-7947 and CVE-2016-7948 (Closes: #840441).
  * Update d/upstream/signing-key.asc with Matthieu Herrb's key.
  * Update a bunch of URLs in packaging to https.
  * Bump Standards-Version to 3.9.8, no changes needed.

  [ Emilio Pozuelo Monfort ]
  * Bump debhelper compat to 10.
    + --with autoreconf is enabled by default now. Drop build-deps on
      dh-autoreconf, automake and libtool.
  * debhelper installs to debian/tmp by default, no need to specify it.
  * Switch to -dbgsym packages.
  * Pass -c4 to dpkg-gensymbols.
  * Drop no longer needed dpkg-dev versioned build-dependency.

 -- Emilio Pozuelo Monfort <email address hidden>  Wed, 07 Dec 2016 00:17:09 +0100

Available diffs

Published in trusty-updates on 2016-07-29
Deleted in trusty-proposed (Reason: moved to -updates)
libxrandr (2:1.5.0-1~trusty1) trusty; urgency=medium

  * Backport for lts-xenial stack. (LP: #1577734)

 -- Timo Aaltonen <email address hidden>  Tue, 03 May 2016 16:25:01 +0300
Superseded in zesty-release on 2016-12-11
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
libxrandr (2:1.5.0-1) sid; urgency=medium

  * New upstream release.
  * control: Bump policy to 3.9.6, no changes.
  * Let uscan verify tarball signatures.
  * control: Bump x11proto-randr-dev build-dep.
  * symbols: Updated.
  * Bump compat to 9, migrate to dh.
  * Purge xsfbs.

 -- Timo Aaltonen <email address hidden>  Mon, 27 Jul 2015 23:20:59 +0300
Superseded in wily-release on 2015-08-04
Deleted in wily-proposed on 2015-08-06 (Reason: moved to release)
libxrandr (2:1.5.0-0ubuntu1) wily; urgency=medium

  * New upstream release (LP: #1473828)
  * debian/control:
    - Bump build-depends on libx11-dev, x11proto-randr-dev
  * debian/libxrandr2.symbols:
    - Updated

 -- Robert Ancell <email address hidden>  Tue, 14 Jul 2015 14:27:03 +1200
Published in precise-updates on 2015-04-13
Published in precise-security on 2015-04-13
libxrandr (2:1.3.2-2ubuntu0.3) precise-security; urgency=medium

  * SECURITY UPDATE: buffer overflow in MakeBigReq (LP: #1441381)
    - debian/control: change Build-Depends to libx11 security update
    - CVE-2013-7439
 -- Marc Deslauriers <email address hidden>   Mon, 13 Apr 2015 08:15:51 -0400
Superseded in wily-release on 2015-07-15
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-01-23
Deleted in trusty-proposed (Reason: moved to release)
libxrandr (2:1.4.2-1) sid; urgency=medium


  * New upstream release.
  * Update debian/copyright.
  * Remove Cyril Brulebois from Uploaders.

 -- Julien Cristau <email address hidden>  Mon, 20 Jan 2014 14:48:07 +0100
Superseded in trusty-release on 2014-01-23
Deleted in trusty-proposed on 2014-01-24 (Reason: moved to release)
libxrandr (2:1.4.1-1ubuntu1) trusty; urgency=low

  * Merge from debian. Remaining changes:
    - fix-kwin-crashes-on-xrandr-update-on-NX.diff
  * Drop CVE-2013-1986.patch, fixed upstream

Superseded in trusty-release on 2013-10-26
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
libxrandr (2:1.4.0-1ubuntu2) saucy; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-1986.patch: fix multiple overflows.
    - CVE-2013-1986
 -- Marc Deslauriers <email address hidden>   Wed, 05 Jun 2013 15:37:02 -0400
Obsolete in raring-updates on 2015-04-24
Obsolete in raring-security on 2015-04-24
libxrandr (2:1.4.0-1ubuntu1.1) raring-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-1986.patch: fix multiple overflows.
    - CVE-2013-1986
 -- Marc Deslauriers <email address hidden>   Tue, 28 May 2013 10:46:52 -0400
Obsolete in quantal-updates on 2015-04-24
Obsolete in quantal-security on 2015-04-24
libxrandr (2:1.4.0-1ubuntu0.1) quantal-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-1986.patch: fix multiple overflows.
    - CVE-2013-1986
 -- Marc Deslauriers <email address hidden>   Tue, 28 May 2013 10:49:46 -0400
Superseded in precise-updates on 2015-04-13
Superseded in precise-security on 2015-04-13
libxrandr (2:1.3.2-2ubuntu0.2) precise-security; urgency=low

  * SECURITY UPDATE: denial of service and possible code execution via
    incorrect memory size calculations
    - debian/patches/CVE-2013-1986.patch: fix multiple overflows.
    - CVE-2013-1986
 -- Marc Deslauriers <email address hidden>   Tue, 28 May 2013 10:53:26 -0400
Superseded in precise-updates on 2013-06-05
Deleted in precise-proposed on 2013-06-07 (Reason: moved to -updates)
libxrandr (2:1.3.2-2ubuntu0.1) precise-proposed; urgency=low

  * fix-kwin-crashes-on-xrandr-update-on-NX.diff: Fix kwin crashing on
    xrandr update (LP: #985202)
 -- Timo Aaltonen <email address hidden>   Tue, 19 Feb 2013 09:50:02 +0200

Available diffs

Superseded in saucy-release on 2013-06-05
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
libxrandr (2:1.4.0-1ubuntu1) raring; urgency=low

  * fix-kwin-crashes-on-xrandr-update-on-NX.diff: Fix kwin crashing on
    xrandr update (LP: #985202)
 -- Timo Aaltonen <email address hidden>   Wed, 06 Mar 2013 17:27:48 +0200
Superseded in raring-release on 2013-02-06
Obsolete in quantal-release on 2015-04-24
libxrandr (2:1.4.0-1) experimental; urgency=low


  [ Maarten Lankhorst ]
  * New upstream release
  * Bump Standards-Version to 3.9.3

  [ Julien Cristau ]
  * Make clean target work without (fake)root

 -- Julien Cristau <email address hidden>  Fri, 03 Aug 2012 12:02:08 +0200

Available diffs

Superseded in quantal-release on 2012-08-15
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
libxrandr (2:1.3.2-2) unstable; urgency=low

  * Brown paper bag upload:
    - Merge back origin/debian-unstable, fixing the loss of the
      2:1.3.1-2 upload (including multiarch changes).

Available diffs

Superseded in oneiric-release on 2011-06-30
libxrandr (2:1.3.1-2) unstable; urgency=low

  * Team upload.

  [ Steve Langasek ]
  * Build for multiarch.

  [ Julien Cristau ]
  * Remove David Nusinow from Uploaders.
  * Bump Standards-Version to 3.9.2.
 -- Steve Langasek <email address hidden>   Sun,  12 Jun 2011 21:35:52 +0000

Available diffs

Superseded in oneiric-release on 2011-06-12
Obsolete in natty-release on 2013-06-04
libxrandr (2:1.3.1-1ubuntu1) natty; urgency=low

  * FFe LP: #733501: build for multiarch.
 -- Steve Langasek <email address hidden>   Wed, 23 Mar 2011 23:14:52 -0700

Available diffs

Superseded in natty-release on 2011-03-24
libxrandr (2:1.3.1-1) unstable; urgency=low

  * New upstream release.
  * Bump xutils-dev build-dep for new macros.
  * Update debian/copyright from upstream COPYING.
  * Switch from --list-missing to --fail-missing for additional safety.
  * Exclude libXrandr.la from dh_install accordingly.
  * Add myself to Uploaders.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  20 Nov 2010 11:15:47 +0000

Available diffs

Superseded in natty-release on 2010-11-20
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
libxrandr (2:1.3.0-3) unstable; urgency=low

  [ Timo Aaltonen ]
  * Drop pre-dependency on x11-common from libxrandr-dev. This was needed
    for upgrades from sarge.
  * Move -dbg package to section debug.
  * Bump Standards-Version to 3.8.3.

  [ Julien Cristau ]
  * Rename the build directory to not include DEB_BUILD_GNU_TYPE for no
    good reason.  Thanks, Colin Watson!
  * Remove myself from Uploaders

  [ Brice Goglin ]
  * Remove Jamey Sharp and Josh Triplett from Uploaders, closes: #568282.
 -- Timo Aaltonen <email address hidden>   Mon,  22 Mar 2010 19:08:30 +0000

Available diffs

Superseded in lucid-release on 2010-03-22
libxrandr (2:1.3.0-2build1) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Sun, 07 Mar 2010 00:55:50 +0100

Available diffs

Superseded in lucid-release on 2010-03-07
Obsolete in karmic-release on 2013-03-04
libxrandr (2:1.3.0-2) unstable; urgency=low

  * libxrandr-dev depends on randrproto 1.3 (closes: #519981).  Thanks, Adrian
    Bunk!

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 12:02:46 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
libxrandr (2:1.3.0-1build1) jaunty; urgency=low

  * No-change rebuild to fix lpia shared library dependencies.

 -- Colin Watson <email address hidden>   Thu, 19 Mar 2009 01:48:54 +0000

Available diffs

Superseded in jaunty-release on 2009-03-19
libxrandr (2:1.3.0-1) unstable; urgency=low

  * New upstream release.
  * Bump randrproto build-dep to 1.3.
  * Bump shlibs.
  * Update debian/copyright.

 -- Bryce Harrington <email address hidden>   Mon,  16 Mar 2009 08:11:58 +0000

Available diffs

Superseded in jaunty-release on 2009-03-16
libxrandr (2:1.2.99.4-2) experimental; urgency=low

  * Cherry-pick patch from upstream git to fix XRRGetOutputPrimary.

 -- Bryce Harrington <email address hidden>   Fri,  27 Feb 2009 18:28:33 +0000

Available diffs

Superseded in jaunty-release on 2009-02-27
libxrandr (2:1.2.99.4-1) experimental; urgency=low

  [ Timo Aaltonen ]
  * New upstream prerelease.
  * debian/control:
    - Build-depend on automake, libtool, xutils-dev.
    - Split the build-depends to span multiple lines.
    - Bump the build-dep on x11proto-randr-dev to (>= 1.2.99.2).
  * debian/rules:
    - Run autoreconf -vfi on configure.
  * debian/libxrandr2.symbols: Add the new symbols.

  [ Julien Cristau ]
  * Update from 1.2.99.2 to 1.2.99.4
  * Bump x11proto-randr-dev build and runtime dependencies to >= 1.2.99.3.
  * debian/libxrandr2.symbols: add new symbols.

 -- Timo Aaltonen <email address hidden>   Tue,  06 Jan 2009 10:32:47 +0000

Available diffs

Superseded in jaunty-release on 2009-01-06
libxrandr (2:1.2.99.2-0ubuntu1) jaunty; urgency=low

  * Merge from debian experimental git branch.

Available diffs

Superseded in jaunty-release on 2008-12-09
Obsolete in intrepid-release on 2013-02-20
libxrandr (2:1.2.3-1) unstable; urgency=low

  [ Brice Goglin ]
  * Add a link to www.X.org in the long description.
  * Add upstream URL to debian/copyright.

  [ Julien Cristau ]
  * New upstream release.

 -- Bryce Harrington <email address hidden>   Thu,  28 Aug 2008 01:37:46 +0100

Available diffs

Superseded in intrepid-release on 2008-08-28
libxrandr (2:1.2.2-2) unstable; urgency=low

  * Add debian/libxrandr2.symbols.
    Symbols added in the first version (RandR protocol 1.0) carry no version,
    symbols added for RandR 1.1 need >= 4.3, and RandR 1.2 symbols need
    libxrandr2 >= 2:1.2.0.
  * Drop -1 debian revisions from build-deps.
  * Bump Standards-Version to 3.7.3.
  * Drop the XS- prefix from Vcs-* control fields.
  * libxrandr2{,-dbg} don't need to depend on x11-common.
  * Merge changes from the 7.1 branch (libxrandr 1.1.1) which had never been
    merged to the trunk (yes, that was two years ago).

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  19 May 2008 13:39:39 +0100
Superseded in intrepid-release on 2008-05-19
Obsolete in hardy-release on 2015-04-24
libxrandr (2:1.2.2-1) unstable; urgency=low

  * New upstream release.
  * Add myself to Uploaders, and remove Branden and Fabio with their
    permission.
  * Use ${binary:Version} instead of ${Source-Version}.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 17:32:34 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
libxrandr (2:1.2.1-1) unstable; urgency=low

  * New upstream release.
  * Upload to unstable.
  * Add XS-Vcs-Browser.

Superseded in gutsy-release on 2007-05-16
Obsolete in feisty-release on 2009-08-20
libxrandr (2:1.2.0-3ubuntu1) feisty; urgency=low

  * Add 01_fix_variable_name_delete.diff, 'delete' is a reserved
    word in c++, so Xrandr.h cannot be imported to build KDE.
    Ping upstream and debian about the issue.

 -- Anthony Mercatante <email address hidden>   Thu, 22 Feb 2007 22:13:31 +0100
Superseded in feisty-release on 2007-02-22
libxrandr (2:1.2.0-3) experimental; urgency=low

  * Add debian/libxrandr2.shlibs, thanks to Michel Dänzer for noticing my
    mistake.

Superseded in feisty-release on 2007-02-20
Obsolete in edgy-release on 2008-06-19
libxrandr (2:1.1.1-0ubuntu1) edgy; urgency=low

  * New Upstream version
  * Dropped 01_manpage_location.diff (applied upstream)
  * Dropped debian/patches subdirectory as its empty now

 -- Rodrigo Parra Novo <email address hidden>   Fri, 21 Jul 2006 16:54:01 -0300
Superseded in edgy-release on 2006-07-21
libxrandr (2:1.1.0.2-4ubuntu1) edgy; urgency=low

  * Merge with Debian due to orig.tar.gz mismatch:
    - Ship the man pages.

Superseded in edgy-release on 2006-07-07
Obsolete in dapper-release on 2011-09-06
libxrandr (1:1.1.0.2-0ubuntu4) dapper; urgency=low

  * what about shipping the man pages too?

 -- Fabio M. Di Nitto <email address hidden>   Mon, 01 May 2006 12:39:40 +0200
Superseded in dapper-release on 2006-05-01
libxrandr (1:1.1.0.2-0ubuntu3) dapper; urgency=low

  * Define LIB_MAN_SUFFIX=3 at configure time.

  * Change the Maintainer field.

 -- Fabio M. Di Nitto <email address hidden>   Mon, 01 May 2006 12:37:44 +0200
Superseded in dapper-release on 2006-05-01
Superseded in dapper-release on 2006-02-03
libxrandr (1:1.1.0.2-0ubuntu2) dapper; urgency=low


  * Change dependency on x-common to x11-common.

 -- Daniel Stone <email address hidden>  Thu, 19 Jan 2006 18:32:00 +1100
Superseded in dapper-release on 2006-01-31
libxrandr (1:1.1.0.2-0ubuntu1) dapper; urgency=low


  * New upstream release.

 -- Daniel Stone <email address hidden>  Wed, 21 Dec 2005 13:32:31 +1100
Obsolete in breezy-release on 2008-03-25
libxrandr (1:1.0.2-2) breezy; urgency=low


  * Update Build-Depends on libx11-dev and libxext-dev to avoid _XOPEN_SOURCE.

 -- Daniel Stone <email address hidden>  Sat, 23 Jul 2005 00:00:57 +1000
140 of 40 results