linux-hwe 4.8.0-58.63~16.04.1 source package in Ubuntu

Changelog

linux-hwe (4.8.0-58.63~16.04.1) xenial; urgency=low

  * linux-hwe: 4.8.0-58.63~16.04.1 -proposed tracker (LP: #1700534)

  * linux: 4.8.0-58.63 -proposed tracker (LP: #1700533)

  * CVE-2017-1000364
    - Revert "UBUNTU: SAUCE: mm: Only expand stack if guard area is hit"
    - Revert "mm: do not collapse stack gap into THP"
    - Revert "mm: enlarge stack guard gap"
    - mm: vma_adjust: remove superfluous confusing update in remove_next == 1 case
    - mm: larger stack guard gap, between vmas
    - mm: fix new crash in unmapped_area_topdown()
    - Allow stack to grow up to address space limit

linux (4.8.0-57.62) yakkety; urgency=low

  * linux: 4.8.0-57.62 -proposed tracker (LP: #1699035)

  * CVE-2017-1000364
    - SAUCE: mm: Only expand stack if guard area is hit

  * CVE-2017-7374
    - fscrypt: remove broken support for detecting keyring key revocation

  * CVE-2017-100363
    - char: lp: fix possible integer overflow in lp_setup()

  * CVE-2017-9242
    - ipv6: fix out of bound writes in __ip6_append_data()

  * CVE-2017-9075
    - sctp: do not inherit ipv6_{mc|ac|fl}_list from parent

  * CVE-2017-9074
    - ipv6: Prevent overrun when parsing v6 header options

  * CVE-2017-9076
    - ipv6/dccp: do not inherit ipv6_mc_list from parent

  * CVE-2017-9077
    - ipv6/dccp: do not inherit ipv6_mc_list from parent

  * CVE-2017-8890
    - dccp/tcp: do not inherit mc_list from parent

  * extend-diff-ignore should use exact matches (LP: #1693504)
    - [Packaging] exact extend-diff-ignore matches

  * APST quirk needed for Intel NVMe (LP: #1686592)
    - nvme: Quirk APST on Intel 600P/P3100 devices

  * regression: the 4.8 hwe kernel does not create the
    /sys/block/*/device/enclosure_device:* symlinks (LP: #1691899)
    - scsi: ses: Fix SAS device detection in enclosure

  * datapath: Add missing case OVS_TUNNEL_KEY_ATTR_PAD (LP: #1676679)
    - openvswitch: Add missing case OVS_TUNNEL_KEY_ATTR_PAD

  * connection flood to port 445 on mounting cifs volume under kernel
    (LP: #1686099)
    - cifs: Do not send echoes before Negotiate is complete

  * Support IPMI system interface on Cavium ThunderX (LP: #1688132)
    - i2c: octeon: Rename driver to prepare for split
    - i2c: octeon: Split the driver into two parts
    - [Config] CONFIG_I2C_THUNDERX=m
    - i2c: thunderx: Add i2c driver for ThunderX SOC
    - i2c: thunderx: Add SMBUS alert support
    - i2c: octeon,thunderx: Move register offsets to struct
    - i2c: octeon: Sort include files alphabetically
    - i2c: octeon: Use booleon values for booleon variables
    - i2c: octeon: thunderx: Add MAINTAINERS entry
    - i2c: octeon: Fix set SCL recovery function
    - i2c: octeon: Avoid sending STOP during recovery
    - i2c: octeon: Fix high-level controller status check
    - i2c: octeon: thunderx: TWSI software reset in recovery
    - i2c: octeon: thunderx: Remove double-check after interrupt
    - i2c: octeon: thunderx: Limit register access retries
    - i2c: thunderx: Enable HWMON class probing

  * CVE-2017-5577
    - drm/vc4: Return -EINVAL on the overflow checks failing.

  * Merlin SGMII fail on Ubuntu Xenial HWE kernel (LP: #1686305)
    - net: phy: marvell: fix Marvell 88E1512 used in SGMII mode
    - drivers: net: phy: xgene: Fix mdio write

  * Keyboard backlight control does not work on some dell laptops.
    (LP: #1693126)
    - platform/x86: dell-laptop: Add Latitude 7480 and others to the DMI whitelist
    - platform/x86: dell-laptop: Add keyboard backlight timeout AC settings

  * exec'ing a setuid binary from a threaded program sometimes fails to setuid
    (LP: #1672819)
    - SAUCE: exec: ensure file system accounting in check_unsafe_exec is correct

  * CVE-2017-7294
    - drm/vmwgfx: fix integer overflow in vmw_surface_define_ioctl()

 -- Stefan Bader <email address hidden>  Mon, 26 Jun 2017 17:31:13 +0200

Upload details

Uploaded by:
Stefan Bader on 2017-06-26
Uploaded to:
Xenial
Original maintainer:
Ubuntu Kernel Team
Architectures:
all i386 amd64 armhf arm64 invalid ppc64el s390x
Section:
devel
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
linux-hwe_4.8.0.orig.tar.gz 133.5 MiB 80229497a1584076d534e96acf529a01a0fc00044eba9e6c00ae936e453dbd3c
linux-hwe_4.8.0-58.63~16.04.1.diff.gz 13.5 MiB 3205cb6a35ae9ca5419d1a85883bef67b32accdb8e2a6c2a8fb25b4f46ac0eb0
linux-hwe_4.8.0-58.63~16.04.1.dsc 8.3 KiB 3442a8daecb1f02c99a5562ea676a751be76cec50ff648ddfba7fc7241c5d1d3

View changes file

Binary packages built by this source

block-modules-4.8.0-58-generic-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

block-modules-4.8.0-58-generic-lpae-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

crypto-modules-4.8.0-58-generic-di: crypto modules

 This package contains crypto modules.

crypto-modules-4.8.0-58-generic-lpae-di: crypto modules

 This package contains crypto modules.

dasd-extra-modules-4.8.0-58-generic-di: DASD storage support -- extras
dasd-modules-4.8.0-58-generic-di: DASD storage support
fat-modules-4.8.0-58-generic-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fat-modules-4.8.0-58-generic-lpae-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fb-modules-4.8.0-58-generic-di: Framebuffer modules
firewire-core-modules-4.8.0-58-generic-di: Firewire (IEEE-1394) Support
floppy-modules-4.8.0-58-generic-di: Floppy driver support
fs-core-modules-4.8.0-58-generic-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-core-modules-4.8.0-58-generic-lpae-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-secondary-modules-4.8.0-58-generic-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

fs-secondary-modules-4.8.0-58-generic-lpae-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

input-modules-4.8.0-58-generic-di: Support for various input methods
input-modules-4.8.0-58-generic-lpae-di: Support for various input methods
ipmi-modules-4.8.0-58-generic-di: ipmi modules
ipmi-modules-4.8.0-58-generic-lpae-di: ipmi modules
irda-modules-4.8.0-58-generic-di: Support for Infrared protocols
irda-modules-4.8.0-58-generic-lpae-di: Support for Infrared protocols
kernel-image-4.8.0-58-generic-di: kernel image and system map
kernel-image-4.8.0-58-generic-lpae-di: kernel image and system map
linux-cloud-tools-4.8.0-58-generic: Linux kernel version specific cloud tools for version 4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 4.8.0-58 on
 64 bit x86.

linux-cloud-tools-4.8.0-58-lowlatency: Linux kernel version specific cloud tools for version 4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 4.8.0-58 on
 64 bit x86.

linux-headers-4.8.0-58: Header files related to Linux kernel version 4.8.0

 This package provides kernel header files for version 4.8.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-hwe-headers-4.8.0-58/debian.README.gz for details

linux-headers-4.8.0-58-generic: Linux kernel headers for version 4.8.0 on ARM (hard float) SMP

 This package provides kernel header files for version 4.8.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.8.0-58/debian.README.gz for details.

linux-headers-4.8.0-58-generic-lpae: Linux kernel headers for version 4.8.0 on ARM (hard float) SMP

 This package provides kernel header files for version 4.8.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.8.0-58/debian.README.gz for details.

linux-headers-4.8.0-58-lowlatency: Linux kernel headers for version 4.8.0 on 64 bit x86 SMP

 This package provides kernel header files for version 4.8.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.8.0-58/debian.README.gz for details.

linux-hwe-cloud-tools-4.8.0-58: Linux kernel version specific cloud tools for version 4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 4.8.0-58 on
 64 bit x86.
 You probably want to install linux-cloud-tools-4.8.0-58-<flavour>.

linux-hwe-cloud-tools-4.8.0-58-dbgsym: debug symbols for package linux-hwe-cloud-tools-4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 4.8.0-58 on
 64 bit x86.
 You probably want to install linux-cloud-tools-4.8.0-58-<flavour>.

linux-hwe-tools-4.8.0-58: Linux kernel version specific tools for version 4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.8.0-58 on
 ARM (hard float).
 You probably want to install linux-tools-4.8.0-58-<flavour>.

linux-hwe-tools-4.8.0-58-dbgsym: debug symbols for package linux-hwe-tools-4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.8.0-58 on
 ARM (hard float).
 You probably want to install linux-tools-4.8.0-58-<flavour>.

linux-hwe-udebs-generic: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-hwe-udebs-generic-lpae: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-image-4.8.0-58-generic: Linux kernel image for version 4.8.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 4.8.0 on
 ARM (hard float) SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.8.0-58-generic-dbgsym: Linux kernel debug image for version 4.8.0 on ARM (hard float) SMP

 This package provides a kernel debug image for version 4.8.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-4.8.0-58-generic-lpae: Linux kernel image for version 4.8.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 4.8.0 on
 ARM (hard float) SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.8.0-58-generic-lpae-dbgsym: Linux kernel debug image for version 4.8.0 on ARM (hard float) SMP

 This package provides a kernel debug image for version 4.8.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-4.8.0-58-lowlatency: Linux kernel image for version 4.8.0 on 64 bit x86 SMP

 This package contains the Linux kernel image for version 4.8.0 on
 64 bit x86 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.8.0-58-lowlatency-dbgsym: Linux kernel debug image for version 4.8.0 on 64 bit x86 SMP

 This package provides a kernel debug image for version 4.8.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-extra-4.8.0-58-generic: Linux kernel extra modules for version 4.8.0 on 64 bit x86 SMP

 This package contains the Linux kernel extra modules for version 4.8.0 on
 64 bit x86 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-source-4.8.0: Linux kernel source for version 4.8.0 with Ubuntu patches

 This package provides the source code for the Linux kernel version
 4.8.0.
 .
 This package is mainly meant for other packages to use, in order to build
 custom flavours.
 .
 If you wish to use this package to create a custom Linux kernel, then it
 is suggested that you investigate the package kernel-package, which has
 been designed to ease the task of creating kernel image packages.
 .
 If you are simply trying to build third-party modules for your kernel,
 you do not want this package. Install the appropriate linux-headers
 package instead.

linux-tools-4.8.0-58-generic: Linux kernel version specific tools for version 4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.8.0-58 on
 ARM (hard float).

linux-tools-4.8.0-58-generic-lpae: Linux kernel version specific tools for version 4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.8.0-58 on
 ARM (hard float).

linux-tools-4.8.0-58-lowlatency: Linux kernel version specific tools for version 4.8.0-58

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.8.0-58 on
 64 bit x86.

md-modules-4.8.0-58-generic-di: Multi-device support (raid, device-mapper, lvm)
md-modules-4.8.0-58-generic-lpae-di: Multi-device support (raid, device-mapper, lvm)
message-modules-4.8.0-58-generic-di: Fusion and i2o storage modules

 This package containes the fusion and i2o storage modules.

mouse-modules-4.8.0-58-generic-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

mouse-modules-4.8.0-58-generic-lpae-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

multipath-modules-4.8.0-58-generic-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

multipath-modules-4.8.0-58-generic-lpae-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

nfs-modules-4.8.0-58-generic-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nfs-modules-4.8.0-58-generic-lpae-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nic-modules-4.8.0-58-generic-di: Network interface support
nic-modules-4.8.0-58-generic-lpae-di: Network interface support
nic-pcmcia-modules-4.8.0-58-generic-di: PCMCIA network interface support
nic-shared-modules-4.8.0-58-generic-di: nic shared modules

  This package contains modules which support nic modules

nic-shared-modules-4.8.0-58-generic-lpae-di: nic shared modules

  This package contains modules which support nic modules

nic-usb-modules-4.8.0-58-generic-di: USB network interface support
nic-usb-modules-4.8.0-58-generic-lpae-di: USB network interface support
parport-modules-4.8.0-58-generic-di: Parallel port support
parport-modules-4.8.0-58-generic-lpae-di: Parallel port support
pata-modules-4.8.0-58-generic-di: PATA support modules
pcmcia-modules-4.8.0-58-generic-di: PCMCIA Modules
pcmcia-storage-modules-4.8.0-58-generic-di: PCMCIA storage support
plip-modules-4.8.0-58-generic-di: PLIP (parallel port) networking support
plip-modules-4.8.0-58-generic-lpae-di: PLIP (parallel port) networking support
ppp-modules-4.8.0-58-generic-di: PPP (serial port) networking support
ppp-modules-4.8.0-58-generic-lpae-di: PPP (serial port) networking support
sata-modules-4.8.0-58-generic-di: SATA storage support
sata-modules-4.8.0-58-generic-lpae-di: SATA storage support
scsi-modules-4.8.0-58-generic-di: SCSI storage support
scsi-modules-4.8.0-58-generic-lpae-di: SCSI storage support
serial-modules-4.8.0-58-generic-di: Serial port support
storage-core-modules-4.8.0-58-generic-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

storage-core-modules-4.8.0-58-generic-lpae-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

usb-modules-4.8.0-58-generic-di: Core USB support
usb-modules-4.8.0-58-generic-lpae-di: Core USB support
virtio-modules-4.8.0-58-generic-di: VirtIO Modules

 Includes modules for VirtIO (virtual machine, generally kvm guests)

vlan-modules-4.8.0-58-generic-di: vlan modules

 This package contains vlan (8021.Q) modules.

vlan-modules-4.8.0-58-generic-lpae-di: vlan modules

 This package contains vlan (8021.Q) modules.