Parallels Desktop for Mac Optical Drive not recognized

Bug #95830 reported by Eric Kerby on 2007-03-25
6
Affects Status Importance Assigned to Milestone
linux-source-2.6.20 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.20

This only applies to kernel version 2.6.20-12 and later as far as I can tell.

Description:
This testing was done on a Mac Pro in a Parallels Desktop (build 3188) for Mac virtual machine set to OS Type: Linux and OS Version: Other Linux kernel 2.6. The issue also happens with OS Version set to Debian. This install was done as Ubuntu Feisty Herd 5 since I am not able to boot Feisty Beta due to the optical drive recognition issue I am describing.
When booting the virtual machine from the live cd or a full installation of Ubuntu Feisty Fawn (herd 5 in this case) with the Parallels CD/DVD-ROM set to be the Mac Pro's physical optical drive and set to Connect at startup, the optical drive does not get recognized properly by kernel version 2.6.20-12-generic.

Kernel versions 2.6.20-11-generic and 2.6.20-9-generic have been confirmed to work and read the inserted CD properly in the same virtual machine. When I say that the optical drive does not get recognized, I mean that if you open the Computer in Nautilus and double click on CD-ROM 1, the error "Unable to mount the selected volume. mount: special device /dev/hdb does not exist." In earlier kernel versions, the CD drive shows up in the Computer list as CD-RW/DVD+RW and shows up on the desktop after logging in.

The optical drive installed in my Mac Pro as reported by Apple is: SONY DVD RW DW-D150A. In Ubuntu, if I right click on the drive in the Computer list, click Properties, and go to the Drive tab, the Model listed is: PRL CD-ROM [1] and Firmware: FMR10003. I assume PRL there stands for Parallels since they virtualize most hardware components in that way.

I would blame Parallels for this problem, but I have to claim this is a kernel bug since earlier kernel versions worked flawlessly. Also, note that this issue exists in Fedora 7 as well. Kernel version 2.6.20-1.2933.fc6 in Fedora Core 6 works with the drive just fine. All kernel versions in Fedora 7 test 2 that I have tried (2.6.20-1.2949.fc7, 2.6.20-1.3003.fc7, and 2.6.20-1.3017.fc7) have basically the exact problem I described above.

Also note that both the desktop and alternate versions of the Ubuntu Feisty Beta install CD fail to boot on this virtual machine due to the optical drive problem. After hitting enter to begin booting the live CD, some text scrolls and then the usual "ACPI: Unable to locate RSDP" displays followed by "Loading, please wait..." The screen then goes blank to start loading the graphical progress, but remains blank. If you switch the terminal to tty1 by pressing ctrl+alt+F1, you see that "ata2: rest failed, giving up" displayed. After that are a bunch of ata1.01 errors. I am attaching some screenshots to this report to illustrate this.

Eric Kerby (erickerby) wrote :

I attached the Parallels screenshot I mentioned to this comment.

If there is any more information I could provide that would help fix this issue, I would be more than glad to help. I obviously have a high interest in seeing this resolved. I also wonder if other Parallels for Mac users are experiencing this.

Eric Kerby (erickerby) wrote :

Here is the changelog at http://changelogs.ubuntu.com/changelogs/pool/main/l/linux-source-2.6.20/linux-source-2.6.20_2.6.20-13.21/changelog for the kernel version of interest in this bug. I did not spot anything too noticeable, but maybe someone else will:

------------------trim------------------
linux-source-2.6.20 (2.6.20-12.20) feisty; urgency=low

  [Upstream Kernel Changes]

  * pci_iomap_regions() error handling fix
    - Fixes bug #93648

 -- Ben Collins <email address hidden> Wed, 21 Mar 2007 11:47:18 -0400

linux-source-2.6.20 (2.6.20-12.19) feisty; urgency=low

  [Ben Collins]

  * piix: Fix typo that allowed this module to override ata_piix.
    - GIT-SHA 80bc1fd97d95519b2ab8c5007924f9e591838351
    - Bug #84964
  * vdso: Fix incompatibility between vdso and paravirt+vmi
    - GIT-SHA 83821a009b3ec3f3d3ebaeda9a4f45900928900c
  * drivers/ata/: Sync with upstream for new drivers and acpi fixes.
    - GIT-SHA c38186b50b5d8444091a2f974e035abeb783499b
  * debian/d-i/: Update sata/pata module listings.
    - GIT-SHA e2c160419a8c50e9adc5de4b81e33251a7e952af
  * rt2x00: Disable module aliases if legacy drivers are built.
    - GIT-SHA a4e3d596f4b304e01ce04e43762ddf3873635a8c
  * rt2x00-legacy: Re-add some legacy drivers since mainline isn't working
    everywhere yet.
    - GIT-SHA 59992a59a531f62aeb82384abc8296779092f1cc
  * rt2x00-legacy/rt61: Fix big-endian compilation.
    - GIT-SHA 6603c59fa3aee248aaf5ae73015ad155977ddad8
  * lib/iomap: Only build on architectures that need it.
    - GIT-SHA fb3d5ca41505e11b8cd2cd85bc8db0571d58a6ae
  * rt61: Fixup build on ppc.
    - GIT-SHA 8c7eebfaf5c0ea44e7a77165894ebd3861ed3668

  [Dan Hecht]

  * Feisty VMI paravirt-ops: Fix cpu hotplug on VMI
    - GIT-SHA 44bbb009bb465537b9d7660a101641174f67b678

  [Daniel T. Chen]

  * sound/pci/hda/: LP: #92909: Fix regression in -11.18 for Toshiba
    Satellite M115 - S3094 (patch_realtek.c)
    - GIT-SHA ff352c874a71fcce9af5f04d19360a0a8a4318b8
  * sound/pci/: LP: #90349: Add SSID for Dell Inspiron 9100 to headphone
    quirk table (intel8x0.c)
    - GIT-SHA 94ea2cdff6440a5bc8602cc8431380a690520f80

  [Fabio M. Di Nitto]

  * Make scsi_proc_hostdir_add silent on failure
    - GIT-SHA a6ad8ab034e40e188825cede360f69e8101351d3

  [Upstream Kernel Changes]

  * <GROUP> Synced drivers/ata/
  * ACPI support for IDE devices
  * ide-acpi support warning fix
  * Disable NMI watchdog by default properly
  * devres: device resource management
  * sort the devres mess out
  * Add pci class code for SATA & AHCI, and replace some magic numbers.
  * PCI: allow multiple calls to pcim_pin_device()
  * devres: release resources on device_del()

 -- Ben Collins <email address hidden> Sat, 17 Mar 2007 11:15:27 -0400
------------------trim------------------

Eric Kerby (erickerby) wrote :

Now that the 2.6.20-13 kernel has been released, I should say that this Parallels optical drive problem still exists. So...add that version to the affected kernels.

Tim Gardner (timg-tpi) on 2007-03-26
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Unconfirmed → Confirmed

Confirmed bug occurs on build 3186 (MacBook Pro).

Bug doesn't occur on build 1970. While we trackdown the source of the bug, this may be a temporary workaround.

Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → phillip-lougher
status: Confirmed → In Progress

In above Dmesg generated using Parallels build 1970, ata_piix driver is correctly recognising and configuring emulated DVD/CDROM drive.

Using Parallels build 3186, ata_piix driver is not recognising the emulated DVD/CDROM drive, and it is instead erroring as shown in the previously attached Parallels screendump.

So, two separate issues:

1. A change in the hardware emulation by Parallels has broken ata_piix.

2. Previous versions of the kernel (prior to 2.6.20-12) install a driver that correctly recognises the emulated DVD/CDROM driver in the Parallels build 3186. This may be related to changelog comment: "piix: Fix typo that allowed this module to override ata_piix.".

Confirmed, prior to 2.6.20-12 the piix driver is used.

Latest kernel has been reverted to use piix driver. This should fix this issue. Please test when the new kernel is released. Thanks.

Eric Kerby (erickerby) wrote :

The issue is still present with the latest linux-image-generic installed (2.6.20-14.23_i386).

Quite. Unfortunately the reversion to using the piix driver for selected PCI IDs missed Parallels. This will have to fixed in a later SRU.

Changed in linux-source-2.6.20:
assignee: phillip-lougher → ubuntu-kernel-team
status: In Progress → Confirmed
Eric Kerby (erickerby) wrote :

I can find a way around this issue, but there are many people who will have more difficulty that will turn them off to either Ubuntu, Parallels, or both. If this can't be fixed, a good workaround should be published by Canonical. The issue ends up keeping people from being able to install Ubuntu from the media, so it will be an issue that sticks around for six months.

To see how users are already responding to this issue, see the following links:

http://forums.parallels.com/thread10625.html
http://forums.parallels.com/thread10308.html
http://forums.parallels.com/thread10297.html
http://forums.parallels.com/thread10738.html
http://forums.parallels.com/thread10333.html

As you see in the first thread link, a workaround seems to be to select Solaris instead of Linux as the OS Type in Parallels. This changes the virtual optical drive that Parallels uses. This may or may not affect further things with the Ubuntu environment, but at least it enables people to install the OS. Thanks for your help so far on this, Phillip, and I hope that Parallels and the Linux community can work better together in the future. As both a Parallels and Ubuntu user, I want to do as much as possible to improve these products.

Thanks!

kentbye (kent-kentbye) wrote :

I'd like to second Eric Kelby's intrepid investigation into this issue, and confirm that I'm a disappointed first-time user who can't even install Ubuntu w/ Parallels -- not even with the proposed Solaris workaround.

FWIW, I'd like to propose upping the priority of this issue from Medium to High for the following reason.

Eric said, "The issue ends up keeping people from being able to install Ubuntu from the media."
I also get the "ACPI: Unable to locate RSDP" error message for a split-second before going to an endless black screen of death.

FYI: I searched for "installing ubuntu on parallels" and came across an excellent (tho a bit outdated) set of instructions for getting Ubuntu up and running w/ Parallels.
http://www.simplehelp.net/2006/09/18/how-to-install-ubuntu-in-os-x-using-parallels-a-complete-walkthrough/

This is the top hit on Google for how to install Ubuntu w/ Parallels, and it says, "Ubuntu is a free, open source Linux-based operating system a clear focus on the user and usability (it should “Just Work”™)."

Needless to say, it doesn't just work for me and many others.

Anyway, back to trying to find a viable workaround and off to download another 700 MB version that seems to have worked in the past -- Ubuntu 6.06.

kentbye (kent-kentbye) wrote :

I'm back after finally getting past this “ACPI: Unable to locate RSDP” error message after reading through the first thread that Eric Kirby so kindly aggregated in the above.

I'm going to spell out how I got it to work real clearly for anyone who found this thread via Google (like I did) and is trying to get Ubuntu 7.04 up and running with Parallels build 3188.
* In Parallels, go to "Edit -> Virtual Machine..."
* Change the OS Type from Linux to “Solaris” & “Other Linux Kernel 2.6″ to “Solaris (Other)”
* Start Parallels by pressing the Green Play/Run button
* Instead of hitting "Enter" at the next boot screen, interrupt the boot startup sequence by hitting "function key (fn) + F4" keys. (Hitting just F4 on a MacBook Pro will just lower the volume)
* When you get the "boot:" prompt, then type in "live vga=790" in order to start Ubuntu in safe graphics mode
* Then hit enter in order to start the Ubuntu install process

You should be able to get the gist for what to do next from the other instructions located here:
http://www.simplehelp.net/2006/09/18/how-to-install-ubuntu-in-os-x-using-parallels-a-complete-walkthrough/

A big thanks to Eric Kerby for giving me hope that a workaround actually existed, and I got the ultimate answers from this thread: http://forums.parallels.com/thread10625.html

This has been fixed, and will be available in the first kernel SRU,

Changed in linux-source-2.6.20:
status: Confirmed → Fix Committed
assignee: ubuntu-kernel-team → phillip-lougher
Colin Watson (cjwatson) wrote :

Note that a fix for this bug has a reasonable chance of appearing in a point release of Ubuntu 7.04 at some point, so it's not quite "doomed for six months".

Eric Kerby (erickerby) wrote :

Well, I can now confirm that on my Ubuntu virtual machine, the 2.6.20-16.28 kernel image now plays properly with the optical drive. It recognizes the drive as a CD-RW and DVD+/-RW drive, reads media, etc.

I would say that this bug is fixed (as Phillip mentioned when he said the kernel update would be coming). Thanks for your work on this and I do hope that a point release comes out in the future.

Eric,

Thanks for confirming it is fixed. Closing this bug...

Phillip

Changed in linux-source-2.6.20:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers