Change log for mpi-defaults package in Ubuntu

121 of 21 results
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-17
Deleted in cosmic-proposed (Reason: moved to release)
mpi-defaults (1.13) unstable; urgency=medium

  * Team upload.

  [ Manuel A. Fernandez Montecelo ]
  * Add support for riscv64, default to openmpi.  Closes: #895748

  [ Mattia Rizzolo ]
  * Fix FTBFS also on m68k and sh4.  Closes: #896110
  * Set Rules-Requires-Root: no.

 -- Mattia Rizzolo <email address hidden>  Tue, 01 May 2018 18:19:56 +0200

Available diffs

Superseded in cosmic-release on 2018-05-17
Published in bionic-release on 2018-02-06
Deleted in bionic-proposed (Reason: moved to release)
mpi-defaults (1.10) unstable; urgency=medium

  [ James Clarke ]
  * Team upload.

  [ Alastair McKinstry ]
  * Change control.in to match control

  [ James Clarke ]
  * Add ia64 using openmpi
  * Bump debhelper compat level to 11
  * Use https for copyright format URI
  * Bump standards version to 4.1.3, no changes needed
  * Change deprecated extra priority to optional
  * Update Vcs-* to point to salsa

 -- James Clarke <email address hidden>  Mon, 05 Feb 2018 12:29:49 +0000

Available diffs

1.9
Superseded in bionic-release on 2018-02-06
Deleted in bionic-proposed on 2018-02-07 (Reason: moved to release)
mpi-defaults (1.9) unstable; urgency=medium

  * Team upload
  * Standards-Version: 4.1.0
  * Add m68k to OPENMPI_AVAILABLE_ARCHITECTURES
  * Add powerpcspe to MPICH_AVAILABLE_ARCHITECTURES. Closes: #872911
  * Set DH_COMPAT=10 and change debhelper dep

 -- Alastair McKinstry <email address hidden>  Mon, 28 Aug 2017 10:54:20 +0100

Available diffs

1.8
Superseded in bionic-release on 2017-11-14
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
mpi-defaults (1.8) unstable; urgency=medium

  * Team upload
  * Cope with multi-arch openmpi.  Closes: #848797
  * Add myself to Uploaders.

 -- Alastair McKinstry <email address hidden>  Mon, 26 Dec 2016 09:08:47 +0000

Available diffs

1.7
Superseded in zesty-release on 2016-12-26
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
mpi-defaults (1.7) unstable; urgency=medium

  * Team upload.
  * Change hppa from MPICH to OpenMPI.  Closes: #833425
  * Make sure architecture lists are sorted.

 -- Mattia Rizzolo <email address hidden>  Thu, 04 Aug 2016 11:38:16 +0000

Available diffs

1.6
Superseded in yakkety-release on 2016-08-05
Deleted in yakkety-proposed on 2016-08-06 (Reason: moved to release)
mpi-defaults (1.6) unstable; urgency=medium

  * Team upload.
  * Add powerpcspe again, using openmpi.  Closes: #821179

 -- Mattia Rizzolo <email address hidden>  Sat, 16 Apr 2016 14:34:59 +0000

Available diffs

1.4
Superseded in yakkety-release on 2016-04-29
Published in xenial-release on 2016-02-29
Deleted in xenial-proposed (Reason: moved to release)
mpi-defaults (1.4) unstable; urgency=medium

  * Team upload.
  * Reinstate accidentally removed mips64el support (defaul: OpenMPI).

 -- Mattia Rizzolo <email address hidden>  Mon, 29 Feb 2016 12:12:41 +0000

Available diffs

1.2
Superseded in xenial-release on 2016-02-29
Deleted in xenial-proposed on 2016-03-02 (Reason: moved to release)
mpi-defaults (1.2) unstable; urgency=medium

  * Team upload.
  * Add a README with a small note to remember there are packages needed
    sourceful updates when changing the defaults.
  * Use openmpi on x32 too.

 -- Mattia Rizzolo <email address hidden>  Wed, 10 Feb 2016 20:18:28 +0000

Available diffs

1.1
Superseded in xenial-proposed on 2016-02-11
mpi-defaults (1.1) unstable; urgency=medium

  * Team upload.
  * Use https in the Vcs-* fields.
  * Bump debhelper compat level to 9.
  * Fix path of debian_defaults file in README.Debian.
  * Use the cleaner dh sequencer in d/rules.
  * Bump Standards-Version to 3.9.7, no changes needed.
  * Covert d/copyright to copyright-format 1.0.
  * Drop support for s390, it's not a thing anymore since wheezy.
  * Switch to openmpi on s390x.  Closes: #813691

 -- Mattia Rizzolo <email address hidden>  Wed, 10 Feb 2016 10:41:49 +0000
Superseded in xenial-proposed on 2016-02-10
mpi-defaults (1.0.2+nmu2ubuntu1) xenial; urgency=medium

  * Switch to openmpi on s390x.

 -- Matthias Klose <email address hidden>  Wed, 03 Feb 2016 15:44:36 +0100
Superseded in xenial-release on 2016-02-15
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
mpi-defaults (1.0.2+nmu2) unstable; urgency=medium


  * Non-maintainer upload.
  * Switch to openmpi on arm64, powerpcspe, ppc64 and ppc64el.
    Closes: #748510, #731646.

 -- Matthias Klose <email address hidden>  Thu, 07 Aug 2014 10:26:43 +0200
Superseded in utopic-release on 2014-08-15
Deleted in utopic-proposed on 2014-08-16 (Reason: moved to release)
mpi-defaults (1.0.2+nmu1ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - Build against openmpi for arm64 and ppc64el.

Available diffs

Superseded in utopic-release on 2014-05-10
Published in trusty-release on 2013-12-22
Deleted in trusty-proposed (Reason: moved to release)
mpi-defaults (1.0.2ubuntu1) trusty; urgency=medium

  * Build against openmpi for arm64 and ppc64el.
 -- Logan Rosen <email address hidden>   Sat, 21 Dec 2013 21:53:17 -0500

Available diffs

Superseded in trusty-release on 2013-12-22
Deleted in trusty-proposed on 2013-12-23 (Reason: moved to release)
mpi-defaults (1.0.2build1) trusty; urgency=medium

  * Rebuild for ppc64el.
 -- Dimitri John Ledkov <email address hidden>   Sat, 21 Dec 2013 13:49:24 +0000

Available diffs

Superseded in trusty-release on 2013-12-21
Deleted in trusty-proposed on 2013-12-22 (Reason: moved to release)
mpi-defaults (1.0.2) unstable; urgency=low


  * Team upload
  * Fix the logic of debian/rules: it was broken by the renaming of mpich2
    to mpich in the alternatives system
  * Update all dependencies to the new libmpich-dev and mpich packages (instead
    of the transitional packages libmpich2-dev and mpich2)
  * Replace MPICH2 by MPICH in package descriptions
  * Use canonical URLs in Vcs-* fields

 -- S├ębastien Villemot <email address hidden>  Sat, 26 Oct 2013 13:35:29 +0000

Available diffs

Superseded in trusty-release on 2013-10-26
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2012-01-02
mpi-defaults (1.0.1) unstable; urgency=low

  * Team upload
  * Upload in unstable
  * Switch to dpkg-source 3.0 (quilt) format
  * Update of the description (clearly state that it is a metapackage)
  * Update of the target in debian/rules to match the policy
  * Fix the lintian warning debian-rules-missing-recommended-target

Available diffs

Superseded in precise-release on 2012-01-02
mpi-defaults (0.6ubuntu2) precise; urgency=low

  * Default to OpenMPI on armhf.
 -- Matthias Klose <email address hidden>   Wed, 07 Dec 2011 09:23:27 +0100

Available diffs

Superseded in precise-release on 2011-12-07
Obsolete in oneiric-release on 2015-04-24
mpi-defaults (0.6ubuntu1) oneiric; urgency=low

  * Default to OpenMPI on armel.
 -- Jani Monoses <email address hidden>   Wed, 25 May 2011 18:08:05 +0300

Available diffs

0.6
Superseded in oneiric-release on 2011-05-25
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
mpi-defaults (0.6) unstable; urgency=low

  * Set Standards-Version to 3.8.2. No changes needed.
  * Added lpia to list of supported architectures, defaulting to
    Open MPI. Thanks to Steven Susbauer! (Closes: #532643)

Available diffs

Superseded in karmic-release on 2009-07-08
mpi-defaults (0.4ubuntu1) karmic; urgency=low

  * Add defaults for lpia (LP: #383665)

 -- Steven Susbauer <email address hidden>   Thu, 04 Jun 2009 11:46:11 -0600

Available diffs

0.4
Superseded in karmic-release on 2009-06-10
Superseded in karmic-release on 2009-05-12
Superseded in karmic-release on 2009-05-12
mpi-defaults (0.4) unstable; urgency=low

  * debian/control: Fixed broken dependency line. (Closes: #520141)
  * Made LAM default on Sparc.

121 of 21 results