Keep Desktop icons automatically arranged

Bug #20284 reported by Nikolaus Rath on 2005-08-23
This bug report is a duplicate of:  Bug #12608: 'keep aligned' does not work right. Edit Remove
130
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Wishlist
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

It would be great to have an option to automatically keep all the icons on the
desktop in order. This would also work around bug 12454.

http://bugs.gnome.org/show_bug.cgi?id=172128: http://bugs.gnome.org/show_bug.cgi?id=172128

Sebastien Bacher (seb128) wrote :

Thanks for your bug. You can right click on the desktop and pick "keep aligned"
as an option. Does it do what you want?

Nikolaus Rath (nikratio) wrote :

No, "keep aligned" ensures that each icon itself is aligned on an imaginary
grid. But it's still possible to move icons over each other or to spread them
over the entire desktop. What I want is something that runs "Clean up by name"
whenever an icon appears, disappears or is moved.

Nikolaus Rath (nikratio) wrote :

Do you still need some additional info? If so, just tell me what you need to know.
I'm just wondering because this bug has been tagged as NEEDINFO for quite some
time now.

Daniel Holbach (dholbach) wrote :

This seems to be adressed in an upstream bug report:
http://bugs.gnome.org/show_bug.cgi?id=172128

Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in nautilus:
assignee: seb128 → desktop-bugs
status: Unconfirmed → Confirmed
colchaodemola (colchaodemola) wrote :

Try this patch. I made it for gutsy , maybe work in other versions ...

Try:
apt-get source nautilus
cp 92_nautilus_keep_aligned.patch debian/patches
echo 92_nautilus_keep_aligned.patch >> debian/patches/series
dpkg-buildpackage
after the build , just install the new package

Now keep aligned option will work as an AUTOSORT by name function ...
Please post some feedback ...

colchaodemola (colchaodemola) wrote :

Try this patch. I made it for gutsy , maybe work in other versions ...

Try:
apt-get source nautilus
cp 92_nautilus_keep_aligned.patch debian/patches
echo 92_nautilus_keep_aligned.patch >> debian/patches/series
dpkg-buildpackage
after the build , just install the new package

Now keep aligned option will work as an AUTOSORT by name function ...
Please post some feedback ...

Nikolaus Rath (nikratio) wrote :

Hmm. For me this patch doesn't do anything at all.

I compiled and installed it, logged out and logged in again and tried it with and without the "Keep Aligned" option in the context menu of the desktop. Still, I can place items anywhere and there is no automatic "Clean Up by Name".

I have attached the console output of compilation and installation.

colchaodemola (colchaodemola) wrote :

The option works when icons are added or removed....
For example , if you insert a usb disk the icons are auto aligned ...
Another thing , i only installed the new nautilus_2.20.0-0ubuntu7_i386.deb and none of the others *.deb
Try to move an icon to any place [out of the grid] then , disable Keep Aligned , and reenable , the icon should be auto sorted....

Changed in nautilus:
status: Confirmed → Triaged
Nikolaus Rath (nikratio) wrote :

Yes, that's true. But this isn't really what this bug is about. If I have to disable and reenable "Keep Aligned" every time then I can just as well click "Clean Up by Name" once. Your patch seems to be a solution to bug 12454 instead. Maybe you confused these two bugs? Because bug 12454 also speaks specifically about the problem with usb disk icons.

Attached patch addresses this issue. Needs some love, but it's a start...

Daniel Schierbeck (dasch) wrote :

This is not a paper cut because it is not a general usability issue, but rather a feature request that will benefit a relatively small amount of users. The bug itself is fine -- and I agree with it -- but it's not a paper cut.

Changed in hundredpapercuts:
status: New → Invalid

Sorry, this is very much a paper cut! Auto-arrange desktop icons is already a user visible feature in Nautilus, it just doesn't work as expected. This small fix would benefit an enormous number of users by helping them to keep their desktops tidy.

Daniel, why do you think it would not benefit a significant percentage of users?

Changed in hundredpapercuts:
status: Invalid → Confirmed
Daniel Schierbeck (dasch) wrote :

David: I'm quoting from your blog post:

"A paper cut is not:

    * A new feature. If it requires writing more than a few lines of code, or adds any new visual elements to an interface, it’s probably not a paper cut."

By that definition, this isn't a paper cut, it's just an important usability bug.

I think the conditions posted in your blog should be updated, otherwise the process is completely arbitrary, and it's hard to actually help filter out any bugs at all.

A. Walton (awalton) wrote :

Newly attached patch is one I've seen before in some form, but it still needs quite a lot of work before it can be accepted. Breaks coding style, irreversibly forces the new behavior upon users, and adds changes that should be irrelevant (and wrong in the case of the commented assertion; if it's failing the assertion, there's likely a good reason for it).

summary: - Auto Arrange Desktop Icons
+ Keep Desktop icons automatically arranged

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project. This is a longstanding problem with the way Nautilus manages your desktop, and is not trivial to fix.

Changed in hundredpapercuts:
status: Confirmed → Invalid
L3ttuce (ifearx) wrote :

Too much energy wasted on arguing over semantics.

Ask any of the Windows users who have shifted to Ubuntu and the desktop icons auto alignment issue is sure to be on the top of the list Ubuntu quirks they find very bothersome. This has been long outstanding too and I do not believe that not many people desire this feature, it goes a long way in preserving the tidy look. I do agree that it may not be so very important to many people but it is for someone like me who is borderline fervid about keeping the desktop tidy and intuitive. It's a good feature to have.

tags: added: patch
Nigel Babu (nigelbabu) wrote :

Conrad and colchaodemola, thanks for your patches. It would be great if you could forward these patches and upstream and get feedback. Thanks again for your effort on the patches.

Changed in nautilus:
importance: Unknown → Wishlist
Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
tags: added: patch-needswork
removed: patch

I'm out of the office until 1st August.

On 28 Apr 2011, at 06:46, DSSDSD <email address hidden> wrote:

> GHD straighteners <strong><a href="http://www.rs2goldmart.com/"
> target=_blank>rs money</a></strong> achieve their complete
> temperatures
> in near to twenty seconds, depending inside the temperatures from the
> room. This allows you to definitely acquire on to undertaking what
> matters most, straightening your hair. GHDs include excellent
> electronics which retain the temperatures from the heat plates
> <strong><a href="http://www.rs2goldmart.com/runescape-gold/"
> target=_blank>runescape gold</a></strong> steady providing you a
> steady
> finish.
>
> The ghd styler also carries a safety
> <strong><a href="http://www.westwoodjewellerystore.com/vivienne-westwood-brooches.html
> " target=_blank>vivienne westwood brooches</a></strong> attribute
> that provides you peace of ideas by turning away the straighteners
> when it's left unattended for 30 minutes. No extra
> <strong><a href="http://www.westwoodjewellerystore.com/genuine-vivienne-westwood.html
> " target=_blank>vivienne westwood sale</a></strong> worrying about
> no subject whether you turned the straighteners away or not! And no
> extra return trips home to locate that you
>
> <strong><a href="http://www.westwoodjewellerystore.com/vivienne-
> westwood-charms.html" target=_blank>vivienne westwood
> charms</a></strong> simply do in reality unplug them while in the
> wall!
>
> --
> You received this bug notification because you are a member of
> Papercutters, which is subscribed to One Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/20284
>
> Title:
>  Keep Desktop icons automatically arranged
>
> Status in One Hundred Paper Cuts:
>  Invalid
> Status in Nautilus:
>  Confirmed
> Status in “nautilus” package in Ubuntu:
>  Triaged
>
> Bug description:
>  It would be great to have an option to automatically keep all the
> icons on the
>  desktop in order. This would also work around bug 12454.
>
>  http://bugs.gnome.org/show_bug.cgi?id=172128:
>  http://bugs.gnome.org/show_bug.cgi?id=172128

Gujche (gujche) wrote :

Solution for Lubuntu(PCManFM):

1. go to /home/USER/.config/pcmanfm/default/ or /home/USER/.config/pcmanfm/lubuntu/
         -change USER with your user name
2. sudo nano pcmanfm.conf
3. go to section "[desktop]"
4. change sort_by to sort_by=2 (if you want to sort by name)
5. log out -> log in -> Tadaaa :)

I'm not an expert, probably there is some nicer way to do that with bash script or something..but this works and it is needed to be done only once. About sorting numbers I'm not sure which one is for what and didn't find any useful info, so you'll need to discover it by yourself by playing or finding some info. Enjoy.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.