Change log for pcre-ocaml package in Ubuntu

131 of 31 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-11-05
Deleted in bionic-proposed (Reason: moved to release)
pcre-ocaml (7.2.3-2build1) bionic; urgency=medium

  * Rebuild against new OCAML ABI.

 -- Gianfranco Costamagna <email address hidden>  Fri, 27 Oct 2017 11:19:46 +0200
Superseded in bionic-release on 2017-11-05
Published in artful-release on 2017-07-21
Deleted in artful-proposed (Reason: moved to release)
pcre-ocaml (7.2.3-2) unstable; urgency=medium

  * Add ocamlbuild to Build-Depends

 -- Stéphane Glondu <email address hidden>  Sat, 15 Jul 2017 11:55:07 +0200
Superseded in artful-release on 2017-07-21
Deleted in artful-proposed on 2017-07-22 (Reason: moved to release)
pcre-ocaml (7.2.3-1ubuntu1) artful; urgency=high

  * No change rebuild against ocaml 4.04.
  * Add ocamlbuild build-dep.

 -- Dimitri John Ledkov <email address hidden>  Tue, 27 Jun 2017 13:37:28 +0100
Superseded in artful-release on 2017-07-18
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-06-22 (Reason: moved to release)
pcre-ocaml (7.2.3-1) unstable; urgency=medium

  * New upstream release
  * Update debian/watch
  * Update Vcs-*
  * Bump Standards-Version to 3.9.8
  * Bump debhelper compat to 9

 -- Stéphane Glondu <email address hidden>  Wed, 03 Aug 2016 13:56:58 +0200
Superseded in yakkety-release on 2016-09-03
Published in xenial-release on 2015-11-13
Deleted in xenial-proposed (Reason: moved to release)
pcre-ocaml (7.0.4-2build1) xenial; urgency=medium

  * No-change rebuild against ocaml 4.02.

 -- Łukasz 'sil2100' Zemczak <email address hidden>  Tue, 03 Nov 2015 15:03:49 -0600
Superseded in xenial-release on 2015-11-13
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
pcre-ocaml (7.0.4-2) unstable; urgency=medium

  * Team upload.
  * Fix homepage URL.

 -- Mehdi Dogguy <email address hidden>  Mon, 10 Aug 2015 20:22:12 +0000

Available diffs

Superseded in wily-release on 2015-08-11
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-01-27
Deleted in trusty-proposed (Reason: moved to release)
pcre-ocaml (7.0.4-1) unstable; urgency=medium


  * New upstream release
  * Bump Standards-Version to 3.9.5

 -- Stéphane Glondu <email address hidden>  Mon, 27 Jan 2014 10:24:50 +0100

Available diffs

Superseded in trusty-release on 2014-01-27
Deleted in trusty-proposed on 2014-01-29 (Reason: moved to release)
pcre-ocaml (7.0.2-4) unstable; urgency=low


  * Upload to unstable

 -- Stéphane Glondu <email address hidden>  Tue, 03 Dec 2013 08:40:37 +0100

Available diffs

Superseded in trusty-release on 2013-12-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
pcre-ocaml (7.0.2-2) unstable; urgency=low


  * Remove META from -dev (it is installed by -ocaml)

 -- Stéphane Glondu <email address hidden>  Thu, 09 May 2013 08:19:33 +0200

Available diffs

Superseded in saucy-proposed on 2013-05-09
pcre-ocaml (7.0.2-1) unstable; urgency=low


  * New upstream release
  * Do no longer use CDBS
  * Use format version 1.0 in debian/copyright
  * Bump Standards-Version to 3.9.4

 -- Stéphane Glondu <email address hidden>  Wed, 08 May 2013 20:19:11 +0200
Superseded in saucy-release on 2013-05-12
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
pcre-ocaml (6.2.5-1) unstable; urgency=low


  * New upstream release
    - drop Fix-typo-in-debug-native-code-library-target-of-OCam.patch

 -- Stéphane Glondu <email address hidden>  Fri, 10 Feb 2012 06:50:22 +0100

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-12-05
pcre-ocaml (6.2.3-1) unstable; urgency=low

  * New upstream release
    - drop Change-position-of-flag-lpcre.patch since it seems to have
      been addressed upstream
  * Bump Standards-Version to 3.9.2 (no changes)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  05 Dec 2011 11:02:42 +0000

Available diffs

Superseded in precise-release on 2011-12-05
pcre-ocaml (6.2.2-2build2) precise; urgency=low

  * Rebuild for OCaml 3.12.1.
 -- Colin Watson <email address hidden>   Sat, 19 Nov 2011 01:00:33 +0000

Available diffs

Superseded in precise-release on 2011-11-19
Obsolete in oneiric-release on 2015-04-24
pcre-ocaml (6.2.2-2build1) oneiric; urgency=low

  * Rebuild to pick up ocaml fixes on armel.
 -- Adam Conrad <email address hidden>   Wed, 24 Aug 2011 16:28:25 -0600

Available diffs

Superseded in oneiric-release on 2011-08-24
pcre-ocaml (6.2.2-2) unstable; urgency=low

  * Remove obsolete README.source
  * Update libpcre-ocaml-dev.README.Debian (Closes: #622233)

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
pcre-ocaml (6.0.1-3) unstable; urgency=low

  [ Stéphane Glondu ]
  * Fix generation of documentation by dh_ocamldoc (Closes: #570717)
  
  [ Stefano Zacchiroli ]
  * Bump Standards-Version to 3.8.4 (no changes)
  * debian/source/format: set source format to 3.0 (quilt)
  * switch patch management from dpatch to quilt
  * debian/patches: remove unused meta.dpatch
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:59:33 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
pcre-ocaml (6.0.1-2build1) lucid; urgency=low

  * No-change rebuild for OCaml 3.11.2 transition (LP: #526073).
 -- Ilya Barygin <email address hidden>   Wed, 24 Feb 2010 23:03:33 +0300

Available diffs

Superseded in lucid-release on 2010-02-24
pcre-ocaml (6.0.1-2) unstable; urgency=low

  * Switch packaging to dh-ocaml 0.9
  * Update my e-mail address and remove DMUA
  * Bump Standards-Version to 3.8.3 (no changes)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  06 Nov 2009 08:58:22 +0000

Available diffs

Superseded in lucid-release on 2009-11-06
Obsolete in karmic-release on 2013-03-04
pcre-ocaml (6.0.1-1) unstable; urgency=low

  * New Upstream Version

Available diffs

Superseded in karmic-release on 2009-07-27
pcre-ocaml (5.15.1-2) unstable; urgency=low

  * upload to unstable
  * bump debhelper compatibility level to 7
    - simplify debian/*.install file getting rid of debian/tmp/
  * debian/*.install.in: use @OCamlStdlibDir@ and @OCamlDllDir@ instead of
    making assumption on stdlib directory layout
  * debian/rules: use ocaml.mk as a "rules" makefile snippet, bump
    build-dep on dh-ocaml to the minumum version implementing it
  * debian/control:
    - drop obsolete dep version requirements
    - version build-deps on findlib, to ensure buildability in unstable

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
pcre-ocaml (5.13.0-1build1) intrepid; urgency=low

  * No change rebuild against ocaml 3.10.2 (LP: #234581)

 -- Cesare Tirabassi <email address hidden>   Sun, 25 May 2008 19:23:30 +0200
Superseded in intrepid-release on 2008-05-26
pcre-ocaml (5.13.0-1) unstable; urgency=low

  * new upstream release
  * fix vcs-svn field to point just above the debian/ dir
  * rebuild against ocaml 3.10.1

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
pcre-ocaml (5.12.2-2) unstable; urgency=low

  * debian/control
    - bump build-dep on ocaml-nox to 3.10.0-8 to ensure we build against fixed
      CDBS class wrt ocamldoc generation

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
pcre-ocaml (5.11.1-2) unstable; urgency=low

  * debian/rules
    - use ocaml.mk cdbs class
  * debian/control
    - bumped ocaml-nox build dependency to >= 3.09.2-7 since we now use
      ocaml.mk

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  07 Nov 2006 03:16:52 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
pcre-ocaml (5.11.1-1) unstable; urgency=low

  * New upstream release
  * debian/rules
    - removed no longer needed workaround for cdbs + dpatch
    - avoid to create debian/control from debian/control.in on ocamlinit
  * debian/control.in
    - file removed; it is deprecated as per ocaml packaging policy 3.3
  * debian/patches/
    - commented out 19_meta.dpatch (not needed with this version, lib version
      is correct in upstream's META)

 -- Daniel T Chen <email address hidden>   Tue,  19 Sep 2006 17:20:59 +0100
Superseded in edgy-release on 2006-09-19
pcre-ocaml (5.10.1-4) unstable; urgency=low

  * Upload to unstable.

Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
pcre-ocaml (5.10.1-2) unstable; urgency=low


  * Rebuilt against OCaml 3.09.1, bumped deps accordingly.

 -- Stefano Zacchiroli <email address hidden>  Sat,  7 Jan 2006 14:30:33 +0100
Superseded in dapper-release on 2006-01-31
pcre-ocaml (5.10.1-1) unstable; urgency=low


  * New upstream release
  * rebuilt with ocaml 3.09
  * debian/*
    - no more hardcoding of ocaml abi anywhere
  * debian/control
    - bumped standards-version
  * debian/patches/19_meta.dpatch
    - bumped lib version in META

 -- Stefano Zacchiroli <email address hidden>  Tue,  8 Nov 2005 23:08:44 +0100
Obsolete in breezy-release on 2008-03-25
pcre-ocaml (5.08.1-3) unstable; urgency=low


  * Rebuilt against ocaml 3.08.3

 -- Stefano Zacchiroli <email address hidden>  Thu, 24 Mar 2005 22:44:54 +0100
Obsolete in hoary-release on 2008-03-19
pcre-ocaml (5.08.1-2) unstable; urgency=medium


  * debian/control
    - depend on ocaml-base-nox-3.08 instead of ocaml-base-3.08 since
      this package doesn't directly need ocaml X libraries

 -- Stefano Zacchiroli <email address hidden>  Tue, 24 Aug 2004 12:18:34 +0200
Obsolete in warty-release on 2008-01-09
pcre-ocaml (5.06.2-1) unstable; urgency=low


  * New upstream release
  * debian/control
    - bumped standards-version to 3.6.1.0
    - bumped dependencies to libpcre3-dev >= 4.5 as needed by this
      upstream release

 -- Stefano Zacchiroli <email address hidden>  Mon, 15 Mar 2004 19:18:28 +0100
131 of 31 results