pcre3 2:8.35-7ubuntu2 source package in Ubuntu

Changelog

pcre3 (2:8.35-7ubuntu2) wily; urgency=low

  * SECURITY UPDATE: PCRE Library Heap Overflow Vulnerability
    - debian/patches/cve-2015-2325.patch: change some variables
      pointer to integer, and related contents. Based on upstream patch
    - CVE-2015-2325
  * SECURITY UPDATE: PCRE Library Heap overflow Vulnerability II
    - debian/patches/cve-2015-2326.patch: take save_hwm_offset out
      from adjust_recurse. Based on upstream patch
    - CVE-2015-2326
  * SECURITY UPDATE: PCRE Library Heap Overflow Vulnerability
    - debian/patches/cve-2015-3210.patch: change checking if
      oc->number == recno code, Based on upstream patch
    - CVE-2015-3210
  * SECURITY UPDATE: PCRE Library Heap Overflow Vulnerability in
    find_fixedlength()
    - debian/patches/cve-2015-5073.patch: missing test code
      Based on upstream patch
    - CVE-2015-5073

 -- Seyeong Kim <email address hidden>  Tue, 21 Jul 2015 15:42:03 +0900

Upload details

Uploaded by:
Seyeong Kim on 2015-07-23
Sponsored by:
Marc Deslauriers
Uploaded to:
Wily
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
pcre3_8.35.orig.tar.gz 1.9 MiB 1c9ee292943ba2737f127b481a3f72f44c13fbd09a7b5b4eb8fa58650cfa56a0
pcre3_8.35-7ubuntu2.debian.tar.gz 29.4 KiB 9bb3391202c0ac4913f58cee43a9730fcf4568d1eb546922239c0cd71e3f7835
pcre3_8.35-7ubuntu2.dsc 2.1 KiB dd13abcc3c02d900a66d96ccc4f23fbb237b8a47069f141b7fd1cf467ffdb8a9

View changes file

Binary packages built by this source

libpcre16-3: No summary available for libpcre16-3 in ubuntu wily.

No description available for libpcre16-3 in ubuntu wily.

libpcre16-3-dbgsym: No summary available for libpcre16-3-dbgsym in ubuntu wily.

No description available for libpcre16-3-dbgsym in ubuntu wily.

libpcre3: No summary available for libpcre3 in ubuntu wily.

No description available for libpcre3 in ubuntu wily.

libpcre3-dbg: No summary available for libpcre3-dbg in ubuntu wily.

No description available for libpcre3-dbg in ubuntu wily.

libpcre3-dbgsym: No summary available for libpcre3-dbgsym in ubuntu wily.

No description available for libpcre3-dbgsym in ubuntu wily.

libpcre3-dev: No summary available for libpcre3-dev in ubuntu wily.

No description available for libpcre3-dev in ubuntu wily.

libpcre3-dev-dbgsym: No summary available for libpcre3-dev-dbgsym in ubuntu wily.

No description available for libpcre3-dev-dbgsym in ubuntu wily.

libpcre3-udeb: No summary available for libpcre3-udeb in ubuntu wily.

No description available for libpcre3-udeb in ubuntu wily.

libpcre3-udeb-dbgsym: No summary available for libpcre3-udeb-dbgsym in ubuntu wily.

No description available for libpcre3-udeb-dbgsym in ubuntu wily.

libpcre32-3: No summary available for libpcre32-3 in ubuntu wily.

No description available for libpcre32-3 in ubuntu wily.

libpcre32-3-dbgsym: No summary available for libpcre32-3-dbgsym in ubuntu wily.

No description available for libpcre32-3-dbgsym in ubuntu wily.

libpcrecpp0: No summary available for libpcrecpp0 in ubuntu wily.

No description available for libpcrecpp0 in ubuntu wily.

libpcrecpp0-dbgsym: No summary available for libpcrecpp0-dbgsym in ubuntu wily.

No description available for libpcrecpp0-dbgsym in ubuntu wily.

pcregrep: No summary available for pcregrep in ubuntu wily.

No description available for pcregrep in ubuntu wily.

pcregrep-dbgsym: No summary available for pcregrep-dbgsym in ubuntu wily.

No description available for pcregrep-dbgsym in ubuntu wily.