Postgresql won't start after installation because "TCP/IP connections must be enabled for SSL"

Bug #33996 reported by Johannes Thoma on 2006-03-07
8
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned
postgresql (Ubuntu)
Medium
Martin Pitt

Bug Description

Hello,

I just installed postgresql, when starting up it complains as follows:

johannes@karin:~$ sudo /etc/init.d/postgresql-7.4 start
Password:
 * Starting PostgreSQL 7.4 database server: main The PostgreSQL server failed to start. Please check the log output:
/usr/lib/postgresql/7.4/bin/postmaster: TCP/IP connections must be enabled for SSL
                                                                         [fail]

Is this a known bug? Is there any work-around? (maybe there is a dependency missing?)

I use Ubuntu 5.10 and installed with Synaptic.

Thanks

- Johannes

Johannes Thoma (johannes-thoma) wrote :

I found how to fix this:

edit the postgres.conf file for the 7.4 version:

sudo vi /etc/postgresql/7.4/main/postgresql.conf

and change the line 30 which is as follows:

# tcpip_socket = false

to:

tcpip_socket = true

then it works. This should be easy to fix for the next ubuntu release (or update).

best wishes

- Johannes

Martin Pitt (pitti) wrote :

Rejecting superfluous Ubuntu task.

Martin Pitt (pitti) wrote : debdiff

Fix:

  * pg_createcluster:
    - Do not enable SSL on 7.4 clusters since enabling it without enabling the
      TCP socket breaks.
    - Fix backported from version 29.
    - Malone #33996.

Martin Pitt (pitti) wrote :

Matt, are you fine with fixing this in Breezy? The patch is straightforward, this was fixed in Dapper long ago.

Changed in postgresql:
assignee: nobody → pitti
status: Unconfirmed → Fix Committed

On Wed, Mar 08, 2006 at 12:20:27PM -0000, Martin Pitt wrote:
> Comment:
> Matt, are you fine with fixing this in Breezy? The patch is
> straightforward, this was fixed in Dapper long ago.

Yes.

--
 - mdz

Martin Pitt (pitti) wrote :

The upload is blocked by a Soyuz bug (bug 34089).

Martin Pitt (pitti) wrote :

Uploaded.

Changed in postgresql:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches