puppet 0.24.4-3ubuntu0.1 source package in Ubuntu

Changelog

puppet (0.24.4-3ubuntu0.1) hardy-security; urgency=low

  * SECURITY UPDATE: unauthenticated directory traversal allows writing of
    arbitrary files as puppet master. Patch thanks to Daniel Pittman from
    upstream puppet.
    - 5107c5a979d74d9da40a4cb8362f8ea3e7fb0dd5
    - CVE-2011-3848
    - LP: #861182
  * SECURITY UPDATE: k5login can overwrite arbitrary files as root
    - adjust type/k5login.rb to securely open the file before writing to it as
      root. Patch thanks to Daniel Pittman from upstream puppet.
    - 17bf848bd1fa40fb56e6a83e2ac823e6cce60479
    - CVE-2011-3869
 -- Jamie Strandboge <email address hidden>   Wed, 05 Oct 2011 14:48:27 -0500

Upload details

Uploaded by:
Jamie Strandboge on 2011-10-05
Uploaded to:
Hardy
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
all
Section:
admin
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Hardy: [FULLYBUILT] i386

Downloads

File Size MD5 Checksum
puppet_0.24.4.orig.tar.gz 637.3 KiB 9658624ed3745e8954772b3fbfdcc438
puppet_0.24.4-3ubuntu0.1.diff.gz 209.7 KiB 4d1453811382e8b212ca68f7fd1a8cad
puppet_0.24.4-3ubuntu0.1.dsc 1.6 KiB 8c32506ba8ab34a4fc3ee6c8190bc4c3

View changes file

Binary packages built by this source

puppet: No summary available for puppet in ubuntu hardy.

No description available for puppet in ubuntu hardy.

puppetmaster: No summary available for puppetmaster in ubuntu hardy.

No description available for puppetmaster in ubuntu hardy.