Change log for python-llfuse package in Ubuntu

145 of 45 results
Published in focal-release on 2019-11-07
Deleted in focal-proposed (Reason: moved to Release)
python-llfuse (1.3.6+dfsg-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.

  [ Sandro Tosi ]
  * Drop python2 support; Closes: #937896

 -- Sandro Tosi <email address hidden>  Wed, 06 Nov 2019 22:34:54 -0500
Superseded in focal-release on 2019-11-07
Deleted in focal-proposed on 2019-11-08 (Reason: moved to Release)
python-llfuse (1.3.6+dfsg-1build1) focal; urgency=medium

  * No-change rebuild to build with python3.8.

 -- Matthias Klose <email address hidden>  Fri, 18 Oct 2019 18:43:16 +0000
Superseded in focal-release on 2019-10-21
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-02-17
Deleted in disco-proposed (Reason: moved to release)
python-llfuse (1.3.6+dfsg-1) unstable; urgency=medium

  * New upstream release.

 -- Nikolaus Rath <email address hidden>  Thu, 14 Feb 2019 13:00:32 +0000
Superseded in disco-release on 2019-02-17
Deleted in disco-proposed on 2019-02-18 (Reason: moved to release)
python-llfuse (1.3.5+dfsg-1build1) disco; urgency=medium

  * No-change rebuild to build without python3.6 support.

 -- Matthias Klose <email address hidden>  Sat, 03 Nov 2018 12:09:16 +0000
Superseded in disco-release on 2018-11-05
Published in cosmic-release on 2018-09-25
Deleted in cosmic-proposed (Reason: moved to release)
python-llfuse (1.3.5+dfsg-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Convert git repository from git-dpm to gbp layout

  [ Nikolaus Rath ]
  * python3-llfuse-dbg: recommend python3-dbg, not python-dbg. Closes:
    #906080.
  * New upstream release.

 -- Nikolaus Rath <email address hidden>  Thu, 30 Aug 2018 20:24:40 +0200

Available diffs

Superseded in cosmic-release on 2018-09-25
Deleted in cosmic-proposed on 2018-09-26 (Reason: moved to release)
python-llfuse (1.3.3+dfsg-4) unstable; urgency=medium

  [ Nikolaus Rath ]
  * Do not modify proxy settings in integration tests, this change was
    actually meant for a different package.

  [ Ondřej Nový ]
  * d/control: Remove ancient X-Python-Version field
  * d/control: Remove ancient X-Python3-Version field

  [ Nikolaus Rath ]
  * Drop -Werror=conversion, causes build failure with new Cython
    (or maybe new GCC?)

 -- Nikolaus Rath <email address hidden>  Mon, 02 Jul 2018 16:59:10 +0100
Superseded in cosmic-proposed on 2018-07-02
python-llfuse (1.3.3+dfsg-3build1) cosmic; urgency=medium

  * No-change rebuild to build for python3.7.

 -- Matthias Klose <email address hidden>  Thu, 28 Jun 2018 12:36:55 +0000
Superseded in cosmic-release on 2018-07-03
Published in bionic-release on 2018-04-04
Deleted in bionic-proposed (Reason: moved to release)
python-llfuse (1.3.3+dfsg-3) unstable; urgency=medium

  * Get rid of python-catchlog dependency for integration tests
    as well. Closes: #894716.
  * Disable proxy in integration tests.

 -- Nikolaus Rath <email address hidden>  Wed, 04 Apr 2018 09:47:38 +0100
Superseded in bionic-release on 2018-04-04
Deleted in bionic-proposed on 2018-04-06 (Reason: moved to release)
python-llfuse (1.3.3+dfsg-2ubuntu1) bionic; urgency=medium

  * drop again pytest-catchlog from testsuite

 -- Gianfranco Costamagna <email address hidden>  Wed, 04 Apr 2018 08:54:42 +0200
Superseded in bionic-release on 2018-04-04
Deleted in bionic-proposed on 2018-04-05 (Reason: moved to release)
python-llfuse (1.3.3+dfsg-2) unstable; urgency=medium

  * Fully drop pytest-catchlog dependency (previous upload only dropped
    dependency for Python 3 by accident). Closes: #894716.

 -- Nikolaus Rath <email address hidden>  Tue, 03 Apr 2018 21:19:02 +0100
Superseded in bionic-release on 2018-04-04
Deleted in bionic-proposed on 2018-04-05 (Reason: moved to release)
python-llfuse (1.3.3+dfsg-1ubuntu1) bionic; urgency=medium

  * Really drop catchlog depedency

 -- Gianfranco Costamagna <email address hidden>  Tue, 03 Apr 2018 12:36:53 +0200
Superseded in bionic-release on 2018-04-03
Deleted in bionic-proposed on 2018-04-04 (Reason: moved to release)
python-llfuse (1.3.3+dfsg-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Use https protocol in Format field
  * d/control: Deprecating priority extra as per policy 4.0.1
  * d/changelog: Remove trailing whitespaces
  * d/control: Remove trailing whitespaces

  [ Nikolaus Rath ]
  * New upstream release.
  * Dropped pytest-catchlog dependency, depend on py.test 3.3
    instead. Closes: #892616.

 -- Nikolaus Rath <email address hidden>  Sat, 31 Mar 2018 12:51:40 +0100

Available diffs

Superseded in bionic-release on 2018-04-03
Deleted in bionic-proposed on 2018-04-04 (Reason: moved to release)
python-llfuse (1.3.2+dfsg-2) unstable; urgency=medium

  * Fixed up patches/mips_dev_t.diff (missing file)

 -- Nikolaus Rath <email address hidden>  Mon, 13 Nov 2017 14:03:03 +0000
Superseded in bionic-proposed on 2017-11-13
python-llfuse (1.3.2+dfsg-1) unstable; urgency=medium

  * New upstream version.
  * Don't apply dev_t fix to mips64 (just mips and mipsel). 
    Closes: #877500

 -- Nikolaus Rath <email address hidden>  Mon, 13 Nov 2017 12:51:16 +0000

Available diffs

Superseded in bionic-release on 2017-11-14
Deleted in bionic-proposed on 2017-11-15 (Reason: moved to release)
python-llfuse (1.3+dfsg-3) unstable; urgency=medium

  * Updated standards version to 4.1.1
  * Added support for 'nodoc' in DEB_BUILD_OPTIONS.
  * python-llfuse-doc is now Multi-Arch: foreign
  * Fixed mips_dev_t.diff one more time. One mips, dev_t is unsigned
    and we have to apply the match for mips, not just mips64.

 -- Nikolaus Rath <email address hidden>  Sun, 01 Oct 2017 15:21:45 +0100
Superseded in bionic-release on 2017-11-09
Published in artful-release on 2017-09-05
Deleted in artful-proposed (Reason: moved to release)
python-llfuse (1.2+dfsg-1build3) artful; urgency=medium

  * No-change rebuild to drop _PyFPE support.

 -- Matthias Klose <email address hidden>  Tue, 05 Sep 2017 08:23:09 +0000
Superseded in artful-release on 2017-09-05
Deleted in artful-proposed on 2017-09-06 (Reason: moved to release)
python-llfuse (1.2+dfsg-1build2) artful; urgency=medium

  * No-change rebuild to build to drop python3.5.

 -- Matthias Klose <email address hidden>  Sat, 05 Aug 2017 16:27:43 +0000
Superseded in artful-release on 2017-08-06
Deleted in artful-proposed on 2017-08-07 (Reason: moved to release)
python-llfuse (1.2+dfsg-1build1) artful; urgency=medium

  * Rebuild for python 3.6 support.

 -- Bhavani Shankar <email address hidden>  Sat, 13 May 2017 09:48:49 +0530
Superseded in artful-release on 2017-05-13
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
python-llfuse (1.2+dfsg-1) unstable; urgency=medium

  * New upstream release.

 -- Nikolaus Rath <email address hidden>  Sun, 22 Jan 2017 14:42:22 -0800

Available diffs

Superseded in zesty-release on 2017-01-23
Deleted in zesty-proposed on 2017-01-24 (Reason: moved to release)
python-llfuse (1.1.1+dfsg-7) unstable; urgency=medium

  * Fix syntax error introduced with new Debian patch in -6.

 -- Nikolaus Rath <email address hidden>  Sun, 22 Jan 2017 09:54:54 -0800
Superseded in zesty-proposed on 2017-01-22
python-llfuse (1.1.1+dfsg-6) unstable; urgency=medium

  * Ignore exceptions during interpreter shutdown

    These can most likely be ignored in general. In the specific
    case that we are addressing with this, they also seem to be
    caused by a bug in Python. Closes: #851724.

 -- Nikolaus Rath <email address hidden>  Sat, 21 Jan 2017 16:36:43 -0800

Available diffs

Superseded in zesty-release on 2017-01-23
Deleted in zesty-proposed on 2017-01-24 (Reason: moved to release)
python-llfuse (1.1.1+dfsg-5) unstable; urgency=medium

  * Added missing python-pytest-catchlog dependency for tests

 -- Nikolaus Rath <email address hidden>  Mon, 02 Jan 2017 20:17:51 -0800

Available diffs

Superseded in zesty-release on 2017-01-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
python-llfuse (1.1.1+dfsg-4) unstable; urgency=medium

  * Added missing python3-pytest-catchlog dependency for tests

 -- Nikolaus Rath <email address hidden>  Fri, 07 Oct 2016 20:46:10 -0700
Superseded in yakkety-release on 2016-10-10
Deleted in yakkety-proposed on 2016-10-12 (Reason: moved to release)
python-llfuse (1.1.1+dfsg-3ubuntu1) yakkety; urgency=medium

  * Add python*-pytest-catchlog to test-dependencies, they are
    needed to run the testsuite.

 -- Gianfranco Costamagna <email address hidden>  Mon, 26 Sep 2016 12:21:24 +0200
Superseded in yakkety-proposed on 2016-09-26
python-llfuse (1.1.1+dfsg-3) unstable; urgency=medium

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

  [ Nikolaus Rath ]
  * Don't use pytest.skip at module level. Closes: #837254.

 -- Nikolaus Rath <email address hidden>  Fri, 23 Sep 2016 20:41:07 -0700

Available diffs

Superseded in yakkety-proposed on 2016-09-26
python-llfuse (1.1.1+dfsg-2) unstable; urgency=medium

  * Added missing pytest-catchlog build dependency
  * Fixup 0004-Backport-properties-to-Cython-0.23-syntax.patch

 -- Nikolaus Rath <email address hidden>  Wed, 27 Jul 2016 11:25:48 -0700

Available diffs

Superseded in yakkety-release on 2016-09-26
Deleted in yakkety-proposed on 2016-09-27 (Reason: moved to release)
python-llfuse (1.0+dfsg-2) unstable; urgency=medium

  * Cherry picked ns-resolution support for kFreeBSD

 -- Nikolaus Rath <email address hidden>  Thu, 10 Mar 2016 09:13:08 -0800
Superseded in yakkety-release on 2016-04-29
Published in xenial-release on 2016-01-19
Deleted in xenial-proposed (Reason: moved to release)
python-llfuse (0.41.1+dfsg-4build1) xenial; urgency=medium

  * No-change rebuild to drop python3.4 support.

 -- Matthias Klose <email address hidden>  Tue, 19 Jan 2016 11:45:48 +0000
Superseded in xenial-release on 2016-01-19
Deleted in xenial-proposed on 2016-01-20 (Reason: moved to release)
python-llfuse (0.41.1+dfsg-4) unstable; urgency=medium

  * Added patches/mips_dev_t.diff to work around bug in mips/mipsel libc
    (cf. https://sourceware.org/bugzilla/show_bug.cgi?id=17786).
    Closes: #635197.

 -- Nikolaus Rath <email address hidden>  Wed, 16 Sep 2015 13:59:11 -0700

Available diffs

Superseded in xenial-release on 2015-10-25
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
python-llfuse (0.40+dfsg-2) unstable; urgency=medium

  * Correctly handle symlink-to-directory transition of 
    /usr/share/doc/{python,python3}-llfuse-dbg when upgrading from jessie.
    Closes: #788161.
  * Add versioned Breaks and Conflicts to -dbg packages to avoid
    upgrade problems due to moved file. Closes: #781652.
  * Put debugging symbols for regular interpreter into -dbg
    package again. Closes: #781719.
  * Bumped Standards-Version to 3.9.6 (no changes needed).
  * Added missing build-depends on cython3 and cython-dbg. 
    Closes: #794056.

 -- Nikolaus Rath <email address hidden>  Wed, 29 Jul 2015 20:49:49 -0700
Superseded in wily-release on 2015-08-11
Deleted in wily-proposed on 2015-08-12 (Reason: moved to release)
python-llfuse (0.40+dfsg-1ubuntu1) wily; urgency=medium

  * Add missing build-dependency on cython-dbg.

 -- Steve Langasek <email address hidden>  Thu, 30 Jul 2015 07:33:57 +0000
Superseded in wily-proposed on 2015-07-30
python-llfuse (0.40+dfsg-1build1) wily; urgency=medium

  * No-change rebuild for python3.5 transition

 -- Steve Langasek <email address hidden>  Wed, 22 Jul 2015 21:35:57 +0000
Superseded in wily-release on 2015-07-30
Deleted in wily-proposed on 2015-07-31 (Reason: moved to release)
python-llfuse (0.40+dfsg-1) unstable; urgency=medium


  * Updated watch file to use pypi, and validate pgp signature.
  * Remove minified javascript files from upstream source.
  * Switched package build system to pybuild.
  * Updated project URL.

 -- Nikolaus Rath <email address hidden>  Thu, 10 Jul 2014 21:34:34 -0700
Superseded in wily-release on 2015-05-08
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-03-23
Deleted in trusty-proposed (Reason: moved to release)
python-llfuse (0.40-2build2) trusty; urgency=medium

  * No-change rebuild to drop Python 3.3 support.
 -- Matthias Klose <email address hidden>   Sun, 23 Mar 2014 15:29:06 +0000

Available diffs

Superseded in trusty-release on 2014-03-23
Deleted in trusty-proposed on 2014-03-25 (Reason: moved to release)
python-llfuse (0.40-2build1) trusty; urgency=medium

  * Rebuild for python3.4 as a supported python version.
 -- Matthias Klose <email address hidden>   Sat, 04 Jan 2014 19:32:41 +0000

Available diffs

Superseded in trusty-release on 2014-01-05
Deleted in trusty-proposed on 2014-01-06 (Reason: moved to release)
python-llfuse (0.40-2) unstable; urgency=low


  * Some cosmetic fixes to debian/
  * Bumped standards version to 3.9.5, no other changes required.
  * Added force_xattr_api.diff to support compilation under GNU/kFreeBSD.

 -- Nikolaus Rath <email address hidden>  Wed, 27 Nov 2013 20:19:13 -0800

Available diffs

Superseded in trusty-release on 2013-12-03
Deleted in trusty-proposed on 2013-12-04 (Reason: moved to release)
python-llfuse (0.40-1) unstable; urgency=low


  * New upstream release.

 -- Nikolaus Rath <email address hidden>  Tue, 26 Nov 2013 21:59:10 -0800

Available diffs

Superseded in trusty-release on 2013-11-28
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
python-llfuse (0.39-1) unstable; urgency=low


  [ Nikolaus Rath ]
  * Bumped standards version to 3.9.4, no other changes required.
  * Bumped debhelper compatibility level to 9 to get support for
    dpkg-buildflags.
  * Added lintian override for hardening-no-fortify-functions,
    this is a false positive.
  * Build depend on newer Cython (> 0.16).
  * New upstream release.

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

 -- Nikolaus Rath <email address hidden>  Sat, 11 May 2013 12:33:34 -0700
Superseded in saucy-release on 2013-05-12
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
python-llfuse (0.37.1-2build2) raring; urgency=low

  * Rebuild to drop python3.2 provides.
 -- Matthias Klose <email address hidden>   Wed, 07 Nov 2012 23:00:41 +0000

Available diffs

Superseded in raring-release on 2012-11-08
python-llfuse (0.37.1-2build1) raring; urgency=low

  * No-change upload to build for python3.3.
 -- Matthias Klose <email address hidden>   Tue, 23 Oct 2012 14:44:09 +0200

Available diffs

Superseded in raring-release on 2012-10-23
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2012-01-03
python-llfuse (0.37.1-2) unstable; urgency=low

  * Fix build failure, only call dh_sphinxdoc when building
    python-llfuse-doc package.

Available diffs

Superseded in precise-release on 2012-01-03
python-llfuse (0.36-1) unstable; urgency=low

  * New upstream release.
  * Depend on Cython > 0.15.1, previous versions generated segfaulting
    code.
  * Breaks S3QL < 1.2, API changed in non-backwards compatible way.
    (python-llfuse is not in any stable release, and S3QL is the
    only reverse dependency, so a new package name does not seem
    justified).
  * Update format of copyright file.

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
python-llfuse (0.33-1) unstable; urgency=low
  * New upstream release.  * Build extension before generating documentation, so that    autogenerated documentation is no longer empty. Closes: 631871  * Ship cached python intersphinx file in debian/, so that it    does not need to be downloaded at build time. -- Nikolaus Rath <email address hidden>  Wed, 06 Jul 2011 09:32:38 -0400
Superseded in oneiric-release on 2011-07-27
python-llfuse (0.32-2) unstable; urgency=low

  * Created separate -doc package for documentation. Closes: 630632
  * Regenerate documentation in debian/rules. Closes: 630605
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  28 Jun 2011 10:02:44 +0000

Available diffs

Superseded in oneiric-release on 2011-06-28
python-llfuse (0.32-1) unstable; urgency=low

  * First official debian release. Closes: 626658
  * Breaks and Replaces s3ql <= 0.28, this package isn't in the official
    debian package but was provided by upstream over various channels (LLFUSE
    was factored out of S3QL in version 0.29).
  * Rebuilding of HTML documentation requires (yet unreleased) Sphinx version
    1.1 or resolution of wishlist bug #63040, therefore we do not rebuild the
    documentation in debian/rules but use the HTML files included in the
    upstream tarball.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  15 Jun 2011 22:59:29 +0000
145 of 45 results