Change log for pyudev package in Ubuntu

118 of 18 results
Published in groovy-release on 2020-04-24
Published in focal-release on 2020-02-20
Deleted in focal-proposed (Reason: moved to Release)
pyudev (0.21.0-3ubuntu1) focal; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Fix tests with recent hypothesis version.

Superseded in focal-proposed on 2020-02-19
pyudev (0.21.0-3) unstable; urgency=medium

  * Team upload.
  * Drop python2 support; Closes: #938293, #912966
  * Add hypothesis, mock, py, pytest, six to b-d, needed by tests
  * Dont fail tests during build, udev devices may not be available in chroots

 -- Sandro Tosi <email address hidden>  Tue, 17 Dec 2019 11:44:47 -0500
Superseded in focal-release on 2020-02-20
Deleted in focal-proposed on 2020-02-23 (Reason: moved to Release)
pyudev (0.21.0-2ubuntu1) focal; urgency=medium

  * Fix tests with recent hypothesis version.

 -- Matthias Klose <email address hidden>  Wed, 06 Nov 2019 15:27:29 +0100
Superseded in focal-release on 2019-11-06
Deleted in focal-proposed on 2019-11-07 (Reason: moved to Release)
pyudev (0.21.0-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/watch: Use https protocol
  * d/changelog: Remove trailing whitespaces
  * d/control: Remove ancient X-Python-Version field
  * d/control: Remove ancient X-Python3-Version field
  * Convert git repository from git-dpm to gbp layout
  * Use debhelper-compat instead of debian/compat.

  [ Felix Geyer ]
  * Backport upstream patches to fix compatbility with pytest 4.6.
    - Add Use_tool_pytest_instead_of_pytest.diff
    - Add tests_fix_tests_for_pytest_4.0.diff
    - Closes: #942179

 -- Felix Geyer <email address hidden>  Tue, 15 Oct 2019 00:16:32 +0200
Superseded in focal-release on 2019-10-25
Published in eoan-release on 2019-10-11
Deleted in eoan-proposed (Reason: moved to Release)
pyudev (0.21.0-1ubuntu1) eoan; urgency=medium

  * Refresh section name in setup.cfg.

 -- Matthias Klose <email address hidden>  Fri, 11 Oct 2019 13:33:55 +0200
Superseded in eoan-release on 2019-10-11
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
pyudev (0.21.0-1) unstable; urgency=medium

  * New upstream release.
  * Run more tests.
  * Add isolation-machine restriction to autopkgtests.

 -- Felix Geyer <email address hidden>  Fri, 09 Sep 2016 23:35:21 +0200

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
pyudev (0.19.0-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

  [ Felix Geyer ]
  * New upstream release.
  * d/watch: Mangle upstream version so RCs are less than final releases.

 -- Felix Geyer <email address hidden>  Tue, 26 Apr 2016 20:58:21 +0200

Available diffs

Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
pyudev (0.16.1-3) unstable; urgency=medium

  * Update the watch file.
  * Fix unsafe library loading. (Closes: #722573)
    - Add libudev_loading.diff
  * Bump Standards-Version to 3.9.6, no changes needed.
  * Build-depend on dh-python.
  * Switch to debhelper compat level 9.
  * Add autopkgtests.

 -- Felix Geyer <email address hidden>  Fri, 26 Jun 2015 19:46:32 +0200
Superseded in wily-release on 2015-06-27
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-02-24
Deleted in trusty-proposed (Reason: moved to release)
pyudev (0.16.1-2build1) trusty; urgency=medium

  * Rebuild to drop files installed into /usr/share/pyshared.
 -- Matthias Klose <email address hidden>   Sun, 23 Feb 2014 13:53:41 +0000
Superseded in trusty-release on 2014-02-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
pyudev (0.16.1-2) unstable; urgency=low


  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Luk Claes ]
  * Upload to unstable as 0.16 copes with udev 183 and higher 
    (Closes: #722570).

 -- Felix Geyer <email address hidden>  Mon, 16 Sep 2013 19:41:40 +0200
Superseded in saucy-release on 2013-09-17
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
pyudev (0.16.1-1ubuntu1) raring; urgency=low

  * Flip dependencies from libudev0 to libudev1.
 -- Martin Pitt <email address hidden>   Fri, 15 Mar 2013 10:55:25 +0100

Available diffs

Superseded in raring-release on 2013-03-15
Deleted in raring-proposed on 2013-03-16 (Reason: moved to release)
pyudev (0.16.1-1build1) raring; urgency=low

  * No-change rebuild against libudev1
 -- Martin Pitt <email address hidden>   Wed, 13 Mar 2013 07:02:12 +0000
Superseded in raring-release on 2013-03-14
Deleted in raring-proposed on 2013-03-16 (Reason: moved to release)
pyudev (0.16.1-1) experimental; urgency=low


  * New upstream release.
    - Require at least python 3.1.
  * Switch to my @debian.org email address.
  * Bump Standards-Version to 3.9.4, no changes needed.
  * Update Homepage field.
  * Fix FTBFS if built twice in a row. (Closes: #671218)

 -- Felix Geyer <email address hidden>  Thu, 25 Oct 2012 16:41:07 +0200

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
Superseded in quantal-release on 2012-09-24
Superseded in quantal-release on 2012-06-15
Published in precise-release on 2011-12-14
pyudev (0.13-1) unstable; urgency=low

  * New upstream release.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  14 Dec 2011 09:46:50 +0000

Available diffs

Superseded in precise-release on 2011-12-14
Obsolete in oneiric-release on 2015-04-24
pyudev (0.12-1) unstable; urgency=low

  * New upstream release.
 -- Scott Kitterman <email address hidden>   Sun,  25 Sep 2011 09:51:17 +0000

Available diffs

Superseded in oneiric-release on 2011-09-25
pyudev (0.11-1) unstable; urgency=low
  * New upstream release.  * Bump Standards-Version to 3.9.2, no changes needed.  * Add DM-Upload-Allowed: yes. -- Felix Geyer <email address hidden>  Thu, 14 Jul 2011 10:31:51 +0200
Superseded in oneiric-release on 2011-07-27
pyudev (0.10-1) unstable; urgency=low

  * Team upload

  [ Felix Geyer ]
  * Guard loops over supported python versions with set -e.
  * Install upstream changelog.

  [ Scott Kitterman ]
  * New upstream release
  * Add libudev0 (>= 151) to build-depends to support tests
  * Drop ${python:Breaks} and ${python3:Breaks}, not used by dh_python2/3
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  01 May 2011 08:01:58 +0000

Available diffs

Superseded in oneiric-release on 2011-05-01
Obsolete in natty-release on 2013-06-04
Superseded in natty-release on 2011-02-23
pyudev (0.8-1) unstable; urgency=low

  * Initial release. (Closes: #612663)
 -- Felix Geyer <email address hidden>   Mon,  14 Feb 2011 11:44:20 +0000
118 of 18 results