Change log for wicd package in Ubuntu

142 of 42 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-05
Deleted in cosmic-proposed (Reason: moved to release)
wicd (1.7.4+tb2-6) unstable; urgency=low

  * Set "Rules-Requires-Root: no".
  * Add debian/duck-override for "moved to" false positive on
    bugs.debian.org.
  * Declare compliance with Debian Policy 4.1.4. (No changes needed.)
  * Apply patch by Wasif Malik to fix "AttributeError in keypress():
    'Text' object has no attribute 'keypress'" in wicd-curses. Thanks
    Wasif! (Closes: #814090)
  * Update Vcs-* headers for move to salsa.debian.org.
  * Bump debhelper compatibility level to 11.
    + Update versioned debhelper build-dependency accordingly.
  * Fix several spelling errors in packaging found by Lintian.
  * Install upstream .service files, but patch them to fix multiple
    lintian warnings and to not disconnect the network connection on
    service stop. (Closes: #789567)
  * Replace dependency on python-gobject with python-gobject-2. (Closes:
    #890179)
  * Replace gksu and gksudo with pkexec and su-to-root. (Closes: #885546)
    + Update and rename patch 32-prefer_gksu.patch accordingly.
    + Recommend policykit-1 or menu (or kde-runtime for kdesu) instead of
      gksu.
  * Add a DEP12 upstream metadata file.
  * Add a note to /etc/default/wicd that the file is ignored if systemd is
    used as init system.

 -- Axel Beckert <email address hidden>  Mon, 23 Apr 2018 01:10:23 +0200

Available diffs

Superseded in cosmic-release on 2018-05-05
Published in bionic-release on 2017-11-11
Deleted in bionic-proposed (Reason: moved to release)
wicd (1.7.4+tb2-5) unstable; urgency=medium

  * Add location of Debian derivatives patches in debian/README.source.
  * Declare compliance with Debian Policy 4.1.1.
    + Switch DEP5 copyright format URL to HTTPS.
  * Replace dependencies on "net-tools | ethtool" and "net-tools |
    iproute2" in wicd-daemon with a hard dependency on net-tools and
    suggesting ethtool and iproute2 in python-wicd. Thanks to Neels
    Hofmeyr for the bug report. (Closes: #881225)
  * Switch bugs.debian.org URLs in DEP3 headers to HTTPS and short form.

 -- Axel Beckert <email address hidden>  Sat, 11 Nov 2017 00:18:14 +0100

Available diffs

Superseded in bionic-release on 2017-11-11
Published in artful-release on 2017-05-29
Deleted in artful-proposed (Reason: moved to release)
wicd (1.7.4+tb2-4) unstable; urgency=medium

  [ Axel Beckert ]
  * Drop old quilt-related contents of debian/README.source and hijack it
    for inter-distribution hints.

  [ Giap Tran ]
  * Add patch to fix wrong Galician translation (Closes: #856690,
    LP: #1689138)
  * Add Vietnamese translation.
  * Change my name to ASCII-compatible variant also in debian/changelog.

 -- Axel Beckert <email address hidden>  Sun, 28 May 2017 22:20:00 +0200

Available diffs

Superseded in artful-release on 2017-05-29
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
wicd (1.7.4+tb2-3) unstable; urgency=medium

  [ Axel Beckert ]
  * Now maintained by the Debian WICD Packaging Team. (Closes: #801253)
    + Change Vcs-* URLs to …/pkg-wicd/wicd.git
    + Update Maintainers field and add Uploaders field.
  * Add NEWS.Debian entry for changes between Jessie and Stretch
    wrt. /etc/wicd/dhclient.conf.template and the possible need to update
    the file manually.
  * Update dependency on dhcpcd to dhcpcd5. (Closes: #783272) Thanks
    Konrad Zimmermann!
  * Fix typo MSCHAPv2 vs MSCHAPV2 for more pedantic wpa_supplicant 2.6.
    (LP: #1656061) Thanks to Piotr Karbowski for the upstream bug report
    and suggested fix!
  * Add WPA*-PEAP templates without domain. (Closes: #831805, #759785, LP:
    #1591489)
  * Add patch to fix documentation wrt. to which dhclient.conf wicd
    (re)generates. Also update mention path in an older NEWS.Debian item
    to avoid confusion. (Closes: #773809)

  [ Giáp Trần ]
  * Remove $DAEMON_OPTIONS from reload function.

  [ John C. Peterson ]
  * wicd-gtk: Add patch to initialize state of Wifi On/Off button
    properly. (Closes: #758737, LP: #1232521)

  [ Vincent Lefevre ]
  * Add patch to fix wicd-manager-settings.conf(5) man page
    wrt. wired_connect_mode. (Closes: #557156)

 -- Axel Beckert <email address hidden>  Sun, 22 Jan 2017 17:16:07 +0100

Available diffs

Superseded in zesty-release on 2017-01-23
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
wicd (1.7.4+tb2-2) unstable; urgency=low

  * QA upload

  [ Axel Beckert ]
  * Fix FTBFS if $LANG is unset (or set to something unexpected) by
    hardcoding a sane value in debian/rules. (Closes: #824596)
  * Declare compliance with Debian Policy 3.9.8. (No changes needed.)
  * Switch Vcs-Git header from git:// to https://.

  [ Giáp Trần ]
  * Add default DAEMON_ARGS="--keep-connection" to /etc/default/wicd
    (Closes: #816076)

 -- Axel Beckert <email address hidden>  Sun, 22 May 2016 23:50:03 +0200

Available diffs

Superseded in yakkety-release on 2016-05-23
Published in xenial-release on 2016-02-17
Deleted in xenial-proposed (Reason: moved to release)
wicd (1.7.4+tb2-1) unstable; urgency=low

  * QA upload

  [ toogley ]
  * cleaned up trailing spaces inside d/changelog
  * fixing lintian error "command-in-menu-file-and-desktop-file"
    https://lintian.debian.org/tags/command-in-menu-file-and-desktop-file.html

  [ Axel Beckert ]
  * Import second tarball release of new upstream release.
    + Remove 38-fix_WEP-hex_connection_template.patch (applied upstream)
    + Refresh 26-support_etc-network_scripts.patch.
  * Remove 02-workaround_dhclient_bug.patch (#609851 has been fixed in
    dhclient)

 -- Axel Beckert <email address hidden>  Tue, 26 Jan 2016 10:11:53 +0100

Available diffs

Superseded in xenial-release on 2016-02-17
Deleted in xenial-proposed on 2016-02-18 (Reason: moved to release)
wicd (1.7.3-3) unstable; urgency=low

  * QA upload
  * Add patch from upstream bug report to fix "IndexError: list index out
    of range" in wicd-curses. (Closes: #812224)
  * Add patch to fix the parsing and writing of wep-hex configurations and
    hence fix connecting to WEP based networks. (Closes: #812427)

 -- Axel Beckert <email address hidden>  Sun, 24 Jan 2016 02:35:17 +0100
Superseded in xenial-release on 2016-01-26
Deleted in xenial-proposed on 2016-01-27 (Reason: moved to release)
wicd (1.7.2.4-4.2ubuntu1) xenial; urgency=low

  * Merge from Debian unstable (LP: #1510854).  Remaining changes:
    - debian/patches/34-fix-resolv.conf_backup-restore-broken-link.patch:
      allow wicd-daemon to start when /etc/resolv.conf is a broken link

Superseded in xenial-release on 2015-11-13
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-01-14
Deleted in trusty-proposed (Reason: moved to release)
wicd (1.7.2.4-4.1ubuntu1) trusty; urgency=low

  * debian/patches/34-fix-resolv.conf_backup-restore-broken-link.patch:
    allow wicd-daemon to start when /etc/resolv.conf is a broken link
    (LP: #1132529)
 -- <email address hidden> (Javier P.L.)   Fri, 06 Dec 2013 01:02:49 -0600
Superseded in trusty-release on 2014-01-14
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
wicd (1.7.2.4-4.1) unstable; urgency=low


  * Non-maintainer upload
  * Add patch by isis agora lovecruft to fix wicd-curses run time errors
    caused by the changes of python-urwid 1.1 API (Closes: #709120)
  * Bump wicd-curses dependency on python-urwid to >= 1.1

 -- Axel Beckert <email address hidden>  Fri, 07 Jun 2013 18:42:23 +0200

Available diffs

Superseded in saucy-release on 2013-06-10
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
wicd (1.7.2.4-4) unstable; urgency=low


  * Move user-adding code from debconf-config to wicd-daemon postinst
    (Closes: #692916)

 -- David Paleino <email address hidden>  Sat, 10 Nov 2012 21:41:50 +0100

Available diffs

Superseded in raring-release on 2012-11-11
Deleted in raring-proposed on 2012-11-12 (Reason: moved to release)
wicd (1.7.2.4-3) unstable; urgency=low


  * Fix debian/watch
  * Recommend rfkill in wicd-daemon (Closes: #683559)
  * Substitute dependency on dhcp3-client with isc-dhcp-client
    (Closes: #680976)
  * Fix handling of /etc/resolv.conf when it's a symlink (Closes: #691973)

 -- David Paleino <email address hidden>  Fri, 02 Nov 2012 21:49:32 +0100
Superseded in raring-release on 2012-11-03
Obsolete in quantal-release on 2015-04-24
wicd (1.7.2.4-2ubuntu1) quantal; urgency=low

  * Switch dependancies from the now obsolete transitional package
    dhcp3-client to the replacement isc-dhcp-client.
 -- Andy Whitcroft <email address hidden>   Mon, 09 Jul 2012 13:54:40 +0100
Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
wicd (1.7.0+ds1-2ubuntu0.1) lucid-security; urgency=low

  * SECURITY UPDATE: local privilege escalation (LP: #979221)
    - debian/patches/23-fix_local_privilege_escalation.patch: sanitize
      config properties. Thanks to David Paleino <email address hidden>
    - CVE-2012-2095
  * SECURITY UPDATE: information leak in log files (LP: #992177)
    - debian/patches/24-mask-sensitive-info-from-log.patch: mask sensitive
      information in logs. Thanks to David Paleino <email address hidden>
    - CVE-2012-0813
 -- Julian Taylor <email address hidden>   Mon, 30 Apr 2012 22:15:04 +0200
Obsolete in natty-updates on 2013-06-04
Obsolete in natty-security on 2013-06-04
wicd (1.7.0+ds1-6ubuntu0.11.04.1) natty-security; urgency=low

  * SECURITY UPDATE: local privilege escalation (LP: #979221)
    - debian/patches/36-fix_local_privilege_escalation.patch: sanitize
      config properties. Thanks to David Paleino <email address hidden>
    - CVE-2012-2095
  * SECURITY UPDATE: information leak in log files (LP: #992177)
    - debian/patches/37-mask-sensitive-info-from-log.patch: mask sensitive
      information in logs. Thanks to David Paleino <email address hidden>
    - CVE-2012-0813
 -- Julian Taylor <email address hidden>   Mon, 30 Apr 2012 19:57:13 +0200
Obsolete in oneiric-updates on 2015-04-24
Obsolete in oneiric-security on 2015-04-24
wicd (1.7.0+ds1-6ubuntu0.11.10.1) oneiric-security; urgency=low

  * SECURITY UPDATE: local privilege escalation (LP: #979221)
    - debian/patches/36-fix_local_privilege_escalation.patch: sanitize
      config properties. Thanks to David Paleino <email address hidden>
    - CVE-2012-2095
  * SECURITY UPDATE: information leak in log files (LP: #992177)
    - debian/patches/37-mask-sensitive-info-from-log.patch: mask sensitive
      information in logs. Thanks to David Paleino <email address hidden>
    - CVE-2012-0813
 -- Julian Taylor <email address hidden>   Mon, 30 Apr 2012 19:57:13 +0200
Published in precise-updates on 2012-05-07
Published in precise-security on 2012-05-07
wicd (1.7.2.3-1ubuntu0.1) precise-security; urgency=low

  * SECURITY UPDATE: local privilege escalation (LP: #979221)
    - debian/patches/33-fix_local_privilege_escalation.patch: sanitize
      config properties. Thanks to David Paleino <email address hidden>
    - CVE-2012-2095
 -- Julian Taylor <email address hidden>   Mon, 30 Apr 2012 22:22:03 +0200
Superseded in quantal-release on 2012-07-09
wicd (1.7.2.4-2) unstable; urgency=high


  * Fix comments inside /etc/default/wicd (Closes: #668327)
  * Fixed sanitation bug (urgency=high)

 -- David Paleino <email address hidden>  Fri, 04 May 2012 10:22:46 +0200

Available diffs

Superseded in quantal-release on 2012-05-06
wicd (1.7.2.4-1) unstable; urgency=high


  * New upstream version
    - really fix local privilege escalation, CVE-2012-2095 (Closes: #668397)
  * Fixed typo in previous changelog entry

 -- David Paleino <email address hidden>  Mon, 30 Apr 2012 21:32:55 +0200

Available diffs

Superseded in quantal-release on 2012-05-01
Published in precise-release on 2012-04-23
wicd (1.7.2.3-1) unstable; urgency=high


  * New upstram version
    - fix bug with wicd-curses and UTF-8 locales (Closes: #669602)

 -- David Paleino <email address hidden>  Sun, 22 Apr 2012 18:42:19 +0200

Available diffs

Superseded in precise-release on 2012-04-23
wicd (1.7.2.1-1) unstable; urgency=low


  * New upstream version
    - fix crash with wicd-curses (Closes: #668520)

 -- David Paleino <email address hidden>  Thu, 12 Apr 2012 22:08:37 +0200

Available diffs

Superseded in precise-release on 2012-04-16
wicd (1.7.1-1) unstable; urgency=low


  * New upstream release
  * Patches refreshed to match 1.7.1's code

 -- David Paleino <email address hidden>  Thu, 02 Feb 2012 20:36:02 +0100

Available diffs

Superseded in precise-release on 2012-02-11
wicd (1.7.0+ds1-9) unstable; urgency=high

  * Fix postinst: it breaks dh_python2's layout

Available diffs

Superseded in precise-release on 2011-10-25
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
wicd (1.7.0+ds1-6) unstable; urgency=low

  * debian/patches/:
    - 26-support_etc-network_scripts.patch refreshed, /etc/network/
      scripts should now be properly supported (Closes: #579497)
    - 31-dont_crash_on_notification_exceptions.patch added
      (Closes: #569755, #587303)
    - 32-prefer_gksu.patch added (Closes: #575403)
    - 33-deepcopy_python27_fixes.patch backported from Ubuntu,
      thanks to Matthieu Baerts (LP: #602825)
    - 34-dont_save_useless_config.patch added: don't save link quality,
      signal strength and bitrates in the configuration files.
      (Closes: #612918)
    - 35-restrict_netmode_characters.patch added, don't crash
      if the network mode is not what we expect. Thanks to Julien
      Blache for the patch (Closes: #550957)
  * debian/control:
    - removed depedency on python-iniparse from wicd-daemon
    - removed Build-Depends on quilt
    - fixed typo in long description, thanks to Martin Eberhard Schauer
      (Closes: #611567)
    - bump Standards-Version to 3.9.1, no changes needed
    - use Breaks+Replaces instead of Conflicts+Replaces
  * debian/rules:
    - don't use "--with quilt" anymore
  * debian/po/pt_BR.po added: debconf translation for Brazilian
    Portuguese, thanks to Adriano Rafael Gomes (Closes: #594266)
  * debian/wicd-daemon.config: don't ask if all users are already
    in the netdev group (Closes: #588078)
  * debian/wicd-cli.8: explain -w/--save and -m/--name (Closes: #583586)
  * debian/wicd-daemon.wicd.init, export $PATH, makes the daemon work
    in a clean environment. Thanks to Peter Palfrader (Closes: #604810)
  * debian/wicd-curses.postrm: redirect stderr (Closes: #605338)
 -- Bhavani Shankar <email address hidden>   Sat, 12 Feb 2011 00:16:58 +0100
Superseded in natty-release on 2011-02-12
wicd (1.7.0+ds1-5ubuntu1) natty; urgency=low

  * debian/patches/
   - Added 31-deepcopy+python27-fixes.patch for python 2.7
     (credit to Archlinux and Remy Oudompheng - LP: #602825)
 -- Matthieu Baerts (matttbe) <email address hidden>   Sat, 11 Dec 2010 15:33:10 +0200
Superseded in natty-release on 2010-12-11
Obsolete in maverick-release on 2013-03-05
wicd (1.7.0+ds1-5) unstable; urgency=medium

  * debian/patches/series:
    - 26-support_etc-network_scripts.patch disabled, needs more proper
      support (reopen #579497)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  31 May 2010 10:32:48 +0100

Available diffs

Superseded in maverick-release on 2010-05-31
wicd (1.7.0+ds1-4) unstable; urgency=high

  * Urgency high because of RC #582980
  * debian/patches:
    - 25-use_dhcpcd_also_in_Debian.patch refreshed, to make it work
      again with dhcpcd. Thanks to Brad Jorsch (Closes: #582980)
    - 30-make_connection_info_selectable.patch added (Closes: #571579)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  27 May 2010 09:26:30 +0100

Available diffs

Superseded in maverick-release on 2010-05-27
wicd (1.7.0+ds1-3) unstable; urgency=low

  * debian/control:
    - fixed package descriptions (Closes: #574152)
  * debian/patches/:
    - 23-fix_script_macro_expansion.patch ported from upstream,
      fixes bug in script macro expansion.
    - 24-wait_for_DHCP_client.patch added, waits for DHCP's client
      process to end, avoiding zombie processes. Thanks to Marin
      Ivanov for the patch! (Closes: #537195)
    - 25-use_dhcpcd_also_in_Debian.patch added: upstream changed
      the client from dhcpcd to dhcpcd-bin. This patch reverts it,
      so that defaults in /etc/default/dhcpcd are still observed.
      (Closes: #578014)
    - 26-support_etc-network_scripts.patch added, support /etc/network/
      hierarchy for connection scripts (Closes: #579497)
    - 27-fix_resolv.conf_perms.patch added, make sure dhclient.conf has
      0644 permissions (Closes: #582798)
    - 28-announce_dhclient.conf.template.patch added, describe
      /etc/wicd/dhclient.conf.template in wicd(8) (Closes: #582817)
    - 29-document_variables_passed_to_scripts.patch added (Closes: #570891)
  * debian/NEWS.Debian updated to announce /etc/wicd/dhclient.conf.template
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  25 May 2010 10:15:52 +0100

Available diffs

Superseded in maverick-release on 2010-05-25
Obsolete in lucid-release on 2016-10-26
wicd (1.7.0+ds1-2) unstable; urgency=low

  * Fix RC bug: daemon doesn't start anymore because copy.deepcopy()
    fails with the iniparse object, coming from 20-use_iniparse.patch.
    Bug 568326 reopened. (Closes: #572599)

Available diffs

Superseded in lucid-release on 2010-03-22
wicd (1.7.0-2) unstable; urgency=low

  * debian/rules:
    - pass --install-layout=deb to python setup.py install
      (Closes: #565536)
  * debian/control:
    - break circular dependency, make wicd-daemon only Recommend the
      clients. (Closes: #565608)

Available diffs

Superseded in lucid-release on 2010-02-02
wicd (1.6.2.2-4) unstable; urgency=low

  * debian/control:
    - updated my email address
    - DMUA removed
  * debian/config: add --quiet to adduser, don't show messages if
    user is already in netdev (Closes: #556182)
  * debian/patches/:
    - 07-workaround_urwid_API_change.patch added, handle API change
      between python-urwid 0.9.8.4 and python-urwid 0.9.9
      (Closes: #557462)
    - 08-fix_help_message.patch added, fix minor issue with help
      message of wicd-curses
    - 09-allow_empty_DNS.patch added, one might run a local
      forwarder and 127.0.0.1 wouldn't work (Closes: #552598)
    - 10-order_scripts_directories.patch added, scripts were run
      in a random order (python's os.listdir())
    - 11-fix_gui_showing_from_tray.patch added, raises the GUI
      also when it was trayed in an iconified state (Closes: #549625)
  * debian/links removed, debian/manpages added (Closes: #557173)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  21 Dec 2009 10:44:41 +0000

Available diffs

Superseded in lucid-release on 2009-12-21
wicd (1.6.2.2-3) unstable; urgency=low

  * debian/po/ja.po updated (Closes: #554838)
  * debian/patches/06-dont_bomb_out_on_configparser_error.patch added
    (Closes: #554949)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  17 Nov 2009 17:47:47 +0000

Available diffs

Superseded in lucid-release on 2009-11-17
wicd (1.6.2.2-2) unstable; urgency=low

  * debian/po/ja.po added, thanks to Hideki Yamane (Closes: #546231)
  * debian/control:
    - remove Conflict on network-manager, since both can be used at
      the same time, provided they don't try to control the same
      interface (Closes: #548978)
    - added dependency on dbus (Closes: #540331, #551605)
  * debian/patches/05-use_binsh.patch added (Closes: #549443)

Available diffs

Superseded in lucid-release on 2009-11-11
Obsolete in karmic-release on 2013-03-04
wicd (1.6.1-3ubuntu1) karmic; urgency=low

  * Configure with --no-install-acpi, removing acpi-support integration.
    We've used pm-utils for some time now (LP: #366119).

 -- Colin Watson <email address hidden>   Fri, 04 Sep 2009 16:37:00 +0100

Available diffs

Superseded in karmic-release on 2009-09-04
wicd (1.6.1-3) unstable; urgency=low

  * debian/config, debian/templates updated:
    - only show users to add to netdev, skip those who are already
      members (Closes: #534138)
    - gracefully handle upgrades from previous broken versions, where
      debconf set a value of ${default} for wicd/users
      (Closes: #532112)

Available diffs

Superseded in karmic-release on 2009-06-25
wicd (1.5.9-5) unstable; urgency=low

  * debian/patches/:
    - 08-fix_GetIP.patch added, thanks to Giuseppe Martino
      (Closes: #519433)
    - 09-fix_wire_plugging_detection.patch, added, thanks to Giuseppe 
      Martino (Closes: #503738)
  * debian/control:
    - Standards-Version bumped to 3.8.1:
      + debian/init fixed, /var/run/wicd created on init.d script 
      start, since /var/run may be mounted as a temporary filesystem 
      (§9.3.2)

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
wicd (1.5.9-2) unstable; urgency=low

  * debian/patches/:
    - 06-add_LC_MESSAGES_parsing.patch added (Closes: #514553)
    - 07-add_resolvconf_support.patch added (Closes: #514597)
  * debian/README.Debian updated:
    - add information on how to add users to netdev.
    - add information on how to reload DBus
  * debian/NEWS.Debian updated:
    - add information on how to reload DBus
  * debian/control:
    - swapped Maintainer/Uploaders fields
  * debian/postrm:
    - only force-reload DBus if it's already started (Closes: #514778)
  * debian/postinst: add a netdev *group*, not *user* (Closes: #514597)
  * debian/po/fr.po added, debian/rules updated:
    - workaround to fix broken translation in broken i18n system
      (Closes: #516459)

 -- Alessio Treglia <email address hidden>   Thu,  26 Feb 2009 05:55:49 +0000

Available diffs

Superseded in jaunty-release on 2009-02-26
wicd (1.5.9-1) unstable; urgency=low

  * New upstream release:
    - Fixed security hole in DBus configuration file
    - Fixed the TTLS template
  * debian/patches/:
    - 05-fix_DBus_policy.patch added, allow only members of the netdev
      group to configure wicd (Closes: #512160)
  * debian/postinst: add group "netdev", which will be the only one able
    to configure wicd
  * debian/control: added dependency on adduser
  * debian/NEWS.Debian and debian/docs added, explain the new permissions
    policy

 -- David Paleino <email address hidden>   Thu,  12 Feb 2009 08:46:52 +0000

Available diffs

Superseded in jaunty-release on 2009-02-12
wicd (1.5.8-1) unstable; urgency=low

  * New upstream release
  * debian/control:
    - DM-Upload-Allowed set (ACKed by Bernd Zeimetz)

 -- David Paleino <email address hidden>   Tue,  03 Feb 2009 01:48:40 +0000

Available diffs

Superseded in jaunty-release on 2009-02-03
wicd (1.5.7-2) unstable; urgency=high

  [ David Paleino ]
  * debian/rules:
    - passing --lib to configure, moving files in /usr/share/wicd
      (Closes: #510461)
    - also removing other/55wicd in clean target
    - binary-arch target emptied, not using it
  * debian/prerm removed:
  * debian/postinst updated:
  * debian/postrm updated:
    - fix double-{starting,stopping} of wicd
    - forcibly reload dbus upon installation or removal
  * debian/default added.
  * debian/init updated:
    - allow to disable the daemon in /etc/default/wicd.

  [ Bernd Zeimetz ]
  * debian/rules:
    - run dh_pysupport before dh_installinit, so Python modules will be
      compiled before the daemon starts (Closes: #510457)
    - call setup.py configure and install with appropriate options, so the
      modules are installed in the private module directory properly
      (Closes: #510462).
  * debian/patches/04-fix-scripts.patch:
    - set PYTHONPATH while executing script so Python will find them
      in the private directory (Closes: #510308)

 -- David Paleino <email address hidden>   Thu,  08 Jan 2009 05:56:23 +0000

Available diffs

Superseded in jaunty-release on 2009-01-08
wicd (1.5.7-1) unstable; urgency=low

  * New upstream release (Closes: #503737)
  * debian/control:
    - added some runtime dependencies (not really, but used by most 
      users) to wicd (Closes: #503739)
    - added Conflicts: network-manager (Closes: #509051)
    - added Suggests on pm-utils, since we now also have those
      functionalities
    - update Vcs-* and Maintainer fields to reflect injection into
      PAPT
  * debian/postrm added:
    - removes runtime-generated files (Closes: #503747)
  * debian/patches:
    - 02-fix_logfile_perms.patch added, sets permissions of 
      /var/log/wicd/wicd.log to root:adm (Closes: #503749)
    - 03-fix_lintian_manpage_warning.patch added, gives a more
      meaningful whatis entry
  * debian/rules:
    - get-orig-source target to ease upstream tarball fetch
    - ensure right permissions are set in install target
    - using dh7-style rules
  * debian/README.source added
  * debian/docs removed
  * debian/copyright fixed:
    - added copyright year to in/man*
    - removed useless escaping of '=' in filenames
    - fixed pointer to GPL-2

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  24 Dec 2008 22:36:50 +0000

Available diffs

Superseded in jaunty-release on 2008-12-24
wicd (1.5.2-1) unstable; urgency=low

  * Initial release (Closes: #465870)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  07 Nov 2008 16:41:11 +0000
142 of 42 results