"Safe graphics mode" doesn't use VESA

Bug #59618 reported by robepisc on 2006-09-09
44
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: casper

If I choose "Safe graphics mode" in the boot menu I see that "xforcevesa" is correctly added to the kernel boot parameters, but that hint is ignored by the X configuration scripts of the LiveCD.
That is, in my desktop pc, X always uses nv, even if requested to use vesa by "xforcevesa".

It's a real problem on my laptop, which has a SiS630, because it is affected by #57452 in Knot2 (that is sis doesn't work in Knot2). And even in safe graphics mode it keeps on using sis!

Related branches

robepisc (robepisc) wrote :

From the attached dmesg output:

Kernel command line: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed boot=casper xforcevesa initrd=/casper/initrd.gz ramdisk_size=1048576 root=/dev/ram rw quiet splash -- locale=it kbd-chooser/method=it

robepisc (robepisc) wrote :

As you can see, it doesn't use vesa.

Enrico Sardi (enricoss) wrote :

Hi at all!

I've tried to install Edgy on an Asus 2420 (sis730) and I have the same problem above...

Enrico

robepisc (robepisc) wrote :

Still present in Edgy Beta!

Since "Safe graphics mode" is prominent in the LiveCD boot screen and it's the only hope for people with a buggy graphics card, I think it's very important that it does what it's supposed to do in the stable release.

OrkanSpec (orkanspec) wrote :

I confirm the problem with "safe graphics mode".
I have an NVidia GF 6600 AGP graphics card, which does not work with "nv" driver. It works well with proprietary "nvidia" driver and "vesa".
When booting 6.10 beta there is no difference to me between standard boot and "Start Kubuntu in safe graphics mode" - both the ways result in corrupted display (vertical lines). This "safe graphics mode" worked well in 6.06.

robepisc (robepisc) on 2006-10-02
Changed in casper:
status: Unconfirmed → Confirmed
Tollef Fog Heen (tfheen) wrote :

xorg has configuration for this which doesn't seem to work correctly.

robepisc (robepisc) wrote :

In fact.
The debconf script of xserver-xorg, when executed, sees that "xforcevesa" flag is in use and sets vesa as the default driver.
So far so good.
But then it makes a probe of the video chipset, and if it finds a known one, overrides the default (vesa) with that one (in my case, sis)!

The solution would simply be to modify the debconf script so that, if xforcevesa is set, the probe is completely skipped.

Changed in xorg:
assignee: nobody → ubuntu-x-swat
DominikBodi (dominik-bodi) wrote :

The bug persists in 6.10 final. I've attached my Xorg.0.log to https://launchpad.net/distros/ubuntu/+bug/67405

DominikBodi (dominik-bodi) wrote :

Please escalate the importance of this bug. More duplicate reports keep coming in. "Safe graphics mode" is a workaround for many gfx problems troubling x.org with certain chipsets. Bug #22985 is just one example of what can go wrong. All the other popular gfx chipsets have problems that bite users, as well.

Using the vesa driver for X has always been a good workaround to get the system to a working state. Now this doesn't work any more and many new users will not be able to get X running at all. Judging the number of bug duplicate bug reports that have been trickling in so, you will lose a big number of new users because of this bug unless you act quickly and escalate this problem.

I concur with DominikBodi; <a href="https://launchpad.net/distros/ubuntu/+source/linux-meta/+bug/67487">Bug #67487</a> is another example where being able to force X to use vesa could very well solve the issue of not being able to boot the LiveCD <b>at all</b>.

Including more advanced solutions (such as "ati" and "nv" drivers) is great for a LiveCD, but there must also be the option of using a much more basic, "sure to work" method in the event the first method fails.

zBrain (nick-customdesigns) wrote :

Wow....

I just attempted to install 6.10 on a box with a Voodoo 3 3000 in it just to play around and try Kubuntu out. Not fixing this before release wasn't cool, it affects a lot of people. I don't understand how the severity of this bug is undecided...it's pretty severe! Affecting multiple cards from Nvidia, ATI, and other vendors to the point of being difficult/impossible to even run the installer is bad....and the bug is months old.

TLE (k-nielsen81) wrote :

I agree that this it is very important that this bug gets fixed very soon, and hopefully that it'll be fixed on the 6.10.1 cd.

I the mean time there is a workaround here: https://launchpad.net/distros/ubuntu/+source/xserver-xorg-video-ati/+bug/67487
See the post from Tormod from 2006-11-05 16:31:36 CET

On Tue, 2006-11-07 at 10:32 +0000, TLE wrote:
> and hopefully that it'll be fixed on the 6.10.1 cd.
AFAIK, point releases will only happen for LTS releases, such as 6.06
LTS. 6.10 isn't a LTS, so it won't have a point release (6.10.1). This
was the case with all the releases before 6.06.

--
Bruce Cowan <https://launchpad.net/people/bruce89>

yansnow (ygrugni) wrote :

Same problem as above, impossible to start the Edgy 6.10 live CD in safe mode.

!!! I find that a very Crittical bug and I don't understand why the importance is this undecide!!!
Don't forget that run the safe mode is vey important as it is the only way, for a lot of people, to suceed to install ubuntu if their cards doesn't work well with ati/nvidia driver.

For example I have a fujitsu Siemens A7600 labtop with ATI Radeon IGP320m memory card, and I know by experience that there is only 2 config which works : vesa and radeon with dri disabled.
For Dapper, the safe mode was working nice for me and was the only way to succed to install ubuntu as the normal/install mode was using wrong driver.

So could you please escalate it.

Tormod Volden (tormodvolden) wrote :

I linked to what I hope is clear instructions for a workaround to https://wiki.ubuntu.com/EdgyKnownIssues

ps. If someone knows of some screenshots that would explain things better, please add them to the wiki page.

robepisc (robepisc) wrote :

Just took some screeshots with QEMU and added them to the wiki as you asked.
I hope they are ok.

Thank you Tormod for your nice work on EdgyKnownIssues!
I think it is very useful for both users and developers.

xtknight (xt-knight) wrote :

I don't understand how it is "undecided". It probably affects 15% of everyone who tries to install Ubuntu. The 15% includes people with NVIDIA cards that cause garbling with the nv driver, and other cards that do not work properly by default.

Colin Watson (cjwatson) on 2006-12-18
Changed in xorg:
importance: Undecided → High

As I stated in a comment above, the patch is really trivial.
It is against the /var/lib/dpkg/info/xserver-xorg.config file from Feisty Herd 1, i.e. the debconf file of the xserver-xorg 1:7.1.1ubuntu6 package.

See the attachment.

robepisc (robepisc) wrote :

This is how you can test the previous patch with QEMU:

1. create an empty floppy image (dd if=/dev/zero of=fd.img bs=1k count=1440)
2. format it with mkfs.vfat
3. loop mount it somewhere
4. put xserver-xorg.config.patch there
5. umount it
6. boot a Feisty Herd1 desktop CD image with qemu:

   $ qemu -fda fd.img -cdrom feisty-desktop-i386.iso -boot d

7. boot with: "xforcevesa break=casper-bottom single" and without "quiet splash"
8. at the console, do:

   $ insmod /root/lib/modules/2.6.19-7-generic/kernel/drivers/block/floppy.ko
   $ mkdir /tmp/floppy
   $ mount -t vfat /dev/fd0 /tmp/floppy
   $ patch /root/var/lib/dpkg/info/xserver-xorg.config < /tmp/floppy/xserver-xorg.config.patch
   $ umount /tmp/floppy
   $ rm -r /tmp/floppy
   $ rmmod floppy
   $ ^D

9. wait...
10. check how your just autogenerated /etc/X11/xorg.conf uses vesa instead of cirrus (which is the virtual video card emulated by qemu)
11. enjoy :-)

Still broken in Herd 2 of Feisty Fawn.

Colin Watson (cjwatson) wrote :

I've uploaded robepisc's patch, although it'll probably be for Herd 4 rather than Herd 3 at this point.

Changed in xorg:
assignee: ubuntu-x-swat → kamion
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

Tollef decided to accept this for Herd 3.

xorg (1:7.1.1ubuntu7) feisty; urgency=low

  [ robepisc ]
  * Skip video card autodetection if xforcevesa is set (LP: #59618).

 -- Colin Watson <email address hidden> Wed, 31 Jan 2007 10:38:30 +0000

Changed in xorg:
status: Fix Committed → Fix Released
OrkanSpec (orkanspec) wrote :

I confirm that "Safe graphics mode" works for me in Kubuntu 7.04 Heard 3 (amd64).

Thanks for fixing the bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers