Ubuntu

“postgresql-8.4” 8.4.15-0ubuntu12.04 source package in The Precise Pangolin

Publishing history

8.4.15-0ubuntu12.04
SUPERSEDED: Precise pocket Updates in component universe and section database
  • Removed from disk on 2013-02-16.
  • Removal requested on 2013-02-15.
  • Superseded on 2013-02-14 by postgresql-8.4 - 8.4.16-0ubuntu12.04
  • Published on 2012-12-19
8.4.15-0ubuntu12.04
DELETED: Precise pocket Proposed in component universe and section database
  • Removed from disk on 2013-02-16.
  • Removal requested on 2012-12-19.
  • Deleted on 2012-12-19 by Colin Watson

    moved to -updates

  • Published on 2012-12-12

Builds

Changelog

postgresql-8.4 (8.4.15-0ubuntu12.04) precise-proposed; urgency=low

  * New upstream bug fix release: (LP: #1088393)
    - Fix multiple bugs associated with "CREATE INDEX CONCURRENTLY"
      Fix "CREATE INDEX CONCURRENTLY" to use in-place updates when
      changing the state of an index's pg_index row. This prevents race
      conditions that could cause concurrent sessions to miss updating
      the target index, thus resulting in corrupt concurrently-created
      indexes.
      Also, fix various other operations to ensure that they ignore
      invalid indexes resulting from a failed "CREATE INDEX CONCURRENTLY"
      command. The most important of these is "VACUUM", because an
      auto-vacuum could easily be launched on the table before corrective
      action can be taken to fix or remove the invalid index.
    - See HISTORY/changelog.gz for details about other bug fixes.
 -- Martin Pitt <email address hidden>   Mon, 10 Dec 2012 15:38:48 +0100