Debian Libvirt Maintainers does not use Launchpad. This page was created on 2007-12-17 when the virt-manager_0.5.2-3 package was uploaded to hardy/RELEASE.

Is this a team you run?