Debian Telepathy maintainers does not use Launchpad. This page was created on 2007-05-08 when the farsight_0.1.19-2 package was uploaded to gutsy/RELEASE.

Is this a team you run?