Virtualisation - various (Xenial & newer)

PPA description

Virtualisation PPA (libvirt 8.9.0, qemu 7.1, and more) for Xenial & newer.

*** Please always see https://launchpad.net/~savoury1 for general updates about this Launchpad site before contacting me or reporting any bugs! ***

*** Big thanks to the few (0.25% of all users) who have donated to support this project, you have helped keep it alive to now! To the 99.75% of users who have not donated: please do so if you can as a significant increase in support is still needed for work on these PPAs to continue long term. ***

If software at this site is useful to you then please consider a donation:

*** Donations: https://paypal.me/Savoury1 & https://ko-fi.com/Savoury1 ***
*** Also https://patreon.com/Savoury1 & https://liberapay.com/Savoury1 ***

==========================================================================
                 Virtualisation - various (Xenial & newer)
==========================================================================

acpica-unix (20200925), augeas (1.13.0), autopkgtest (5.16), bcg729 (1.1.1), device-tree-compiler (1.6.1), dmidecode (3.4), e2fsprogs (1.46.5), fuse3 (3.12.0), gfs2-utils (3.3.0), gnutls28 (3.7.3), google-perftools (2.10), gtk-vnc (1.3.1), hivex (1.3.21), hwloc (2.8.0), iniparser (4.1), ipxe (1.21.1+git-20220113), keyutils (1.6.1), libbpf (0.8.0), libcacard (2.8.0), libedit (3.1-20210910), libfabric (1.11.0), libfakekey (0.3+git20170516), libgovirt (0.3.8), libinih (53), libisci (1.19.0), libldm (0.2.5), libnftnl (1.2.1), libnl3 (3.5.0), libosinfo (1.10.0), libpsm2 (12.2.185), libslirp (4.7.0), libsys-virt-perl (8.9.0), libtirpc (1.3.2), libtorrent-rasterbar (2.0.8 Jammy / 1.2.15 Focal / 1.2.11 final Py 2.7 version), libtpms (0.9.3), libusb-1.0 (1.0.26), libvirt{-python} (8.9.0), libvirt-dbus (1.4.1), *glib (4.0.0), libzstd (1.5.2), lsscsi (0.31), nbd (3.24), ndctl (73), nettle (3.7.3), nftables (1.0.4), ntfs-3g (2022.10.3), numactl (2.0.14), openmpi (4.1.4), opensbi (1.1), osinfo-db (0.20221018), osinfo-db-tools (1.10.0), partclone (0.3.20), parted (3.5), pci.ids (0.0~2022.10.28), pcre2 (10.39), phodav (2.5), pmdk (1.12.0), pmix (4.1.2), qemu (7.1), seabios (1.16.0), spice (0.15.0), spice-protocol (0.14.3), spice-gtk (0.41), supermin (5.2.1), swtpm (0.6.3), tox (3.21.4), ucx (1.13.0), usb.ids (2022.05.20), usbredir (0.13.0), virglrenderer (0.9.1), virt-manager (4.1.0), virt-p2v (1.42.3), virt-v2v (1.45.99), virt-viewer (11.0), virt-what (1.25), wireshark (3.6.8), xfsprogs (5.13.0)

Focal & Jammy: liburing (2.2 requires kernel >= 5.1)

Focal only: libice (= libinih 53 / renamed source for i386 build only)

Bionic only (for Xenial use ppa:savoury1/gtk-xenial): pygobject (3.32.2)

Xenial & Bionic: cyrus-sasl2 (2.1.27), dh-sysuser (1.3.3), ebtables (2.0.10.4+snapshot20181205), glusterfs (7.2), icu (66.1), infinipath-psm, iptables (1.8.4), json-c4 (0.13.1), leveldb, libbfio, libewf, libguestfs (1.40.2), libnbd (1.2.2), librest (0.8.1), libvirt-php (0.5.5), lxc (3.0.4), lxc-templates, lxd (3.0.4 bug fix release), mdadm (4.1), nbdkit (1.16.2), nfs-utils (1.3.4), ocaml-libvirt (0.6.1.5), python3-lxc (3.0.4), quota (4.05), rdma-core (28.0), rpcbind (1.2.5), ruby-fog-libvirt, ruby-libvirt, virtualenv-clone (0.3.0), virtualenvwrapper (4.8.4), vmem (1.8), xen (4.11.3+24-g14b62ab3e5), zerofree (1.1.1), zfs-fuse (0.7.0), zfs-linux (0.8.3)

Xenial only: afflib, ceph (12.2.13), dpdk (17.11.10), hfsplus (1.0.4-15), ipxe-qemu-256k-compat, ocaml, openssl, openvswitch (2.9.8), pcre2, php-imagick, sanlock, sgabios, sleuthkit

* denotes a shorthand package name with a common prefix or suffix removed

==========================================================================

IMPORTANT NOTE for Focal and earlier: Upgrading to fuse3 can cause dpkg to attempt removal of many packages, rather than it just simply upgrading the old fuse to fuse3 (which then "provides" fuse anyhow). To rectify this for now until a possible different solution is found do the following command:

  sudo apt-get install fuse3

NOTE: An advanced PPA for the latest virtualisation software. Adding this PPA and upgrading the system will install many changes, especially for older systems (Xenial & Bionic era). Be sure you want this before choosing to proceed and as always: do a full system backup before such an upgrade!

Update (17 Mar 2021): A workaround for a long-standing issue with libvirt backport (currently 7.0.0) on Xenial systems is now included. The issue was the libvirtd service consistently failing to start on boot due to a "start request repeated too quickly" error, which is fixed by adding a systemd startup timer of 30 seconds to force a delayed libvirtd start.

If you are using this PPA for Bionic (or newer) and are encountering the same issue then please report this bug and the libvirtd package can then be updated for the series in question by adding the same libvirtd.timer unit.

*** Install ***

Notes for Xenial: This PPA depends on ppa:savoury1/display for newer than default display drivers, which newer virtualisation software here depends on. Thus, to install on Xenial-based systems do these steps (the FFmpeg 4 PPA provides newer GStreamer and GCC 7.5.0 for Xenial, also required):

  sudo add-apt-repository ppa:savoury1/ffmpeg4
  sudo add-apt-repository ppa:savoury1/display
  sudo add-apt-repository ppa:savoury1/virtualisation
  sudo apt-get update
  sudo apt-get upgrade && sudo apt-get dist-upgrade

Lastly, GTK >= 3.22 is required for virt-manager >= 3.2.0 so the following command must be added to the above commands for virt-manager on Xenial:

  sudo add-apt-repository ppa:savoury1/gtk-xenial

*** Build ***

This PPA has build dependencies on:

  ppa:savoury1/build-tools
  ppa:savoury1/backports
  ppa:savoury1/encryption
  ppa:savoury1/python
  ppa:savoury1/multimedia
  ppa:savoury1/ffmpeg4
  ppa:savoury1/display

Additionally, for Xenial & Bionic:

  ppa:savoury1/tex-2019
  ppa:savoury1/goland-defaults-1.13

Additionally, for Xenial only:

  ppa:savoury1/toolchain
  ppa:savoury1/perl-xenial
  ppa:savoury1/gtk-xenial
  ppa:savoury1/gcc-defaults-7 (specific builds only)

Adding this PPA to your system

You can update your system with unsupported packages from this untrusted PPA by adding ppa:savoury1/virtualisation to your system's Software Sources. (Read about installing)

sudo add-apt-repository ppa:savoury1/virtualisation
sudo apt update
        
Technical details about this PPA

This PPA can be added to your system manually by copying the lines below and adding them to your system's software sources.

Display sources.list entries for:
deb https://ppa.launchpadcontent.net/savoury1/virtualisation/ubuntu YOUR_UBUNTU_VERSION_HERE main 
deb-src https://ppa.launchpadcontent.net/savoury1/virtualisation/ubuntu YOUR_UBUNTU_VERSION_HERE main 
Signing key:
4096R/E996735927E427A733BB653E374C7797FB006459 (What is this?)
Fingerprint:
E996735927E427A733BB653E374C7797FB006459

Dependencies:

For questions and bugs with software in this PPA please contact Rob Savoury.

PPA statistics

Activity
95 updates added during the past month.
View package details

Overview of published packages

175 of 374 results
Package Version Uploaded by
acpica-unix 20200925-6~20.04.sav0 Rob Savoury ()
acpica-unix 20200925-6~18.04.sav0 Rob Savoury ()
acpica-unix 20200925-6~16.04.sav0 Rob Savoury ()
afflib 3.7.16-2build2~16.04.sav0 Rob Savoury ()
augeas 1.13.0-1~20.04.sav0 Rob Savoury ()
augeas 1.13.0-1~18.04.sav0 Rob Savoury ()
augeas 1.13.0-1~16.04.sav0 Rob Savoury ()
autopkgtest 5.16ubuntu2~20.04.sav0 Rob Savoury ()
autopkgtest 5.16ubuntu2~18.04.sav0 Rob Savoury ()
autopkgtest 5.16ubuntu2~16.04.sav0 Rob Savoury ()
bcg729 1.1.1-2~20.04.sav0 Rob Savoury ()
bcg729 1.1.1-2~18.04.sav0 Rob Savoury ()
bcg729 1.1.1-2~16.04.sav0 Rob Savoury ()
ceph 12.2.13+ds1-0ubuntu0.16.04.10sav0 Rob Savoury ()
cyrus-sasl2 2.1.27+dfsg-2ubuntu0.1~18.04.sav0 Rob Savoury ()
cyrus-sasl2 2.1.27+dfsg-2ubuntu0.1~16.04.sav0 Rob Savoury ()
device-tree-compiler 1.6.1-4~22.04.sav0 Rob Savoury ()
device-tree-compiler 1.6.1-4~20.04.sav0 Rob Savoury ()
device-tree-compiler 1.6.1-4~18.04.sav0 Rob Savoury ()
device-tree-compiler 1.6.1-4~16.04.sav0 Rob Savoury ()
dh-sysuser 1.3.3~18.04.sav0 Rob Savoury ()
dh-sysuser 1.3.3~16.04.sav0 Rob Savoury ()
dmidecode 3.4-1~22.04.sav0 Rob Savoury ()
dmidecode 3.4-1~20.04.sav0 Rob Savoury ()
dmidecode 3.4-1~18.04.sav0 Rob Savoury ()
dmidecode 3.4-1~16.04.sav0 Rob Savoury ()
dpdk 17.11.10-0ubuntu0.1~16.04.sav0 Rob Savoury ()
e2fsprogs 1.46.5-2ubuntu1.1~20.04.sav0 Rob Savoury ()
e2fsprogs 1.46.5-2ubuntu1.1~18.04.sav0 Rob Savoury ()
e2fsprogs 1.46.5-2ubuntu1.1~16.04.sav0 Rob Savoury ()
ebtables 2.0.10.4+snapshot20181205-1ubuntu1~18.04.sav0 Rob Savoury ()
ebtables 2.0.10.4+snapshot20181205-1ubuntu1~16.04.sav0 Rob Savoury ()
fuse3 3.12.0-1~22.04.sav1 Rob Savoury ()
fuse3 3.12.0-1~20.04.sav0 Rob Savoury ()
fuse3 3.12.0-1~18.04.sav0 Rob Savoury ()
fuse3 3.12.0-1~16.04.sav0 Rob Savoury ()
gdisk 1.0.5-1~18.04.sav0 Rob Savoury ()
gdisk 1.0.5-1~16.04.sav0 Rob Savoury ()
gfs2-utils 3.3.0-2~20.04.sav0 Rob Savoury ()
gfs2-utils 3.3.0-2~18.04.sav0 Rob Savoury ()
gfs2-utils 3.3.0-2~16.04.sav0 Rob Savoury ()
glusterfs 7.2-2~18.04.sav0 Rob Savoury ()
glusterfs 7.2-2~16.04.sav0 Rob Savoury ()
gnutls28 3.7.3-4ubuntu1.1~20.04.sav0 Rob Savoury ()
gnutls28 3.7.3-4ubuntu1.1~18.04.sav0 Rob Savoury ()
gnutls28 3.7.3-4ubuntu1.1~16.04.sav0 Rob Savoury ()
google-perftools 2.10-0ubuntu1~22.04.sav0 Rob Savoury ()
google-perftools 2.10-0ubuntu1~20.04.sav0 Rob Savoury ()
google-perftools 2.10-0ubuntu1~18.04.sav0 Rob Savoury ()
google-perftools 2.10-0ubuntu1~16.04.sav0 Rob Savoury ()
gtk-vnc 1.3.1-1~22.04.sav0 Rob Savoury ()
gtk-vnc 1.3.1-1~20.04.sav0 Rob Savoury ()
gtk-vnc 1.3.1-1~18.04.sav0 Rob Savoury ()
gtk-vnc 1.3.1-1~16.04.sav0 Rob Savoury ()
hfsplus 1.0.4-15~16.04.sav0 Rob Savoury ()
hivex 1.3.21-1ubuntu1~20.04.sav0 Rob Savoury ()
hivex 1.3.21-1ubuntu1~18.04.sav0 Rob Savoury ()
hivex 1.3.21-1ubuntu1~16.04.sav0 Rob Savoury ()
hwloc 2.8.0-1~22.04.sav0 Rob Savoury ()
hwloc 2.8.0-1~20.04.sav0 Rob Savoury ()
hwloc 2.8.0-1~18.04.sav0 Rob Savoury ()
hwloc 2.8.0-1~16.04.sav0 Rob Savoury ()
icu 66.1-2ubuntu2.1~18.04.sav0 Rob Savoury ()
icu 66.1-2ubuntu2.1~16.04.sav0 Rob Savoury ()
infinipath-psm 3.3+20.604758e7-6~18.04.sav0 Rob Savoury ()
infinipath-psm 3.3+20.604758e7-6~16.04.sav0 Rob Savoury ()
iniparser 4.1-4ubuntu2~20.04.sav0 Rob Savoury ()
iniparser 4.1-4ubuntu2~18.04.sav0 Rob Savoury ()
iniparser 4.1-4ubuntu2~16.04.sav0 Rob Savoury ()
iptables 1.8.4-3ubuntu2~18.04.sav0 Rob Savoury ()
iptables 1.8.4-3ubuntu2~16.04.sav0 Rob Savoury ()
ipxe 1.21.1+git-20220113.fbbdc3926-0ubuntu1~20.04.sav0 Rob Savoury ()
ipxe 1.21.1+git-20220113.fbbdc3926-0ubuntu1~18.04.sav0 Rob Savoury ()
ipxe 1.21.1+git-20220113.fbbdc3926-0ubuntu1~16.04.sav0 Rob Savoury ()
ipxe-qemu-256k-compat 1.0.0+git-20150424.a25a16d-0ubuntu2~16.04.sav0 Rob Savoury ()
175 of 374 results

Latest updates

  • ntfs-3g 12 days ago
    Successfully built
  • ntfs-3g 12 days ago
    Successfully built
  • ntfs-3g 12 days ago
    Successfully built
  • ntfs-3g 12 days ago
    Successfully built
  • fuse3 12 days ago
    Successfully built