Change log for doomsday package in Ubuntu

123 of 23 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-24
Published in focal-release on 2020-03-30
Deleted in focal-proposed (Reason: moved to Release)
doomsday (2.2.2+ds1-1) unstable; urgency=medium

  * Team upload.
  * Upload to unstable.
  * debian/doomsday-compat: Add back the compatibility layer.
  * debian/patches-old: Drop no-libexample.patch, no longer
    needed.
  * debian/control: Update Vcs-* field to use correct one.

 -- Boyuan Yang <email address hidden>  Mon, 02 Mar 2020 15:54:49 -0500

Available diffs

Superseded in focal-release on 2020-03-30
Deleted in focal-proposed on 2020-04-01 (Reason: moved to Release)
doomsday (2.2.2+ds1-1~exp2) experimental; urgency=medium

  * Team upload.
  * debian/control:
    + Replace build-dependency of libqt5opengl5-dev with
      libqt5opengl5-desktop-dev. This game is know to be requiring
      desktop OpenGL support. (Previously explicitly excluded armel
      and armhf in the architecture section)
    + Use "Rules-Require-Root: no".
    + Mark package doomsday-data as Multi-Arch: foreign.
  * debian/copyright: Fix file matching issues (lintian info).
  * debian/doomsday.links: Dropped for now since we are not shipping
    doomsday-compat script.

 -- Boyuan Yang <email address hidden>  Fri, 14 Feb 2020 23:00:03 -0500
Superseded in focal-release on 2020-02-21
Deleted in focal-proposed on 2020-02-23 (Reason: moved to Release)
doomsday (1.15.8-5ubuntu1) focal; urgency=medium

  * Build-depend on python2 instead of python.

 -- Matthias Klose <email address hidden>  Fri, 31 Jan 2020 11:05:47 +0100
Superseded in focal-proposed on 2020-01-31
doomsday (1.15.8-5build4) focal; urgency=medium

  * No-change upload for libassimp soname change.

 -- Matthias Klose <email address hidden>  Fri, 31 Jan 2020 07:28:47 +0100

Available diffs

Superseded in focal-release on 2020-02-13
Deleted in focal-proposed on 2020-02-14 (Reason: moved to Release)
doomsday (1.15.8-5build3) focal; urgency=medium

  * No-change rebuild against libassimp4

 -- Steve Langasek <email address hidden>  Wed, 01 Jan 2020 16:34:32 -0800
Superseded in focal-proposed on 2020-01-02
doomsday (1.15.8-5build2) focal; urgency=medium

  * Rebuild against new libfluidsynth2.

 -- Gianfranco Costamagna <email address hidden>  Mon, 16 Dec 2019 12:20:28 +0100

Available diffs

Superseded in focal-release on 2020-01-02
Published in eoan-release on 2019-04-18
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-11-26
Deleted in bionic-proposed (Reason: moved to release)
doomsday (1.15.8-5build1) bionic; urgency=medium

  * No-change rebuild against latest assimp

 -- Jeremy Bicha <email address hidden>  Sat, 25 Nov 2017 18:58:04 -0500
Obsolete in zesty-updates on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to -updates)
doomsday (1.15.8-3ubuntu0.1) zesty; urgency=medium

  * Add patches to fix the following issues:
    - segfault on startup (Closes: #847651. Fixes LP: #1700822)
    - segfault when attempting to start a new game (Closes: #863536)
    - make the build reproducible (Closes: #858333)
  * Effectively this adds the same patches as in 1.15.8-5, therefore
    the reproducible build patch is included as well to keep the delta
    to that version to a minimum.

 -- Hans Joachim Desserud <email address hidden>  Tue, 27 Jun 2017 20:59:36 +0200
Superseded in bionic-release on 2017-11-26
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed on 2020-07-10 (Reason: moved to release)
doomsday (1.15.8-5) unstable; urgency=medium

  * Team upload.
  * Add mo-thinker-NULL-pointer.patch and fix another segfault.
    Thanks to Hans Joachim Desserud for the report and Bernhard Übelacker for
    the patch. (Closes: #863536)
  * Make the build reproducible. Thanks to Chris Lamb for the report and patch.
    (Closes: #858333)

 -- Markus Koschany <email address hidden>  Thu, 01 Jun 2017 23:42:23 +0200

Available diffs

Superseded in artful-release on 2017-06-02
Deleted in artful-proposed on 2017-06-03 (Reason: moved to release)
doomsday (1.15.8-4) unstable; urgency=medium

  * Team upload.
  * Add Node-parent-NULL-pointer.patch and fix startup crash.
    Thanks to Bernhard Übelacker for the patch. (Closes: #847651)

 -- Markus Koschany <email address hidden>  Tue, 23 May 2017 15:08:36 +0200

Available diffs

Superseded in artful-release on 2017-05-24
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
doomsday (1.15.8-3) unstable; urgency=medium

  * Team upload.
  * d/rules: Remove --parallel option because we use compat 10 already.
  * Remove override for dh_install and do not call strip-nondeterminism
    manually. Let debhelper handle this task automatically. (Closes: #839338)
  * Vcs: Switch to cgit and https.

 -- Markus Koschany <email address hidden>  Sun, 09 Oct 2016 18:15:23 +0200

Available diffs

Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-01-03
Deleted in xenial-proposed (Reason: moved to release)
doomsday (1.15.7-2) unstable; urgency=medium

  * Avoid gcc 5.3.1-4 (see: #809165).

 -- Michael Gilbert <email address hidden>  Sun, 03 Jan 2016 06:50:15 +0000

Available diffs

Superseded in xenial-release on 2016-01-03
Deleted in xenial-proposed on 2016-01-04 (Reason: moved to release)
doomsday (1.15.5-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Gilbert <email address hidden>  Sun, 15 Nov 2015 19:36:05 +0000

Available diffs

Superseded in xenial-release on 2015-11-16
Deleted in xenial-proposed on 2015-11-17 (Reason: moved to release)
doomsday (1.15.4-1) unstable; urgency=medium

  * New upstream release.
  * Use deterministic timestamps in zip files.

 -- Michael Gilbert <email address hidden>  Sun, 04 Oct 2015 00:55:42 +0000

Available diffs

Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
doomsday (1.15.3-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Gilbert <email address hidden>  Sat, 05 Sep 2015 18:14:05 +0000
Superseded in wily-release on 2015-09-16
Deleted in wily-proposed on 2015-09-17 (Reason: moved to release)
doomsday (1.15.1-1build1) wily; urgency=medium

  * No-change rebuild against libassimp3v5

 -- Steve Langasek <email address hidden>  Tue, 11 Aug 2015 16:34:28 +0000
Superseded in wily-release on 2015-08-16
Deleted in wily-proposed on 2015-08-18 (Reason: moved to release)
doomsday (1.15.1-1) unstable; urgency=medium

  * New upstream release.
  * Remove timestamp macros.
  * Replace more shared library exit calls.

 -- Michael Gilbert <email address hidden>  Mon, 06 Jul 2015 19:01:53 +0000

Available diffs

Superseded in wily-release on 2015-07-07
Deleted in wily-proposed on 2015-07-08 (Reason: moved to release)
doomsday (1.15.0-1) unstable; urgency=medium

  * New upstream release.
  * Update debian/copyright (closes: #789882).
  * Update debian/watch for new tarball naming scheme.
  * Use abort instead of exit for some of the shared library failure modes.
  * More robust doomsday-compat (closes: #787985, #788053, #788058, #789882).
    - Many thanks to Fabian Greffrath.

 -- Michael Gilbert <email address hidden>  Sun, 28 Jun 2015 19:51:14 +0000
Superseded in wily-proposed on 2015-06-29
doomsday (1.14.5-3) unstable; urgency=medium

  * Fix lintian warnings.
  * Fix some spelling errors.
  * Escape hyphens in manpages.
  * Split into separate binary packages.

 -- Michael Gilbert <email address hidden>  Sat, 06 Jun 2015 04:32:31 +0000

Available diffs

Superseded in wily-release on 2015-06-29
Deleted in wily-proposed on 2015-06-30 (Reason: moved to release)
doomsday (1.14.5-2) unstable; urgency=medium

  * Update debian/copyrgiht.
  * Add some lintian overrides.
  * Fix /usr/lib installation path.
  * Add manpage for doomsday-compat.
  * Document persist.pack problem (closes: #786758).

 -- Michael Gilbert <email address hidden>  Mon, 25 May 2015 21:17:56 +0000

Available diffs

Superseded in wily-release on 2015-05-26
Deleted in wily-proposed on 2015-05-27 (Reason: moved to release)
doomsday (1.14.5-1) unstable; urgency=medium

  * New upstream release.
  * Update debian/watch file.
  * Enable all build hardening flags.
  * Spelling correction patch now applied upstream.
  * Exclude some unused files from the upstream tarball.
  * Turn fullscreen antialiasing off by default (buggy in upstream 1.14).
  * Adopt the package (closes: #775830, 775928).
  * Correctly parse argument ordering (closes: #749723).
  * Install files into to FHS directories (closes: #783707).

 -- Michael Gilbert <email address hidden>  Sun, 24 May 2015 19:02:31 +0000

Available diffs

Superseded in wily-release on 2015-05-25
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
doomsday (1.10.4-2) unstable; urgency=medium


  [ Fabian Greffrath ]
  * Add rudimentary support for PWAD files in doomsday-compat
    to allow for loading hexdd via a desktop file.
  * Add separate game modes for Freedoom Phases 1 and 2 and FreeDM.
  * Add myself to Uploaders, I am doing the QA anyway.
  * Document missing licenses in debian/copyright (Closes: #740602).
  * Add desktop and menu files and icons (Closes: #737860).

  [ Jonathan Dowland ]
  * Remove myself from uploaders.

  [ Vincent Cheng ]
  * Update to Standards version 3.9.5, no changes required.

 -- Fabian Greffrath <email address hidden>  Mon, 24 Mar 2014 09:46:25 +0100

Available diffs

Superseded in utopic-release on 2014-05-11
Deleted in utopic-proposed on 2014-05-12 (Reason: moved to release)
doomsday (1.10.4-1) unstable; urgency=low


  * Team upload.
  * Set Maintainer: Debian Games Team and remove Uploaders: Kees Meijs
    (Closes: #708843).
  * Imported Upstream version 1.10.4 (Closes: #692095).
    + This version is able to run freedoom, so move this and
      alternative dependencies back from Suggests: to
      Recommends: (Closes: #661329 for real).
    + Fixes FTBFS with libpng (Closes: #650595).
    + Fixes FTBFS with -Werror=format-security (Closes: #646251).
  * debian/doomsday-compat: This script translates between the "-iwad" parameter
    as expected by vanilla Doom and the one expected by the Doomsday Engine.
    + Install as /usr/games/doomsday-compat.
    + Register as alternative for doom and boom in doomsday.{postinst,prerm}.
    + Add Provides: boom-engine, doom-engine to doomsday.
    + Add a native "freedoom" game mode.
  * Remove debian/README.source, we now ship the pristine tarball.
  * Fix installation directories.
  * Avoid installation of APT repository lists.
  * Remove debian/doomsday.6, install upstream manpage instead.
  * Convert to "3.0 (quilt)" source format.
  * Convert to debhelper 9 debian/rules format.
  * Convert to machine-readable debian/copyright format.
  * Fix spelling errors detected by lintian.
  * Remove useless Depends: timidity.
  * Build the fluidsynth plugin.
  * Update Build-Depends with libraries that we actually link against.
  * Run "wrap-and-sort -asb".
  * Install /etc/doomsday/paths to set a system-level iwaddir path.
  * Provide heretic-engine and hexen-engine, add the corresponding heretic-wad
    and hexen-wad to Recommends and register the corresponding alternatives.

 -- Fabian Greffrath <email address hidden>  Mon, 26 Aug 2013 14:57:22 +0200
123 of 23 results