Change log for yosys package in Ubuntu

123 of 23 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-09-09
Deleted in groovy-proposed (Reason: moved to Release)
yosys (0.9-1build4) groovy; urgency=medium

  * No change rebuild against new libffi8ubuntu1 ABI.

 -- Dimitri John Ledkov <email address hidden>  Mon, 24 Aug 2020 20:12:47 +0100
Superseded in groovy-proposed on 2020-08-24
yosys (0.9-1build3) groovy; urgency=medium

  * No change rebuild against new libffi ABI.

 -- Dimitri John Ledkov <email address hidden>  Thu, 20 Aug 2020 13:45:14 +0100
Superseded in groovy-release on 2020-09-09
Published in focal-release on 2020-02-08
Deleted in focal-proposed (Reason: moved to Release)
yosys (0.9-1build2) focal; urgency=medium

  * No-change rebuild with fixed binutils on arm64.

 -- Matthias Klose <email address hidden>  Sat, 08 Feb 2020 11:21:47 +0000

Available diffs

Superseded in focal-release on 2020-02-08
Deleted in focal-proposed on 2020-02-10 (Reason: moved to Release)
yosys (0.9-1build1) focal; urgency=medium

  * No-change rebuild for libffi soname change.

 -- Matthias Klose <email address hidden>  Sun, 12 Jan 2020 08:30:38 +0000

Available diffs

Superseded in focal-release on 2020-01-31
Deleted in focal-proposed on 2020-02-01 (Reason: moved to Release)
yosys (0.9-1) unstable; urgency=medium

  * Upload to sid
  * New upstream release
    - Refreshed patches
  * debian/copyright:
    - Get copyright info up-to-date
  * debian/control:
    - New standards version 4.4.0 - no changes
    - DH level 12
    - Use debhelper-compat instead of debian/compat file
    - Change build-dependency from texlive-generic-recommended to
      texlive-plain-generic (Closes: #941555) (Thanks Steve Langasek)
  * debian/rules:
    - Don't override dh_install with --fail-missing anymore

 -- Ruben Undheim <email address hidden>  Fri, 18 Oct 2019 23:27:34 +0200

Available diffs

Superseded in focal-release on 2019-10-25
Published in eoan-release on 2019-10-01
Deleted in eoan-proposed (Reason: moved to Release)
yosys (0.8-1ubuntu1) eoan; urgency=medium

  * Build-depend on texlive-plain-generic instead of obsolete texlive-
    generic-recommended.

 -- Steve Langasek <email address hidden>  Tue, 01 Oct 2019 15:15:41 -0700

Available diffs

Superseded in eoan-release on 2019-10-01
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed on 2020-07-14 (Reason: moved to release)
yosys (0.8-1build1) disco; urgency=medium

  * No-change rebuild for readline soname change.

 -- Matthias Klose <email address hidden>  Tue, 15 Jan 2019 10:26:21 +0000

Available diffs

Superseded in disco-release on 2019-01-27
Deleted in disco-proposed on 2019-01-29 (Reason: moved to release)
yosys (0.8-1) unstable; urgency=medium

  * New upstream release
  * debian/control:
    - New standards version 4.2.1 - no changes
  * debian/copyright:
    - New copyright years
    - Some new copyright holders for certain files
  * debian/patches: Fix patches after importing new version
  * d/patches/0013-Let-dpkg-buildpackage-handle-stripping-of-binaries.patch:
    - Fix issue with empty -dbgsym package
  * debian/rules:
    - Enable hardening
    - Remove redundant '--parallel'
    - Override dh_auto_install and remove executable permission on some files
    - Delete one more file in override_dh_auto_clean
  * debian/yosys.1: Updated man page for new version
  * debian/yosys.install: Install new files
  * debian/yosys.lintian-overrides:
    - Waive a 'spelling error' which is in fact not an error.

 -- Ruben Undheim <email address hidden>  Wed, 17 Oct 2018 18:36:13 +0200

Available diffs

Superseded in disco-release on 2018-11-11
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-07-13 (Reason: moved to release)
yosys (0.7-7) unstable; urgency=medium

  * debian/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch:
    - Do not quote CXXFLAGS_FOR_YOSYS_CONFIG (fixes build on all)

 -- Ruben Undheim <email address hidden>  Wed, 22 Aug 2018 07:23:08 +0200

Available diffs

Superseded in cosmic-proposed on 2018-08-22
yosys (0.7-6) unstable; urgency=medium

  * debian/compat: level 11
  * debian/control:
    - debhelper >= 11
    - Standards version 4.2.0 - no changes
  * debian/upstream/metadata: Added upstream metadata
  * d/patches/0011-Do-not-show-g-build-flags-in-Version-string.patch:
    - some build flags for the g++ version being used were "injected" into
      the source files for yosys. Remove them

 -- Ruben Undheim <email address hidden>  Tue, 21 Aug 2018 21:37:46 +0200

Available diffs

Superseded in cosmic-release on 2018-08-24
Deleted in cosmic-proposed on 2018-08-25 (Reason: moved to release)
yosys (0.7-5) unstable; urgency=medium

  * debian/patches/0010-Fix-adding-of-sys.path-in-yosys-smtbmc.patch
    - Fix "ModuleNotFoundError: No module named 'smtio'" (Closes: #904752)
  * debian/tests/smtbc:
    - Added CI test to check that 'yosys-smtbmc' can be started with no
      import errors

 -- Ruben Undheim <email address hidden>  Fri, 27 Jul 2018 20:57:41 +0200

Available diffs

Superseded in cosmic-release on 2018-07-28
Deleted in cosmic-proposed on 2018-07-29 (Reason: moved to release)
yosys (0.7-4) unstable; urgency=medium

  * d/patches/0010-Fix-reproducibility-of-PDF-documents-in-yosys-doc.patch
    - Another attempt of getting full reproducibility of PDF documents
      in yosys-doc

 -- Ruben Undheim <email address hidden>  Sat, 14 Jul 2018 23:47:09 +0200

Available diffs

Superseded in cosmic-release on 2018-07-15
Deleted in cosmic-proposed on 2018-07-16 (Reason: moved to release)
yosys (0.7-3) unstable; urgency=low

  * debian/copyright:
    - Use https protocol in Format field
  * debian/control:
    - Added dh-python as build-dependency (Closes: #896802)
    - Changed VCS URLs to Salsa
    - Mark 'yosys-doc' Multi-Arch: foreign
    - Remove 'Testsuite: autopkgtest' since it is now handled automatically
    - Updated Standards Version to 4.1.5 - requires reproducibility
  * debian/patches:
    - 0007-Disable-pretty-build.patch: New patch to disable pretty build
      (Closes: #847110)
    - 0008-Set-fixed-date-when-calling-pdflatex-for-presentatio.patch
      Improve reproducibility
    - 0009-Some-spelling-errors-fixed.patch: Fixed some spelling errors
      detected by lintian
  * debian/rules:
    - Pass down changelog date to pdflatex
    - Upstream source has moved to https://github.com/YosysHQ/yosys
    - Use /usr/share/dpkg/pkg-info.mk instead of separate calls to
      dpkg-parsechangelog
  * debian/watch:
    - Fix watch URL - now github.com/YosysHQ/yosys/releases

 -- Ruben Undheim <email address hidden>  Thu, 12 Jul 2018 17:27:53 +0200

Available diffs

Superseded in cosmic-release on 2018-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
yosys (0.7-2) unstable; urgency=medium

  * debian/control:
    - Moved berkeley-abc from Build-Depends-Indep to Build-Depends in order
      to fix dependency problem during test.

 -- Ruben Undheim <email address hidden>  Sun, 06 Nov 2016 14:40:47 +0000

Available diffs

Superseded in zesty-proposed on 2016-11-06
yosys (0.7-1) unstable; urgency=medium

  * New upstream release
  * Refreshed patches. Some patches applied upstream and deleted.
  * Updated man page for yosys
  * Simplified debian/*.install files
  * debian/patches/03_notruntests.patch deleted
    - Tests can now be run during build since an updated version
      of iverilog is in the archive
  * debian/control:
    - Depend on a newer version of berkeley-abc
    - Build-depend on iverilog >= 10.1

 -- Ruben Undheim <email address hidden>  Sun, 06 Nov 2016 11:28:06 +0100
Superseded in zesty-release on 2016-11-07
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
yosys (0.6-7) unstable; urgency=medium

  [ Ruben Undheim ]
  * Use gbp-pq for patches.
  * debian/control:
    - Removed dependency on GCC 5 which was added in 0.6-6. (Closes: #835953)
      It causes problems now since GCC 6 is default.

  [Sebastian Kuzminsky]
  * debian/patches/switch-to-free-font.patch: Switch manual tt font
    from libertine to inconsolata.  The yosys manual doesn't render with
    libertine on sid, but it renders nicely with inconsolata. (Closes: #835678)

 -- Ruben Undheim <email address hidden>  Thu, 22 Sep 2016 19:30:37 +0200
Superseded in yakkety-proposed on 2016-09-25
yosys (0.6-6build1) yakkety; urgency=medium

  * No-change rebuild for readline soname change.

 -- Matthias Klose <email address hidden>  Sat, 17 Sep 2016 12:12:46 +0000

Available diffs

Superseded in yakkety-release on 2016-09-26
Deleted in yakkety-proposed on 2016-09-27 (Reason: moved to release)
yosys (0.6-6) unstable; urgency=medium

  * Added versioned build-dependency on gcc-5 (>= 5.3.1-15) since it
    now fails to build with older versions due to the fix for #822408.
    (Closes: #823809)
  * Updated Standards to 3.9.8 - no changes

 -- Ruben Undheim <email address hidden>  Wed, 11 May 2016 22:20:00 +0200

Available diffs

Superseded in yakkety-release on 2016-05-12
Deleted in yakkety-proposed on 2016-05-13 (Reason: moved to release)
yosys (0.6-5) unstable; urgency=medium

  [ Sebastian Kuzminsky ]
  * debian/patches/fixup-initalization.patch:
    - Add a bugfix patch from upstream's development branch.

  [ Ruben Undheim ]
  * debian/patches/fix_ftbfs_cannot_find_infinite.patch:
    - Fixes FTBFS due to std::isfinite not found. (Closes: #822408)
  * Move PDFs in yosys-doc to /usr/share/doc/yosys in order to adhere to
    Debian Policy 12.3.
  * Refreshed patches

 -- Ruben Undheim <email address hidden>  Tue, 03 May 2016 21:56:53 +0200
Superseded in yakkety-proposed on 2016-05-04
yosys (0.6-4) unstable; urgency=medium

  * debian/rules:
    - Override dh_auto_build-arch instead of dh_auto_build to resolve
      build issue for "all" package.

 -- Ruben Undheim <email address hidden>  Sat, 09 Apr 2016 16:38:20 +0200
Superseded in yakkety-release on 2016-05-04
Published in xenial-release on 2016-02-08
Deleted in xenial-proposed (Reason: moved to release)
yosys (0.5.0+20151013gitf13e387-1) unstable; urgency=low

  * Uploaded to unstable
    - New features in yosys are needed for the Icestorm tool chain
  * New upstream version
    - Drop patches 04_installpath.patch and 06_cflags_ldflags.patch
    - Set PREFIX in d/rules
  * debian/control: Fixed Vcs-Git to use https

 -- Ruben Undheim <email address hidden>  Sun, 07 Feb 2016 11:59:04 +0100
Superseded in xenial-release on 2016-02-08
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
yosys (0.5.0-1) unstable; urgency=low


  * New upstream release
  * Added d/watch
  * Updated copyright years in d/copyright
  * Changed dependency from tcl8.5-dev to tcl-dev
  * Added d/gbp.conf
  * Added link from /usr/bin/yosys-abc to /usr/bin/berkeley-abc
    - Also added man page for yosys-abc
  * Fixed paths returned by yosys-config
    - fix included in 04_installpath.patch

 -- Ruben Undheim <email address hidden>  Mon, 09 Feb 2015 20:37:38 +0100

Available diffs

Superseded in vivid-release on 2015-02-11
Deleted in vivid-proposed on 2015-02-12 (Reason: moved to release)
yosys (0.4.0-1) unstable; urgency=medium


  * New upstream release
  * Few fixes in d/copyright
  * Removed some strictly not needed dependencies

 -- Ruben Undheim <email address hidden>  Wed, 12 Nov 2014 18:35:59 +0100
123 of 23 results