Change log for fglrx-installer package in Ubuntu

175 of 155 results
Published in trusty-updates on 2017-03-23
Deleted in trusty-proposed (Reason: moved to -updates)
fglrx-installer (2:15.201.2-0ubuntu0.14.04.1) trusty-proposed; urgency=medium

  * Avoid triggering any prompts for /etc (LP: #1511301).
  * Revert the previous change to etc/ati in the sources.

Superseded in trusty-proposed on 2017-03-15
fglrx-installer (2:15.201.1-0ubuntu0.14.04.1) trusty-proposed; urgency=medium

  * Bump the release replacing etc/ati so that we don't trigger a bug in
    software updater (LP: #1511301).

Superseded in trusty-proposed on 2017-03-09
fglrx-installer (2:15.201-0ubuntu0.14.04.3) trusty-proposed; urgency=medium

  * debian/control.in,
    debian/fglrx-core.postinst.in,
    debian/fglrx.preinst.in,
    debian/fglrx.postinst.in,
    debian/fglrx.dirs.in,
    debian/rules:
    - Make sure that fglrx pre-depends on fglrx-core.
    - Back up and restore the files that the old fglrx
      removes when upgrading (LP: #1511301).

Superseded in trusty-proposed on 2017-03-03
fglrx-installer (2:15.201-0ubuntu0.14.04.2) trusty-proposed; urgency=medium

  * debian/fglrx.{pre|post}inst.in:
    - Make sure to also migrate the real ati configuration dir, not
      only the symlinks, or the upgrade will fail (LP: #1511301).

 -- Alberto Milone <email address hidden>  Tue, 21 Feb 2017 17:01:32 +0100
Deleted in xenial-release on 2016-03-03 (Reason: (tjaalton) there will not be updates any more, incompatib...)
Deleted in xenial-proposed on 2016-03-03 (Reason: moved to release)
fglrx-installer (2:15.201-0ubuntu7) xenial; urgency=medium

  * debian/dkms.conf.in,
    dkms/patches/buildfix_kernel_4.4.patch:
    - Add support for Linux 4.4.

 -- Alberto Milone <email address hidden>  Wed, 13 Jan 2016 14:46:35 +0100
Superseded in trusty-updates on 2017-03-23
Deleted in trusty-proposed on 2017-03-24 (Reason: moved to -updates)
fglrx-installer (2:15.201-0ubuntu0.14.04.1) trusty-proposed; urgency=medium

  * New upstream release (Catalyst 15.9):
    - Fixed issues:
      + [424450] Company of Heroes® 2 - Game crashes while running
        the performance test.
      + [424794] Middle-earth™: Shadow of Mordor - Corruption
        observed in game.
      + [424882] DIRT® Showdown - Corruption observed in game.
      + [425234] DIRT® Showdown - Game crashes after the loading
        screen.
      + [424802] DOTA™ 2 – Application hang observed while exiting
        the game.
      + [423471] Unable to switch desktop mode after installing AMD
        Catalyst™ driver.
      + [423735] Renaming Counter-Strike: GO and other Steam game
        binary improves performance.
  * debian/dkms/patches/buildfix_kernel_4.0.patch,
    debian/dkms/patches/buildfix_kernel_4.1.patch,
    debian/dkms/patches/buildfix_kernel_4.2.patch,
    debian/dkms/patches/buildfix_kernel_4.2.fpregs_active.patch,
    debian/dkms/patches/buildfix_kernel_4.2.copy_xregs_to_kernel.patch:
    - Refresh patches for the new release.
    - Add support for Linux 4.2 (LP: #1518958)
  * debian/rules:
    - Blacklist the amdgpu driver, so that fglrx can be loaded
      on the systems where the GPU is supported by amdgpu.
  * debian/substvars:
    - Add support for X ABI 19.

 -- Alberto Milone <email address hidden>  Fri, 27 Nov 2015 16:22:04 +0100
Superseded in xenial-release on 2016-01-13
Deleted in xenial-proposed on 2016-01-14 (Reason: moved to release)
fglrx-installer (2:15.201-0ubuntu6) xenial; urgency=medium

  * debian/dkms.conf.in,
    dkms/patches/buildfix_kernel_4.3.patch:
    - Add support for Linux 4.3.

 -- Alberto Milone <email address hidden>  Mon, 16 Nov 2015 16:40:35 +0100
Superseded in xenial-release on 2015-11-19
Deleted in xenial-proposed on 2015-11-20 (Reason: moved to release)
fglrx-installer (2:15.201-0ubuntu5) xenial; urgency=medium

  * debian/templates/control.in:
    - Add dependency on xserver-xorg-legacy.

 -- Alberto Milone <email address hidden>  Wed, 11 Nov 2015 17:26:41 +0100
Superseded in trusty-updates on 2016-02-19
Deleted in trusty-proposed on 2016-02-20 (Reason: moved to -updates)
fglrx-installer (2:15.200-0ubuntu0.6) trusty-proposed; urgency=medium

  * debian/fglrx.preinst.in:
    - Remove /etc/ati in the migration from the non -core packages
      even when the directory is not a symlink (LP: #1511301).
      Thanks to Kai-Heng Feng for the patch.

 -- Alberto Milone <email address hidden>  Mon, 09 Nov 2015 13:17:02 +0100
Obsolete in wily-updates on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to -updates)
fglrx-installer (2:15.201-0ubuntu2~15.10.2) wily-proposed; urgency=medium

  * debian/rules:
    - Blacklist the amdgpu driver, so that fglrx can be loaded
      on the systems where the GPU is supported by amdgpu (LP: #1510573).

Superseded in xenial-release on 2015-11-11
Deleted in xenial-proposed on 2015-11-13 (Reason: moved to release)
fglrx-installer (2:15.201-0ubuntu3) xenial; urgency=medium

  * debian/rules:
    - Blacklist the amdgpu driver, so that fglrx can be loaded
      on the systems where the GPU is supported by amdgpu (LP: #1510573).

 -- Alberto Milone <email address hidden>  Tue, 27 Oct 2015 15:45:21 +0100
Superseded in wily-proposed on 2015-10-28
fglrx-installer (2:15.201-0ubuntu2~15.10.1) wily-proposed; urgency=medium

  * debian/control.in,
    debian/dkms.conf.in,
    dkms/patches/force-gcc-to-4.9-instead-of-5.x.patch:
    - Add a dependency on gcc-4.9, and force fglrx to use gcc-4.9.
      This prevents fglrx from dying on initialisation (LP: #1493888).
      Credit for finding out the actual problem and for suggesting a
      workaround goes to David Burrows.
      Note: this is only a workaround, and it will be dropped as soon
      as a proper fix from upstream is available.

 -- Alberto Milone <email address hidden>  Mon, 26 Oct 2015 16:42:55 +0100
Superseded in xenial-release on 2015-10-27
Deleted in xenial-proposed on 2015-10-28 (Reason: moved to release)
fglrx-installer (2:15.201-0ubuntu2) xenial; urgency=medium

  * debian/control.in,
    debian/dkms.conf.in,
    dkms/patches/force-gcc-to-4.9-instead-of-5.x.patch:
    - Add a dependency on gcc-4.9, and force fglrx to use gcc-4.9.
      This prevents fglrx from dying on initialisation (LP: #1493888).
      Credit for finding out the actual problem and for suggesting a
      workaround goes to David Burrows.
      Note: this is only a workaround, and it will be dropped as soon
      as a proper fix from upstream is available.

 -- Alberto Milone <email address hidden>  Mon, 26 Oct 2015 16:42:55 +0100
Superseded in xenial-release on 2015-10-26
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
fglrx-installer (2:15.201-0ubuntu1) wily; urgency=medium

  * New upstream release (Catalyst 15.9):
    - Fixed issues:
      + [424450] Company of Heroes® 2 - Game crashes while running
        the performance test.
      + [424794] Middle-earth™: Shadow of Mordor - Corruption
        observed in game.
      + [424882] DIRT® Showdown - Corruption observed in game.
      + [425234] DIRT® Showdown - Game crashes after the loading
        screen.
      + [424802] DOTA™ 2 – Application hang observed while exiting
        the game.
      + [423471] Unable to switch desktop mode after installing AMD
        Catalyst™ driver.
      + [423735] Renaming Counter-Strike: GO and other Steam game
        binary improves performance.
  * debian/dkms/patches/buildfix_kernel_4.0.patch,
    debian/dkms/patches/buildfix_kernel_4.1.patch,
    debian/dkms/patches/buildfix_kernel_4.2.patch,
    debian/dkms/patches/buildfix_kernel_4.2.fpregs_active.patch,
    debian/dkms/patches/buildfix_kernel_4.2.copy_xregs_to_kernel.patch:
    - Refresh patches for the new release.

 -- Alberto Milone <email address hidden>  Thu, 17 Sep 2015 18:29:23 +0200
Superseded in wily-release on 2015-09-18
Deleted in wily-proposed on 2015-09-19 (Reason: moved to release)
fglrx-installer (2:15.200.1-0ubuntu4) wily; urgency=medium

  [ Tim Gardner ]
  * Two more patches for i386 Linux 4.2-rc8 support:
    debian/dkms/patches/buildfix_kernel_4.2.fpregs_active.patch
      Change the name of a structure tag from has_fpu to fpregs_active.
    debian/dkms/patches/buildfix_kernel_4.2.copy_xregs_to_kernel.patch
      Open code copy_xregs_to_kernel() with a debug reference to a GPL
      symbol 'alternatives_patched' commented out.

 -- Alberto Milone <email address hidden>  Wed, 26 Aug 2015 11:20:03 +0200
Obsolete in vivid-updates on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to -updates)
fglrx-installer (2:15.200-0ubuntu4.2) vivid-proposed; urgency=medium

  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_4.0.patch,
    debian/dkms/patches/buildfix_kernel_4.1.patch,
    debian/dkms/patches/buildfix_kernel_4.2.patch:
    - Add support for Linux 4.0, 4.1, 4.2.
    - Work around the GPL only pci_ignore_hotplug() in
      Linux 3.19.0-26 (LP: #1479913).

Superseded in trusty-updates on 2016-02-09
Deleted in trusty-proposed on 2016-02-10 (Reason: moved to -updates)
fglrx-installer (2:15.200-0ubuntu0.5) trusty-proposed; urgency=medium

  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_4.0.patch,
    debian/dkms/patches/buildfix_kernel_4.1.patch,
    debian/dkms/patches/buildfix_kernel_4.2.patch:
    - Add support for Linux 4.0, 4.1, 4.2.
    - Work around the GPL only pci_ignore_hotplug() in
      Linux 3.19.0-26 (LP: #1479913).

Superseded in wily-release on 2015-08-26
Deleted in wily-proposed on 2015-08-27 (Reason: moved to release)
fglrx-installer (2:15.200.1-0ubuntu3) wily; urgency=medium

  * debian/dkms/patches/buildfix_kernel_4.2.patch:
    - Refresh to fix a build failure on i386.
  * debian/dkms.conf.in,
    debian/dkms/patches/ignore-GCC-mismatch.patch:
    - Ignore GCC mismatch (LP: #1483695).

 -- Alberto Milone <email address hidden>  Wed, 12 Aug 2015 17:29:38 +0200
Superseded in wily-release on 2015-08-12
Deleted in wily-proposed on 2015-08-13 (Reason: moved to release)
fglrx-installer (2:15.200.1-0ubuntu2) wily; urgency=medium

  * debian/dkms/patches/buildfix_kernel_4.1.patch,
    debian/dkms/patches/buildfix_kernel_4.2.patch:
    - Refresh the patches for Linux 4.1.3.

 -- Alberto Milone <email address hidden>  Fri, 24 Jul 2015 17:21:59 +0200
Superseded in wily-release on 2015-07-24
Deleted in wily-proposed on 2015-07-25 (Reason: moved to release)
fglrx-installer (2:15.200.1-0ubuntu1) wily; urgency=medium

  * New upstream release (Catalyst 15.7):
    - AMD PowerXpress support for laptops equipped with Intel
      6th generation (Skylake) CPUs.
    - Linux Platform Atomics & SVM Fine Grain Buffer support
      for Carrizo APUs.
    - Multi-Device support for OpenCL 2.0.
  * debian/control.in,
    debian/fglrx-core.maintscript,
    debian/fglrx-core.install.in,
    debian/fglrx-core.postinst.in:
    - Migrate the files in /etc/ati from fglrx to fglrx-core.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_4.1.patch,
    debian/dkms/patches/buildfix_kernel_4.2.patch:
    - Add support for Linux 4.1.
    - Add support for Linux 4.2.

 -- Alberto Milone <email address hidden>  Tue, 14 Jul 2015 11:59:59 +0200
Superseded in vivid-proposed on 2015-08-18
fglrx-installer (2:15.200-0ubuntu4.1) vivid-proposed; urgency=medium

  * debian/rules:
    - Remove the extra "done"s from the for loops (LP: #1471661).
    - Apply the setgid bit and the execute bit to amd-console-helper.
  * debian/fglrx-amdcccle-updates.dirs.in:
    - Rename the template to debian/fglrx-amdcccle.dirs.in, so that
      the correct file can be regenerated.
  * debian/fglrx-amdcccle.preinst.in:
    - Make sure to remove amdcccle to ensure a smooth transition
      on dist-upgrade.

 -- Alberto Milone <email address hidden>  Mon, 06 Jul 2015 16:48:22 +0200
Superseded in trusty-proposed on 2015-08-18
fglrx-installer (2:15.200-0ubuntu0.4) trusty-proposed; urgency=medium

  * debian/rules:
    - Remove the extra "done"s from the for loops (LP: #1471661).
    - Apply the setgid bit and the execute bit to amd-console-helper.
  * debian/fglrx-amdcccle-updates.dirs.in:
    - Rename the template to debian/fglrx-amdcccle.dirs.in, so that
      the correct file can be regenerated.

 -- Alberto Milone <email address hidden>  Mon, 06 Jul 2015 09:15:06 +0200
Superseded in wily-release on 2015-07-16
Deleted in wily-proposed on 2015-07-17 (Reason: moved to release)
fglrx-installer (2:15.200-0ubuntu7) wily; urgency=medium

  * debian/fglrx-amdcccle-updates.dirs.in:
    - Rename the template to debian/fglrx-amdcccle.dirs.in, so that
      the correct file can be regenerated (LP: #1471661).

 -- Alberto Milone <email address hidden>  Mon, 06 Jul 2015 11:44:42 +0200
Superseded in wily-release on 2015-07-06
Deleted in wily-proposed on 2015-07-07 (Reason: moved to release)
fglrx-installer (2:15.200-0ubuntu6) wily; urgency=medium

  * debian/rules:
    - Remove duplicate "done"s.

 -- Alberto Milone <email address hidden>  Wed, 01 Jul 2015 12:39:22 +0200
Superseded in wily-release on 2015-07-01
Deleted in wily-proposed on 2015-07-02 (Reason: moved to release)
fglrx-installer (2:15.200-0ubuntu5) wily; urgency=medium

  *  debian/dkms.conf.in,
     debian/dkms/patches/buildfix_kernel_4.0.patch:
     - Add support for Linux 4.0.
  *  debian/rules:
     - Apply the setgid bit and the execute bit to amd-console-helper.

 -- Alberto Milone <email address hidden>  Fri, 05 Jun 2015 17:33:56 +0200
Superseded in trusty-updates on 2015-08-19
Deleted in trusty-proposed on 2015-08-20 (Reason: moved to -updates)
fglrx-installer (2:15.200-0ubuntu0.3) trusty-proposed; urgency=medium

  * debian/fglrx.preinst.in, debian/fglrx.postinst.in:
    - Work around regression when upgrading from releases that do
      not have the -core package. For some reason, the
      update-alternatives command would remove newly installed
      files when previous versions of the same files belonged to
      the previous alternative (LP: #1443016, LP: #1129409).

Superseded in trusty-proposed on 2015-05-06
fglrx-installer (2:15.200-0ubuntu0.2) trusty-proposed; urgency=medium

  * debian/control.in:
    - Allow the -core package to overwrite files that belong to
      fglrx. This prevents errors caused by the split into fglrx
      and fglrx-core (LP: #1443016, LP: #1129409).

Superseded in wily-release on 2015-06-05
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
fglrx-installer (2:15.200-0ubuntu4) vivid; urgency=medium

  * debian/control.in:
    - Allow the -core package to overwrite files that belong to
      fglrx. This prevents errors caused by the split into fglrx
      and fglrx-core when dist-upgrading (LP: #1443016).
 -- Alberto Milone <email address hidden>   Thu, 16 Apr 2015 12:08:46 +0200
Obsolete in utopic-updates on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to -updates)
fglrx-installer (2:14.201-0ubuntu2.1) utopic-proposed; urgency=medium

  * debian/control.in:
    - Drop conflicts/provides/replaces libopencl1 and
      provide opencl-icd (LP: #1129409).
 -- Alberto Milone <email address hidden>   Fri, 10 Apr 2015 11:41:45 +0200
Superseded in vivid-release on 2015-04-16
Deleted in vivid-proposed on 2015-04-17 (Reason: moved to release)
fglrx-installer (2:15.200-0ubuntu3) vivid; urgency=medium

  * debian/control.in:
    - Drop circular dependency between fglrx and fglrx-amdcccle.
 -- Alberto Milone <email address hidden>   Thu, 09 Apr 2015 10:08:05 +0200
Superseded in trusty-proposed on 2015-04-17
fglrx-installer (2:15.200-0ubuntu0.1) trusty-proposed; urgency=medium

  * New upstream release:
    - Add support for X ABI 19.
  * debian/control.in, debian/com.ubuntu.amdcccle.pkexec.policy,
    debian/rules, debian/fglrx.dirs.in,
    debian/fglrx.install.in,
    debian/fglrx.links.in,
    debian/fglrx.postinst.in,
    debian/fglrx.postrm.in,
    debian/fglrx.preinst.in,
    debian/fglrx.prerm.in,
    debian/fglrx.grub-gfxpayload.in,
    debian/overrides/fglrx.in,
    debian/overrides/fglrx-core.in,
    debian/overrides/fglrx-dev.in,
    debian/fglrx-amdcccle.dirs.in,
    debian/fglrx-amdcccle.install.in,
    debian/fglrx-core.dirs.in,
    debian/fglrx-core.links.in,
    debian/fglrx-core.postinst.in,
    debian/fglrx-core.postrm.in,
    debian/fglrx-core.preinst.in,
    debian/fglrx-core.prerm.in,
    debian/fglrx-core.postrm.in:
    - Drop conflicts/provides/replaces libopencl1 and provide
      opencl-icd (LP: #1129409).
    - Make amdcccle depend on polkit-1.
    - Use pkexec for amdcccle when running Unity.
    - Split the minimal driver into the -core package.
    - Depend on the "file" package.
  * debian/fglrx-dev.links.in:
    - Add links for libOpenCL libGL.so, libAMDXvBA, libXvBAW.
  * debian/substvars:
    - Add support for X ABI 18 and 19.
  * debian/patches/series, amdxdg-su-add-support-for-pkexec.patch:
    - Leave the patch disabled for future reference and easier
      backporting.
  * debian/patches/call-amdcccle-with-full-path.diff:
    - Pass amdxdg the full path.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.15.patch,
    debian/dkms/patches/buildfix_kernel_3.17.patch,
    debian/dkms/patches/buildfix_kernel_3.19.patch:
    - Add support for Linux 3.15-3.19.
    - Leave the patches disabled for future reference and easier
      backporting.
    - Correct a typo that caused an incorrect dkms.conf to be
      generated from the template.
  * debian/71-fglrx.rules:
    - Tag the device for logind.
 -- Alberto Milone <email address hidden>   Wed, 01 Apr 2015 16:49:52 +0200
Superseded in vivid-release on 2015-04-09
Deleted in vivid-proposed on 2015-04-10 (Reason: moved to release)
fglrx-installer (2:15.200-0ubuntu2) vivid; urgency=medium

  * debian/control.in:
    - Provide opencl-icd (LP: #1129409).
 -- Alberto Milone <email address hidden>   Thu, 19 Mar 2015 12:25:58 +0100
Superseded in vivid-release on 2015-03-19
Deleted in vivid-proposed on 2015-03-20 (Reason: moved to release)
fglrx-installer (2:15.200-0ubuntu1) vivid; urgency=medium

  * New upstream release:
    - Add support for X ABI 19.
  * debian/control.in:
    - Drop conflicts/provides/replaces libopencl1 (LP: #1129409).
  * debian/dkms.conf.in:
    - Drop all the patches.
  * debian/substvars:
    - Add support for X ABI 19.
  * debian/patches/series:
    - Drop amdxdg-su-add-support-for-pkexec.patch.
 -- Alberto Milone <email address hidden>   Wed, 11 Mar 2015 16:03:18 +0100
Superseded in vivid-release on 2015-03-11
Deleted in vivid-proposed on 2015-03-12 (Reason: moved to release)
fglrx-installer (2:14.501-0ubuntu1) vivid; urgency=medium

  * New upstream release:
    - OpenCL 2.0 support (requires 64-bit OS and compatible AMD
      Radeon™ R Series GPU).
    - VAAPI decoding support (H264, VC1, MPEG2, MPEG4).
    - Fixed unexpected pixmap's timestamp change with composite
      enabled that caused Linux Khronos CTS to randomly fail.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.19.patch:
    - Add support for Linux 3.19.
  * debian/patches/series:
    - Re-apply amdxdg-su-add-support-for-pkexec.patch.
 -- Alberto Milone <email address hidden>   Wed, 28 Jan 2015 16:12:21 +0100
Superseded in vivid-release on 2015-01-28
Deleted in vivid-proposed on 2015-01-29 (Reason: moved to release)
fglrx-installer (2:14.201-0ubuntu3) vivid; urgency=medium

  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.17.patch:
    - Add support for Linux 3.17 and 3.18.
 -- Alberto Milone <email address hidden>   Thu, 06 Nov 2014 18:33:22 +0100
Superseded in vivid-release on 2014-11-06
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
fglrx-installer (2:14.201-0ubuntu2) utopic; urgency=medium

  * debian/fglrx-core.postinst.in, debian/fglrx-core.postrm.in,
    debian/rules:
    - Avoid alternatives clash caused by the addition of the
      fglrx-core package.
 -- Alberto Milone <email address hidden>   Tue, 14 Oct 2014 10:57:02 +0200
Superseded in utopic-release on 2014-10-15
Deleted in utopic-proposed on 2014-10-16 (Reason: moved to release)
fglrx-installer (2:14.201-0ubuntu1) utopic; urgency=medium

  * New upstream release.
  * debian/control.in, debian/com.ubuntu.amdcccle.pkexec.policy:
    - Make amdcccle depend on polkit-1.
    - Use pkexec for amdcccle when running Unity.
  * debian/dkms.conf.in:
    - Drop all the patches.
  * debian/substvars:
    - Add support for xorg-video-abi-18 (LP: #1359769).
  * debian/71-fglrx.rules:
    - Tag the device for logind (LP: #1365336).
 -- Alberto Milone <email address hidden>   Tue, 09 Sep 2014 17:48:30 +0200
Published in precise-updates on 2014-10-21
Deleted in precise-proposed (Reason: moved to -updates)
fglrx-installer (2:13.350.1-0ubuntu0.0.1) precise-proposed; urgency=medium

  * debian/control, debian/fglrx-amdcccle.install.in:
    - Use pkexec for amdcccle when running Unity, and add a
      dependency on polkit-1.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.15.patch,
    debian/dkms/patches/buildfix_kernel_3.14.patch:
    - Add support for Linux 3.14 (LP: #1355041).
    - Add support for Linux 3.15.
  * debian/patches/call-amdcccle-with-full-path.diff:
    - Pass amdxdg the full path.
  * debian/substvars:
    - Add support for X ABI 15 and for lts-trusty.
 -- Alberto Milone <email address hidden>   Fri, 05 Sep 2014 09:50:26 +0200
Superseded in utopic-release on 2014-09-10
Deleted in utopic-proposed on 2014-09-11 (Reason: moved to release)
fglrx-installer (2:13.350.1-0ubuntu3) utopic; urgency=medium

  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.15.patch:
    - Add support for Linux 3.15.
  * debian/patches/call-amdcccle-with-full-path.diff:
    - Pass amdxdg the full path.
 -- Alberto Milone <email address hidden>   Fri, 27 Jun 2014 16:39:59 +0200
Superseded in utopic-release on 2014-06-27
Published in trusty-release on 2014-04-07
Deleted in trusty-proposed (Reason: moved to release)
fglrx-installer (2:13.350.1-0ubuntu2) trusty; urgency=medium

  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.14.patch:
    - Add support for Linux 3.14.
 -- Alberto Milone <email address hidden>   Fri, 04 Apr 2014 16:45:37 +0200
Superseded in trusty-release on 2014-04-07
Deleted in trusty-proposed on 2014-04-08 (Reason: moved to release)
fglrx-installer (2:13.350.1-0ubuntu1) trusty; urgency=medium

  * New upstream release (14.3):
    - [394848] - Xorg crashed 160 playing AVI video file in VLC
      player or Parole player (LP: #1279412).
    - [394705] - "Nexuiz - Demo3" Ubuntu performance lower than
      Redhat.
 -- Alberto Milone <email address hidden>   Wed, 19 Mar 2014 11:25:21 +0100
Superseded in trusty-release on 2014-03-19
Deleted in trusty-proposed on 2014-03-20 (Reason: moved to release)
fglrx-installer (2:13.350-0ubuntu1) trusty; urgency=low

  * debian/dkms.conf.in:
    - Drop all the patches.
  * debian/substvars:
    - Add support for X ABI 15.
  * New upstream release (14.1):
    - [386897]: System hang on resume from S4 with OpenGL screen
      saver running.
    - [387678]: Backtrace occurs when kill X.
    - [387664]: Failed to start X without kernel module loaded.
    - [378620]: OpenCL test failure in CrossFire Mode.
    - [386945]: piglit test "spec/ARB_copy_buffer/overlap" failed.
    - [386710]: piglit test "spec/ARB_draw_buffers_blend" failed.
    - [386818]: piglit test "spec/OpenGL 2.0/depth-tex-modes-glsl"
      failed.
    - [386941]: piglit test "spec/ARB_blend_func_extended" failed.
    - [386903]: piglit test "spec/OpenGL 3.0/gl-3.0-required-sized-
      texture-formats" failed.
    - [386840]: Viewport goes blank when mouse cursor leaves when run
      Houdini on Ubuntu.
    - [387596]: piglit test "spec/ARB_framebuffer_object (fbo-
      scissor-blit)" failed.
    - [389174]: Failed to get fan speed on Bonaire card.
    - [388110]: Intermittent flashing problem when running at
      2560x1600.
    - [372656]: Crash when resizing Konsole.
    - [388325]: Brightness cannot be adjusted on Ubuntu 12.04 LTS.
    - [388330]: piglit test "spec/ARB_framebuffer_object (fbo-blit-
      stretch)" failed.
    - [385457]: Blue/white screen after using Google-chrome to run
      fishietank.
    - [388500]: piglit test "spec/EXT_texture_integer" failed.
    - [388802]: piglit test "spec/ARB_map_buffer_alignment" failed.
    - [386396]: piglit test "spec/ARB_depth_buffer_float/fbo-
      depthstencil-drawpixels" failed.
    - [389431]: Screens are distorted when connecting an external
      monitor on some Haswell platforms.
    - [389530]: Blank screen/crash observed while running unigine
      heaven benchmark in windowed mode.
    - [387124]: OpenCL performance drop observed on Hawaii compared
      to Tahiti XT.
    - [386940]: piglit test "spec/EXT_texture_sRGB" failed.
    - [392137]: [SteamOS] Failed to return to desktop from steam.
    - [392015]: [SteamOS] Screen is locked when changing user.
    - [392014]: [SteamOS] Failed to login Steam sometimes.
 -- Alberto Milone <email address hidden>   Tue, 04 Feb 2014 12:49:07 +0100
Superseded in trusty-release on 2014-02-04
Deleted in trusty-proposed on 2014-02-05 (Reason: moved to release)
fglrx-installer (2:13.101-0ubuntu6) trusty; urgency=low

  * debian/fglrx.dirs.in:
    - Add /usr/share/applications (this helps in chroots).
  * debian/dkms.conf.in, debian/dkms/patches/buildfix_kernel_3.13.patch:
    - Apply the procfs patch to kernels up to 3.14
    - Add support for Linux 3.13.
 -- Alberto Milone <email address hidden>   Wed, 08 Jan 2014 16:32:39 +0100
Superseded in precise-updates on 2014-10-21
Deleted in precise-proposed on 2014-10-22 (Reason: moved to -updates)
fglrx-installer (2:13.101-0ubuntu0.0.1) precise-proposed; urgency=low

  * New upstream release:
    - Add support for AMD A10, A8, A6, and A4 Series APUs.
    - Add GLX_EXT_buffer_age extension support.
    - Add Xserver 1.14 Support.
    - [371937] Fix black screen while entering Team
      Fortress 2  under cinnamon desktop environment.
    - [366812] Fix tearing for some OpenGL applications
      with VSYNC on or off.
    - [373575] Fix taskbar missing after UVD playback
      on Ubuntu 12.04.
    - [370955] Fix corruption in Team Fortress 2 when
      running Dustbowl map.
    - [377199] Fix the error for APL initialization
      failure.
    - [378086] Fix screen corruption when kill X on
      Ubuntu 13.04.
    - [374657] Fix some WebGL conformance test
      failures.
    - [377379] Fix the regression of performance drop
      with XBMC for UVD playback.
  * debian/substvars:
    - Add support for X ABI up to 14 and xservers up to
      xserver-xorg-core-lts-saucy.
  * debian/rules:
    - Sign the driver to remove the watermark.
  * debian/dkms.conf.in, buildfix_kernel_3.12.patch:
    - Add support for Linux 3.12.
    - Add proper support for Linux 3.11 (LP: #1262238).
 -- Alberto Milone <email address hidden>   Wed, 18 Dec 2013 17:50:31 +0100
Superseded in trusty-release on 2014-01-08
Deleted in trusty-proposed on 2014-01-09 (Reason: moved to release)
fglrx-installer (2:13.101-0ubuntu5) trusty; urgency=low

  * Revert previous upload and introduce the patch used in the
    -updates flavour using dkms instead of quilt.
 -- Alberto Milone <email address hidden>   Wed, 18 Dec 2013 17:16:24 +0100
Superseded in trusty-release on 2013-12-18
Deleted in trusty-proposed on 2013-12-19 (Reason: moved to release)
fglrx-installer (2:13.101-0ubuntu4) trusty; urgency=low

  * Fix compile issue for Linux 3.12
 -- Tim Gardner <email address hidden>   Wed, 30 Oct 2013 18:18:59 +0000
Superseded in trusty-release on 2013-10-31
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
fglrx-installer (2:13.101-0ubuntu3) saucy; urgency=low

  * debian/dkms.conf.in:
    - Add support for Linux 3.11.
 -- Alberto Milone <email address hidden>   Tue, 06 Aug 2013 14:08:43 +0200
Superseded in saucy-release on 2013-08-06
Deleted in saucy-proposed on 2013-08-07 (Reason: moved to release)
fglrx-installer (2:13.101-0ubuntu2) saucy; urgency=low

  * debian/fglrx.dirs.in:
    - Do not install the xorg modules directory.
 -- Alberto Milone <email address hidden>   Thu, 27 Jun 2013 14:39:29 +0200
Superseded in saucy-release on 2013-06-27
Deleted in saucy-proposed on 2013-06-28 (Reason: moved to release)
fglrx-installer (2:13.101-0ubuntu1) saucy; urgency=low

  * New upstream release:
    - Add support for AMD A10, A8, A6, and A4 Series APUs.
    - Add GLX_EXT_buffer_age extension support.
    - Add Xserver 1.14 Support.
    - [371937] Fix black screen while entering Team
      Fortress 2  under cinnamon desktop environment.
    - [366812] Fix tearing for some OpenGL applications
      with VSYNC on or off.
    - [373575] Fix taskbar missing after UVD playback
      on Ubuntu 12.04.
    - [370955] Fix corruption in Team Fortress 2 when
      running Dustbowl map.
    - [377199] Fix the error for APL initialization
      failure.
    - [378086] Fix screen corruption when kill X on
      Ubuntu 13.04.
    - [374657] Fix some WebGL conformance test
      failures.
    - [377379] Fix the regression of performance drop
      with XBMC for UVD playback.
  * debian/dkms.conf.in,
    debian/dkms/patches/replace_old_procfs_calls.patch:
    - Add support for Linux 3.10.
  * debian/substvars:
    - Add support for X ABI 14.
  * debian/rules:
    - Sign the driver to remove the watermark.
 -- Alberto Milone <email address hidden>   Fri, 21 Jun 2013 12:37:08 +0200
Superseded in saucy-release on 2013-06-21
Deleted in saucy-proposed on 2013-06-22 (Reason: moved to release)
fglrx-installer (2:9.010-0ubuntu4) saucy; urgency=low

  * debian/dkms.conf.in:
    - Add support for Linux 3.9 (LP: #1185285).
 -- Alberto Milone <email address hidden>   Fri, 14 Jun 2013 17:02:58 +0200
Superseded in saucy-release on 2013-06-14
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
fglrx-installer (2:9.010-0ubuntu3) raring; urgency=low

  * debian/control:
    - Conflict/replace/provide xorg-driver-binary. Also
      get rid of all the other entries which have no
      use now that xorg-driver-binary is in place.
 -- Alberto Milone <email address hidden>   Mon, 15 Apr 2013 13:19:40 +0200
Superseded in raring-release on 2013-04-19
Deleted in raring-proposed on 2013-04-21 (Reason: moved to release)
fglrx-installer (2:9.010-0ubuntu2) raring; urgency=low

  * debian/control:
    - Drop all the dependencies on the linux-headers.
    - Drop redundant dependency on the xserver.
 -- Alberto Milone <email address hidden>   Thu, 17 Jan 2013 17:46:04 +0100
Superseded in raring-release on 2013-01-17
Deleted in raring-proposed on 2013-01-18 (Reason: moved to release)
fglrx-installer (2:9.010-0ubuntu1) raring; urgency=low

  * New upstream release.
  * debian/dkms.conf.in,
    replace-archdata.acpi_handle-with-acpi_node.handle.patch:
    - Add support for Linux 3.8 (LP: #1095755).
      Thanks to Robert Hooker for the patch.
  * debian/substvars:
    - Remove versioned dependency on xserver-xorg-core.
  * debian/10fglrx.in, debian/rules:
    - Fix paths which prevented OpenGL operations on hybrid systems
      on amd64 (LP: #1068661). Thanks to Nick Andrik for the patch.
 -- Alberto Milone <email address hidden>   Tue, 08 Jan 2013 16:12:09 +0100
Superseded in raring-release on 2013-01-08
Deleted in raring-proposed on 2013-01-09 (Reason: moved to release)
fglrx-installer (2:9.000-0ubuntu4) raring; urgency=low

  * debian/control:
    - Conflict/replace/provide new nvidia flavours.
    - Depend on other flavours of kernel headers.
  * debian/dkms.conf.in,
    replace-VM_RESERVED-with-VM_DONTEXPAND-and-VM_DONTDU.patch:
    - Add support for Linux 3.7 (LP: #1075937).
  * debian/10fglrx.in:
    - Fix path for powerxpress (LP: #1068661). Thanks
      to Nick Andrik and Lu Xingzhe for suggesting
      the fix.

  [ Benjamin Kerensa ]
  * debian/control:
    - Add ${misc:Depends} depends as needed.
 -- Alberto Milone <email address hidden>   Fri, 07 Dec 2012 15:16:01 +0100
Superseded in raring-release on 2012-12-07
Obsolete in quantal-release on 2015-04-24
fglrx-installer (2:9.000-0ubuntu3) quantal; urgency=low

  * debian/rules:
    - Correct the path to Qt libraries on i386.
 -- Alberto Milone <email address hidden>   Sat, 29 Sep 2012 20:47:10 +0200
Superseded in quantal-release on 2012-09-29
fglrx-installer (2:9.000-0ubuntu2) quantal; urgency=low

  * debian/rules:
    - Make sure that all binaries in /usr/bin are executable.
  * Switch to dpkg-source 3.0 (quilt) format.
 -- Alberto Milone <email address hidden>   Thu, 27 Sep 2012 15:22:36 +0200
Superseded in quantal-release on 2012-09-28
fglrx-installer (2:9.000-0ubuntu1) quantal; urgency=low

  * New upstream release (LP: #1032672).
  * debian/dkms.conf.in:
    - Do not apply any kernel patch.
  * debian/rules:
    - Make it possible to set the xserver ABIs in debian/substvars.
  * Merge fixes from the upstream installer:
    - Fix openCL issues running x86 binaries on x86_64.
    - Make sure that dh_shlibdeps doesn't complain about missing qt
      libraries.
 -- Alberto Milone <email address hidden>   Wed, 26 Sep 2012 16:40:59 +0200
Superseded in quantal-release on 2012-09-27
fglrx-installer (2:8.982-0ubuntu1) quantal; urgency=low

  * New upstream release (LP: #1039397).
  * debian/control:
    - Conflict with/replace/provide nvidia and fglrx. This will make
      sure that other binary drivers cannot be installed at the same
      time. This is required by the new restricted drivers UI.
  * debian/rules:
    - Make sure to call the "serverabi" phony target.
    - Hardcode the X ABI to 11.
 -- Alberto Milone <email address hidden>   Mon, 10 Sep 2012 14:00:35 +0200
Superseded in precise-updates on 2014-02-03
Deleted in precise-proposed on 2014-02-04 (Reason: moved to -updates)
fglrx-installer (2:8.960-0ubuntu1.1) precise-proposed; urgency=low

  [ Alberto Milone ]
  * fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch:
    - Fix build issue on i386 where TS_USEDFPU is no longer
      available (LP: #1017822).
  * replace-do_mmap-and-do_munmap-with-vm_mmap-and-vm_mu.patch,
    replace-for_each_cpu_mask-with-for_each_possible_cpu.patch:
    - Add support for Linux 3.5.

  [ Stéphane Graber ]
  * Only purge the package if nothing else provides fglrx
    (LP: #949641).
 -- Alberto Milone <email address hidden>   Wed, 01 Aug 2012 19:11:19 +0200
Superseded in quantal-release on 2012-09-10
fglrx-installer (2:8.960-0ubuntu6) quantal; urgency=low

  [ Stéphane Graber ]
  * Only purge the package if nothing else provides fglrx
    (LP: #949641).
 -- Alberto Milone <email address hidden>   Wed, 01 Aug 2012 12:04:39 +0200
Superseded in quantal-release on 2012-08-01
fglrx-installer (2:8.960-0ubuntu5) quantal; urgency=low

  * debian/control:
    - Make sure that ${xviddriver:Depends} is actually replaced
      with its value.
  * debian/rules:
    - Make sure to call the serverabi target.
 -- Alberto Milone <email address hidden>   Tue, 03 Jul 2012 18:02:31 +0200
Superseded in quantal-release on 2012-07-03
fglrx-installer (2:8.960-0ubuntu4) quantal; urgency=low

  * Rename build to build-arch and make build depend on build-arch.
 -- Adam Conrad <email address hidden>   Mon, 02 Jul 2012 17:32:12 -0600
Superseded in quantal-release on 2012-07-03
fglrx-installer (2:8.960-0ubuntu3) quantal; urgency=low

  * fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch:
    - Update patch so as to make sure to include
      asm/fpu-internal.h (LP: #1017822).
 -- Alberto Milone <email address hidden>   Sat, 30 Jun 2012 11:33:04 +0200
Superseded in quantal-release on 2012-06-30
fglrx-installer (2:8.960-0ubuntu2) quantal; urgency=low

  * replace-do_mmap-and-do_munmap-with-vm_mmap-and-vm_mu.patch,
    replace-for_each_cpu_mask-with-for_each_possible_cpu.patch:
    - Add support for Linux 3.5.
 -- Alberto Milone <email address hidden>   Sun, 17 Jun 2012 17:20:49 +0200
Superseded in quantal-release on 2012-06-18
Published in precise-release on 2012-03-23
fglrx-installer (2:8.960-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Fix issue with XVideo in the new xserver (LP: #921384).
 -- Alberto Milone <email address hidden>   Thu, 22 Mar 2012 16:01:03 +0100
Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
fglrx-installer (2:8.723.1-0ubuntu6) lucid-proposed; urgency=low

  * debian/fglrx.postrm:
    - Do not remove diversions. Those diversions were likely installed by older
      releases of the driver (since we don't use diversions any more). Any
      diversion should be removed in fglrx.preinst, as it's exactly where we
      remove all other diversions (LP: #566437).
  * debian/fglrx.prerm:
    - Call dpkg-trigger with --by-package=$PACKAGE_NAME.
 -- Alberto Milone <email address hidden>   Fri, 20 Jan 2012 12:01:17 +0100
Superseded in precise-release on 2012-03-23
fglrx-installer (2:8.911-0ubuntu2) precise; urgency=low

  * Rebuild to pick up Xserver 1.11 dependencies
 -- Christopher James Halse Rogers <email address hidden>   Thu, 19 Jan 2012 10:49:59 +1100
Superseded in precise-release on 2012-01-24
fglrx-installer (2:8.911-0ubuntu1) precise; urgency=low

  * New upstream release (11-11).
  * debian/fglrx.install.in, debian/fglrx.dirs.in,
    debian/fglrx.links.in ,debian/fglrx.postinst.in,
    debian/rules:
    - Install OpenCL libraries.
    - Make sure to use the multiarch path to the Mesa libraries.
      This (partially) solves an issue with PXpress which couldn't
      find the Mesa libraries (LP: #813809).
 -- Alberto Milone <email address hidden>   Fri, 25 Nov 2011 15:11:02 +0100
Superseded in precise-release on 2011-11-25
fglrx-installer (2:8.902-0ubuntu1) precise; urgency=low

  * New upstream release (11.10).
  * debian/rules:
    - Make sure to always use the right .modalias file
      for the flavour.
  * debian/dkms.conf.in:
    - Drop the non-functional OBSOLETE_BY variable.
 -- Alberto Milone <email address hidden>   Fri, 11 Nov 2011 16:09:29 +0100
Obsolete in oneiric-updates on 2015-04-24
Deleted in oneiric-proposed on 2015-04-26 (Reason: moved to -updates)
fglrx-installer (2:8.881-0ubuntu4.1) oneiric-proposed; urgency=low

  * debian/fglrx.prerm.in:
    - Make sure to remove the correct alternatives on package
      removal (LP: #855943).
    - Call ldconfig with the NOTRIGGER environment variable
      as in the postinst.
 -- Alberto Milone <email address hidden>   Tue, 25 Oct 2011 18:18:36 +0200
Superseded in precise-release on 2011-11-11
fglrx-installer (2:8.881-0ubuntu5) precise; urgency=low

  * debian/fglrx.prerm.in:
    - Make sure to remove the correct alternatives on package
      removal (LP: #855943).
    - Call ldconfig with the LDCONFIG_NOTRIGGER=y environment
      variable, as in the postinst script.
 -- Alberto Milone <email address hidden>   Tue, 25 Oct 2011 17:52:12 +0200
Superseded in precise-release on 2011-10-26
Obsolete in oneiric-release on 2015-04-24
fglrx-installer (2:8.881-0ubuntu4) oneiric; urgency=low

  * Re-enable grub fb and drop the initramfs hook in favour of
    "alias radeon/lbm_radeon off" (LP: #864149).
 -- Alberto Milone <email address hidden>   Mon, 10 Oct 2011 20:29:27 +0200
Superseded in oneiric-release on 2011-10-10
fglrx-installer (2:8.881-0ubuntu3) oneiric; urgency=low

  * debian/rules, debian/modaliases/fglrx_supported:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all AMD cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden>   Fri, 30 Sep 2011 15:36:00 +0200
Superseded in oneiric-release on 2011-09-30
fglrx-installer (2:8.881-0ubuntu2) oneiric; urgency=low

  * debian/rules:
    - Add an initramfs hook to make sure that nothing else loads
      open graphics drivers in the initramfs (LP: #839524).
 -- Alberto Milone <email address hidden>   Thu, 08 Sep 2011 15:12:24 +0200
Superseded in oneiric-release on 2011-09-08
fglrx-installer (2:8.881-0ubuntu1) oneiric; urgency=low

  * New upstream release 8.881 (11-8).
  * debian/rules:
    - Make sure to use LICENSE instead of ATI_LICENSE, as it
      has been renamed by AMD.
    - Add a hack for pbuild which would otherwise fail to call
      execstack when trying to build.
    - Rename the grub_fb_blacklist link, so that it has a name
      shared with all the other proprietary drivers.
 -- Alberto Milone <email address hidden>   Wed, 24 Aug 2011 12:08:49 +0200
175 of 155 results